Dlaczego warto zaktualizować Debiana do wersji testowej

Pomoc dotycząca instalacji systemu
velmafia
Member
Posty: 1820
Rejestracja: 01 września 2006, 00:56
Lokalizacja: Wrocek

Dlaczego warto zaktualizować Debiana do wersji testowej

Post autor: velmafia » 08 stycznia 2007, 21:52

Witam

Chciałem dzisiaj zrobić małe rozważanie, a temat różnych wersji Debiana, a konkretnie: chcę pokazać dlaczego zachęcam do zmiany wersji stabilnej na testową (na komputerze domowym).
Po tych rozważaniach, napiszę krótko jak krok po kroku zaktualizować Debiana do wersji testowej.

----------==========----------

Opisu poszczególnych wersji Debiana:

W Debianie wyróżniamy 3 wersje, stabilną, testową, oraz niestabilną.

Wersja niestabilna - zawsze nosi nazwę Sid,
Jest to wersja, do której trafiają wszystkie nowo powstałe pakiety i to tutaj rozpoczyna się rozwój dystrybucji, tutaj są wprowadzane zarówno małe poprawki tak jak i duże zmiany, tak więc znajdują się tu pakiety, które mogą (lecz nie muszą) zawierać jakieś błędny. Jednak w rzeczywistości pakiety nie stwarzają dużych problemów, ale nie masz pewności że nie będzie tych problemów, stąd nazwa niestabilna, jeśli po upływie jakiegoś czasu w pakiecie nie zostaną wykryte poważniejsze błędy, to pakiet zostaje przeniesiony do wersji testowej.

Wersja testowa - aktualnie jej nazwa brzmi Squeeze, tu trafiają pakiety z wersji niestabilnej, więc są już dość przetestowane i nie stwarzają żadnych poważniejszych problemów, pakiety są dość aktualne, a co jakiś czas (jak dotychczas 1,5 - 3 lata) wersja ta zostaje zamrożona, co oznacza że zostaje wstrzymane przenoszenie pakietów które normalnie by trafiły tutaj z wersji niestabilnej. Po zamrożeniu cała wersja przechodzi gruntowne testy, pod względem stabilności i integralności, (dlatego nie trafiają tu pakiety z Sida, bo nowe pakiety mogą zachwiać stabilność) i po zaliczeniu tych testów zamrożona wersja testowa staje się nową wersją stabilną, i znowu wersja testowa zostaje otwarta.

Wersja stabilna - aktualnie jej nazwa brzmi Lenny, ta wersja nie jest już rozwijana (jedynie są dodawane poprawki dotyczące bezpieczeństwa), ponieważ jej rozwój mógłby osłabić stabilność. W związku z tym wersja ta jest prawdę powiedziawszy przestarzała, ale za to bardzo stabilna i dlatego nadaje się idealnie na serwery, gdzie najważniejsza jest stabilność.
Jeśli zależy Ci na wersji stabilnej, ale chcesz mieć nowsze pakiety, możesz skorzystać z backportów,

Kod: Zaznacz cały

http://www.backports.org/

Nazwy wersji Debiana
Wikipedia pisze:Kolejne wersje Debiana, od początku projektu noszą nazwy będące imionami bohaterów filmu Toy Story.

* buzz - Debian 1.1 - od Buzza Lightyeara - kosmicznego marine
* rex - Debian 1.2 - od tyranozaura
* bo - Debian 1.3 - od Bo Peep, pasterki, która opiekowała się owcami
* hamm - Debian 2.0 - od świnki-skarbonki
* slink - Debian 2.1 - od zabawkowego, rozciągliwego psa (Slinky Dog)
* potato - Debian 2.2 - od Pana Ziemniaka (Mr. Potato)
* woody - Debian 3.0 - od kowboja
* sarge - Debian 3.1 - od sierżanta małych, zielonych, plastikowych żołnierzyków
* etch - Debian 4.0 - od zabawkowej tablicy do rysowania (Etch-a-Sketch)
* lenny - Debian (??) - od lornetki (Lenny the Binoculars)
* sid - od chłopca z sąsiedztwa, który psuł zabawki

Jak sprawdzić jaką mam wersje Debiana?
w konsoli wpisujesz:

Kod: Zaznacz cały

cat /etc/debian_version
i otrzymany wynik porównujesz z listą powyżej.
Przy podawaniu komuś swojej wersji Debiana preferowane są nazwy słowne.

-----=====-----

Dodatkowe wersje/repozytoria:

Można też wspomnieć o wersji eksperymentalnej, która nie jest oficjalną gałęzią Debiana, ale jest zgodna z nim:

Wersja eksperymentalna - jest to wersja, do której trafiają niektóre nowo powstałe pakiety, cechujące się wysoce eksperymentalnym/niebezpiecznym charakterem: eksperymenty niektórych deweloperów, szczególne wersje beta, cvs, więc mogą powodować błędy (czasami poważne), jeśli dopiero zaczynasz przygodę z Debianem, odradzam Ci instalowanie pakietów z tej wersji, jeśli natomiast już znasz się coś na Debianie (i czujesz taką potrzebę) to możesz sobie pozwolić na instalacje potrzebnych pakietów z tej wersji, ale pamiętaj że mogą być problemy (wtedy się najwięcej uczysz).
Jeżeli pakiet nie stwarza poważnych problemów typu: wykładanie się systemu, uszkadzanie innych pakietów itp. to zostaje przeniesiony do wersji niestabilnej.

Inne sposoby zdobywania pakietów - "egzotyczne" pakiety (lub wersje cvs/beta) można też znaleźć przy pomocy apt-get.org lub (co może bezpieczniejsze) w "przydomowych" repozytoriach deweloperów Debiana, na people.debian.org.


Mieszanie Dystrybucji:

Łączenie dystrybucji - poza tym najbardziej "hardcorowa" konfiguracja to używanie łączonych dystrybucji. Ale to może przysporzyć więcej pracy niż korzyści. W miarę rozsądnym rozwiązaniem wydaje się tutaj testowa/niestabilna/eksperymentalna/cokolwiek. Generalnie im bardziej dziwna tym trudniej o stabilność co jest zrozumiałe aczkolwiek w teorii wszystko powinno "ujść".
Mieszanie dystrybucji stabilnej z testową/niestabilną dość często powoduje problemy, z którymi początkujący nie potrafią sobie poradzić (bo się poddają), natomiast mieszanie wersji testowej/niestabilnej nie stwarza aż takich problemów (właściwie żadnych), ponieważ obie wersje są w ciągłym rozwoju i dzieli je około 2 tygodni - miesiąca w aktualności pakietów (przeważnie, zdarzają się wyjątki), natomiast wersję stabilną i testową dzieli parę miesięcy - kilka lat (jak dotychczas wersje stabilne były wydawane co 3 lata, ale teraz ma się to zmienić na około 1,5 roku). Tak więc, jeśli jesteś początkujący, to nie łącz dystrybucji stabilnej z testową/niestabilną, lepiej od razu przejdź na wersję testową, będziesz miał mniej problemów.

----------==========----------

Argumenty za aktualizacją do wersji testowej:

Aktualnie korzystam z wersji niestabilnej, wcześniej korzystałem z wersji testowej i mogę powiedzieć, że wersje te są bardzo stabilne i nie stwarzają większych problemów (mniejszych też nie). Więc nie musisz się martwić o stabilność, lub problemy, bo po prostu ich nie ma (deweloperzy doskonale się spisują).

A o to moje argumenty przemawiające za aktualizacją do wersji testowej:
--- Wersja stabilna stoi w miejscu, nie masz dostępu do nowych programów, a kombinowanie z ich instalacją na wersji stabilnej stwarza więcej problemów, niż aktualizacja Debiana do wersji testowej i problemy (a właściwie ich brak), które wynikają z używania wersji testowej.
--- Przy instalacji/aktualizacji wersji testowej od razu mamy dostęp do nowych jąder, co często rozwiązuje problemy ze sprzętem, bo obsługa większości sprzętu znajduje się w jądrze, a jeśli komputer jest nowy, a wersja stabilna jest starsza niż Twój komputer, to jądro najprawdopodobniej nie ma wkompilowanej obsługi Twojego (nowego) sprzętu, możesz zaktualizować wprawdzie samo jądro, a przy okazji zależności do nowego jądra co spowoduje mieszanie dystrybucji..., a wystarczy tylko zaktualizować Debiana i spokojnie zainstalować nowe jajo.
--- Oprócz nowszych programów, w wersji testowej są też wprowadzone nowsze rozwiązania, co jedynie udoskonala Twój system.
--- "Nowsze nie zawsze znaczy lepsze" ale w wypadku Debiana to się nie sprawdza.
--- Paczki w wersji testowej często rozwiązują problemy, na które nie znano jeszcze rozwiązania podczas premiery wersji stabilnej.

----------==========----------

Opis aktualizacji:

A oto krótki opis mówiący jak zaktualizować wersję stabilną do testowej:

Najpierw dodajemy/(zamieniamy) do pliku

Kod: Zaznacz cały

/etc/apt/sources.list
adresy do repozytoriów wersji testowej,
oficjalne repozytoria wersji testowej są takie:

Kod: Zaznacz cały

deb [url]http://ftp.pl.debian.org/debian/[/url] testing main non-free contrib 
deb-src [url]http://ftp.pl.debian.org/debian/[/url] testing main non-free contrib 
deb [url]http://security.debian.org/debian-security/[/url] testing/updates main contrib non-free
Więcej adresów repozytorium znajdziesz tutaj:
Lista repozytoriów (zawartość pliku /etc/apt/sources.list)
(wybieramy oczywiście wpisy z kategorii wersja testowa).
Jeśli korzystasz teraz z jakiś jeszcze innych repozytoriów, do dobrze by było dodać wersję testową dla tych repozytoriów.

Po dodaniu adresów repozytoriów do wyżej podanego pliku, musimy uaktualnić dane dotyczące dostępnych pakietów, robimy to poleceniem:

Kod: Zaznacz cały

aptitude update
Następnie aktualizujemy cały system poleceniem:

Kod: Zaznacz cały

aptitude -P dist-upgrade
parametr "-P" powoduje wypisanie na ekranie informacji na temat tego co zostanie zaktualizowane, potwierdzamy i w tym momencie zostają pobierane pakiety które potrzebne są do aktualizacji, a zaraz po pobraniu system zostanie zaktualizowany.
Jeżeli wśród listy pakietów do zaktualizowania nie ma jądra (linux-image-<nr-wersji>), to po zaktualizowaniu reszty systemu możemy zaktualizować je sami, w tym celu najpierw wyszukujemy aktualną (najnowszą) wersję jądra w wersji testing (w momencie gdy to piszę najnowszą wersja jądra w wersji testowej jest linux-image-2.6.18-4, za pomocą polecenia:

Kod: Zaznacz cały

apt-cache search linux-image
Z dostępnych wyników wybieramy najnowsze jądro pod swoją architekturę (najprawdopodobniej będzie to architektura 486/686, jeśli inna, to z pewnością będziesz wiedział jaką masz). Po wybraniu jajka przystępujemy do jego instalacji:

Kod: Zaznacz cały

aptitude install linux-image-<wersja>-<architektura>
Teraz już nowe jajko się samodzielnie zainstaluje.

----====----

Jeżeli aktualizujesz system z wersji oldstable (Etch):
to od wersji Etch jest już xorg, warto po aktualizacji systemu skonfigurować xorga, a robimy to tym poleceniem:

Kod: Zaznacz cały

dpkg-reconfigure xserver-xorg
szczegóły dotyczące konfiguracji znajdują się tutaj:
Instalacja serwera X - Xorg

Jeszcze tylko ponowne uruchomienie komputera i gotowe,
teraz może czuć się posiadaczem testowej wersji Debiana.

----------==========----------

aloha

--------------------------------------------------------------------------------------------
Powerade by GNU/Linux, and some fun
Artykuł na licencji: GNU Free Documentation License

KarolOssowski
Posty: 93
Rejestracja: 25 czerwca 2006, 19:59
Lokalizacja: Warszawa

Post autor: KarolOssowski » 09 stycznia 2007, 22:06

[quote="velmafia"]
w Debianie wyróżniamy 4 wersje, stabilną, testową, niestabilną, oraz eksperymentalną.

wersja eksperymentalna &#8211]

dystrybucja 'epxperimental' nie jest jedną z gałęzi Debiana. zawiera tylko garstkę pakietów, które są "niebezpieczne dla stabilności całego systemu"/eksperymenty poszczególnych deweloperów/szczególne wersje beta/cvs. nowe pakiety trafiają generalnie od razu do 'unstable'.

imo tzw. ZU nie musi mieć o niej pojęcia. takie "egzotyczne" pakiety (lub wersje cvs/beta) można też znaleźć przy pomocy apt-get.org lub (co może bezpieczniejsze) w "przydomowych" repo deweloperów debiana, na people.debian.org

http://debian.linux.org.pl/zrobione/dev ... tml#s4.6.4

za to przydałoby się info o seciurity.debian.org co jest wręcz niezbędne. :mrgreen:

poza tym dodam jeszcze, że najbardziej "hardkorowa" konfiguracja to używanie łączonych dystrybucji. ale to może przysporzyć więcej pracy niż korzyści. w miare rozsądnym rozwiązaniem wydaje się tutaj testing/unstable/(experimental/whatever). generalnie im bardziej dziwna tym trudniej o stabilność co jest zrozumiałe aczkolwiek w teorii wszystko powinno "ujść". fakt np. mając obecnie testing/unstable nie mogę nawet podpiąć dystrybucji 'stable' (wywala, niezrozumiały mi błąd przy `apt-get update`)

nt. łączenia dystrybucji i wyboru wersji pakietów można poczytać w Debian Reference i na stronach man: 'apt_preferences'

Awatar użytkownika
davidoski
Beginner
Posty: 234
Rejestracja: 17 kwietnia 2007, 10:53
Lokalizacja: Poznań

Post autor: davidoski » 17 kwietnia 2007, 11:49

Witam. Zainstalowałem dziś po raz pierwszy Debiana 4.0 w wersji z KDE i chciałem go zaktualizować do wersji testing wg podanej instrukcji. Jednak po wydaniu komendy aptitude update dostaję komunikat o błędzie:

Kod: Zaznacz cały

E: Nie udało się uzyskać blokady /var/lib/dpkg/lock - open (11 Zasoby chwilowo niedostępne)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
E: Nie można przebudować informacji o pakietach
c17-19:/home/davidoski# 
O co może chodzić? ¯adnego innego programu nie mam uruchomionego, a repozytoria dodałem jak trzeba.

Dopisane: Już jest ok - pomógł restart systemu (musiałem mieć jakiś proces uruchomiony).

Pozdrawiam

witek
Beginner
Posty: 117
Rejestracja: 16 kwietnia 2007, 12:39
Lokalizacja: Piekary ¦l±skie

Post autor: witek » 17 kwietnia 2007, 11:52

davidoski pisze:Witam. Zainstalowałem dziś po raz pierwszy Debiana 4.0 w wersji z KDE i chciałem go zaktualizować do wersji testing wg podanej instrukcji. Jednak po wydaniu komendy aptitude update dostaję komunikat o błędzie:

Kod: Zaznacz cały

E: Nie udało się uzyskać blokady /var/lib/dpkg/lock - open (11 Zasoby chwilowo niedostępne)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
E: Nie można przebudować informacji o pakietach
c17-19:/home/davidoski# 
O co może chodzić? ¯adnego innego programu nie mam uruchomionego, a repozytoria dodałem jak trzeba.
Aby móc korzystać z aptiude czy apt-get musisz mieć prawa administratora. Czyli najpierw w konsoli su i enter, podajesz hasło roota i dopiero potem aptitude.

Awatar użytkownika
davidoski
Beginner
Posty: 234
Rejestracja: 17 kwietnia 2007, 10:53
Lokalizacja: Poznań

Post autor: davidoski » 17 kwietnia 2007, 12:00

Aby móc korzystać z aptiude czy apt-get musisz mieć prawa administratora. Czyli najpierw w konsoli su i enter, podajesz hasło roota i dopiero potem aptitude.
Tak robiłem - tylko wcześniej kombinowałem z programem xdtv do oglądania telewizji, który coś nie chce działać prawidłowo i on musiał mi coś namieszać. Ale po restarcie systemu już jest ok.

A przy okazji pytanie: czy po dodaniu nowych repozytoriów dla wersji testowej stare repozytoria dla wersji stabilnej zostawiamy nie zmienione (tzn. niezahashowane)?

witek
Beginner
Posty: 117
Rejestracja: 16 kwietnia 2007, 12:39
Lokalizacja: Piekary ¦l±skie

Post autor: witek » 17 kwietnia 2007, 12:55

Zmieniasz całą zawartość pliku sources.list na repozytoria od testinga Lenny

mlyczek
Junior Member
Posty: 979
Rejestracja: 02 sierpnia 2006, 19:17

Post autor: mlyczek » 17 kwietnia 2007, 14:35

davidoski pisze:A przy okazji pytanie: czy po dodaniu nowych repozytoriów dla wersji testowej stare repozytoria dla wersji stabilnej zostawiamy nie zmienione (tzn. niezahashowane)?
Po prostu w pliku /etc/apt/sources.list zamieniasz wszystkie słowa stable(lub sarge, jeśli miałeś tak wpisane) na testing. I już.

Awatar użytkownika
davidoski
Beginner
Posty: 234
Rejestracja: 17 kwietnia 2007, 10:53
Lokalizacja: Poznań

Post autor: davidoski » 17 kwietnia 2007, 18:03

A to co innego. W instrukcji powinno być w takim razie zastępujemy wpisy w sources.list a nie
dodajemy
.

Bo dodać znaczy dodać, a zastąpić - zastąpić.

Pozdrawiam,

davidoski

phund
Posty: 58
Rejestracja: 30 marca 2007, 11:33
Lokalizacja: UTP

Post autor: phund » 18 kwietnia 2007, 18:39

davidoski pisze:

Kod: Zaznacz cały

E: Nie udało się uzyskać blokady /var/lib/dpkg/lock - open (11 Zasoby chwilowo niedostępne)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
E: Nie można przebudować informacji o pakietach
c17-19:/home/davidoski#
Bardzo możliwe, że masz uruchomione dwa narzędzia do zarządzania pakietami - pierwszy, który był uruchomiony zablokowuje /var/lib/dpkg, żeby nie wystąpiły problemy z zależnościami przez jednoczesne instalowanie pakietów przez inne narzędzia (tak sobie to przynajmniej tłumacze :-P )

Awatar użytkownika
3ndriu
Beginner
Posty: 246
Rejestracja: 15 kwietnia 2007, 18:00
Lokalizacja: Chodzież

Post autor: 3ndriu » 22 kwietnia 2007, 17:25

Zgodnie z opisem zrobiłem aktualizację z sarge do lenny, ale w /etc/issue mam to:

Kod: Zaznacz cały

andrzej@andrzej:~$ cat /etc/issue
Debian GNU/Linux 3.1 \n \l
Nie przeszkadza mi to zbytnio, ale chcę wiedzieć dlaczego tak jest.

Zablokowany