AsusPro Pu401 instalacja gruba w Debian11 nie widzi Debiana11

Pomoc dotycząca instalacji systemu
ww71
Beginner
Posty: 412
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

AsusPro Pu401 instalacja gruba w Debian11 nie widzi Debiana11

Post autor: ww71 » 01 kwietnia 2021, 20:33

Witam,
Problem znów sie pojawił po wgraniu nowego Debiana11. Mój AsusPro Pu401La ustawiłem partycje w GPT. Windows go wymagał. Wgrałem Debian11 i przy starcie widzi tylko win 10.

Kod: Zaznacz cały

# fdisk -l
Dysk /dev/sda: 223,57 GiB, bajtów: 240057409536, sektorów: 468862128
Model dysku: ADATA SU630     
Jednostki: sektorów, czyli 1 * 512 = 512 bajtów
Rozmiar sektora (logiczny/fizyczny) w bajtach: 512 / 512
Rozmiar we/wy (minimalny/optymalny) w bajtach: 512 / 512
Typ etykiety dysku: gpt
Identyfikator dysku: D37B1AEA-A1A3-4C35-9B9E-0E0ED53B7421

Urządzenie  Początek    Koniec   Sektory Rozmiar Typ
/dev/sda1       2048    206847    204800    100M System EFI
/dev/sda2     206848    239615     32768     16M Microsoft - zarezerwowana
/dev/sda3     239616 124632462 124392847   59,3G Microsoft - dane podstawowe
/dev/sda4  124633088 125673471   1040384    508M Środowisko odtworzeniowe Window
/dev/sda5  125675520 194312191  68636672   32,7G Microsoft - dane podstawowe
/dev/sda6  194312192 261765119  67452928   32,2G Linux - system plików
/dev/sda7  261765120 325965823  64200704   30,6G Linux - system plików
/dev/sda8  325965824 328062975   2097152      1G Linux swap
/dev/sda9  328062976 468860927 140797952   67,1G Linux - system plików
Próbowałem tak:

Kod: Zaznacz cały

os-prober
dpkg-reconfigure grub-pc
update-grub2
Nie pomogło. Na razie uruchamiam Debiana11 przez Supergrub. Proszę o jakieś wskazówki. Pozdrawiam.

fnmirk
Senior Member
Posty: 8054
Rejestracja: 03 grudnia 2007, 06:37

Re: AsusPro Pu401 instalacja gruba w Debian11 nie widzi Debiana11

Post autor: fnmirk » 01 kwietnia 2021, 21:11


ww71
Beginner
Posty: 412
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: AsusPro Pu401 instalacja gruba w Debian11 nie widzi Debiana11

Post autor: ww71 » 01 kwietnia 2021, 21:18

Nie łapię tego. Teraz mam wszystko na nowym dysku SSD. Robiłem odzysk gruba pod Debian 10 , tak jak pisałem wcześniej. Tu nie pomaga. Także, jakby Ktoś mógł pomóc będę wdzięczny.


ww71
Beginner
Posty: 412
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: AsusPro Pu401 instalacja gruba w Debian11 nie widzi Debiana11

Post autor: ww71 » 01 kwietnia 2021, 21:57

A czy nie można z poziomu Debiana 11? Uruchamiam go przez Supergrub2.

Awatar użytkownika
saturno
Junior Member
Posty: 713
Rejestracja: 08 lipca 2008, 20:04

Re: AsusPro Pu401 instalacja gruba w Debian11 nie widzi Debiana11

Post autor: saturno » 02 kwietnia 2021, 00:31

Nie wiem po co używać narzędzi zewnętrznych do naprawy rozruchu jak można użyć instalatora Debiana.
Należy uruchomić instalator Debiana (Netinstall wystarczy) w trybie ratunkowym (Rescue mode) i tam można łatwo naprawić rozruch (zainstalować grub-a ponownie).

Ps. Zastanawia mnie czy instalujesz Grub-a w: /dev/sda

ww71
Beginner
Posty: 412
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: AsusPro Pu401 instalacja gruba w Debian11 nie widzi Debiana11

Post autor: ww71 » 02 kwietnia 2021, 08:02

Kod: Zaznacz cały

 grub-install /dev/sda
Instalowanie dla platformy i386-pc.
grub-install: uwaga: ta etykieta partycji GPT nie ma BIOS-wej partycji rozruchowej; osadzanie nie będzie możliwe.
grub-install: uwaga: Osadzanie nie jest możliwe. Program GRUB może być instalowany z tymi ustawieniami tylko używając list blokowania. Jednakże, listy blokowania są NIEPEWNE, a ich używanie jest niezalecane..
grub-install: błąd: nie zostanie kontynuowane za pomocą list blokowania.

Kod: Zaznacz cały

 update-grub2
Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-5.10.0-5-amd64
Found initrd image: /boot/initrd.img-5.10.0-5-amd64
Found linux image: /boot/vmlinuz-5.10.0-4-amd64
Found initrd image: /boot/initrd.img-5.10.0-4-amd64

Awatar użytkownika
LordRuthwen
Moderator
Posty: 2212
Rejestracja: 18 września 2009, 21:45
Lokalizacja: klikash?

Re: AsusPro Pu401 instalacja gruba w Debian11 nie widzi Debiana11

Post autor: LordRuthwen » 02 kwietnia 2021, 08:39

Wejdź do biosu i zmień bootloader (wybierz gruba z menu)

ww71
Beginner
Posty: 412
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: AsusPro Pu401 instalacja gruba w Debian11 nie widzi Debiana11

Post autor: ww71 » 02 kwietnia 2021, 08:44

W biosie mam z tego co widzę tylko zmianę kolejności bootowania. Żadnych innych opcji nie widzę. Właśnie jakiś ubogi ten bios.
A czy można jakoś przeskoczyć instalację Debiana z instalki na koniec, do samej instalacji gruba ? Mam na myśli skorzystać z Debiana 10.9 Próbowałem szukać ale nie ma takiej opcji w menu instalki.

Awatar użytkownika
saturno
Junior Member
Posty: 713
Rejestracja: 08 lipca 2008, 20:04

Re: AsusPro Pu401 instalacja gruba w Debian11 nie widzi Debiana11

Post autor: saturno » 02 kwietnia 2021, 16:22

ww71 pisze:
02 kwietnia 2021, 08:02

Kod: Zaznacz cały

 grub-install /dev/sda
Instalowanie dla platformy i386-pc.
...

Kod: Zaznacz cały

 update-grub2
...
Found linux image: /boot/vmlinuz-5.10.0-5-amd64
Found initrd image: /boot/initrd.img-5.10.0-5-amd64
...
Kombinujesz jak koń pod górę!!!
Masz system amd64 z efi, a gruba chcesz instalować i386-pc
Powinno być tak:

Kod: Zaznacz cały

# grub-install /dev/sda
Instalowanie dla platformy x86_64-efi.
Instalacja zakończona. Nie zgłoszono błędów
ww71 pisze:
02 kwietnia 2021, 08:44
A czy można jakoś przeskoczyć instalację Debiana z instalki na koniec, do samej instalacji gruba ? Mam na myśli skorzystać z Debiana 10.9
saturno pisze:
02 kwietnia 2021, 00:31

Należy uruchomić instalator Debiana (Netinstall wystarczy) w trybie ratunkowym (Rescue mode) i tam można łatwo naprawić rozruch (zainstalować grub-a ponownie).

Podstawą jest żeby do naprawy używać instalatora Debiana tej samej wersji i tej same architektury co jest zainstalowana na dysku.
Skoro masz zainsalowany testing amd64 to użyj: https://cdimage.debian.org/cdimage/dail ... etinst.iso do przygotowania instalatora.
ww71 pisze:
02 kwietnia 2021, 08:44
Próbowałem szukać ale nie ma takiej opcji w menu instalki.
Adwanced options >> Rescue mode >> kraj, język, klawiatura, sieć >> wskazanie partycji z systemem >> ponowne zainstalowanie grub-a

Ps.1: Szanuj czyjś czas
Ps. 2: Jakby grub się zainstalował i Debian się uruchamiał, a następnie po uruchomieniu/aktualizacji Windowsa grub znikał zastosuj się do rady z: https://wiki.debian.org/GrubEFIReinstal ... ter_reboot W skrócie zainstaluj z poziomu Debiana program: refind (jest w repozytorium)
fnmirk pisze:
01 kwietnia 2021, 21:11
Spróbuj zrozumieć opis:

https://dug.net.pl/drukuj/264/konwersja ... C=%3E_gpt/

Mnie się wydaje że: ww71 przy okazji instalacji Windowsa "zaorał" cały dysk na gpt i wszystkie partycje są nowe.

ODPOWIEDZ