APT, dist-upgrade

Ogólne pytania dotyczące systemu
dodi
Beginner
Posty: 137
Rejestracja: 24 maja 2006, 19:00

APT, dist-upgrade

Post autor: dodi » 19 czerwca 2006, 21:52

Zrobiłem dziś upgrade sid i przy dist-upgrade się posypało.

Macie jakieś pomysły ?

Kod: Zaznacz cały

apt-get dist-upgrade
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności... Gotowe
Obliczanie aktualizacji...Gotowe
Następujące pakiety zostaną USUNIÊTE:
  event-rpc-perl libtasn1-2-dev
Zostaną zainstalowane następujące NOWE pakiety:
  libevent-rpc-perl libtasn1-3 libtasn1-3-dev
Następujące pakiety zostaną zaktualizowane:
  anyevent-perl libgnutls-dev libgnutls12 libgnutls13
4 aktualizowanych, 3 nowo instalowanych, 2 usuwanych i 0 nieaktualizowanych.
Konieczne pobranie 0B/1429kB archiwów.
Po rozpakowaniu zostanie zwolnione 81,9kB miejsca na dysku.
Czy chcesz kontynuować [T/n]? t
UWAGA: Następujące pakiety nie mogą zostać zweryfikowane!
  libevent-rpc-perl anyevent-perl libtasn1-3 libgnutls-dev libgnutls13 libtasn1-3-dev libgnutls12
Ostrzeżenie uwierzytelniania zignorowano.
(Odczytywanie bazy danych ... 102138 plików i katalogów obecnie zainstalowanych.)
Rozpakowanie libevent-rpc-perl (z .../libevent-rpc-perl_0.90-1_all.deb) ...
dpkg: błąd przetwarzania /var/cache/apt/archives/libevent-rpc-perl_0.90-1_all.deb (--unpack):
 próba nadpisania `/usr/share/perl5/Event/RPC.pm', który istnieje także w pakiecie event-rpc-perl
Wystąpiły błędy podczas przetwarzania:
 /var/cache/apt/archives/libevent-rpc-perl_0.90-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

dzięki z czoła!

Matthew
Posty: 24
Rejestracja: 13 czerwca 2006, 17:43
Lokalizacja: Lipka

Post autor: Matthew » 19 czerwca 2006, 21:57

Polecam:

Kod: Zaznacz cały

# apt-get -f install
Jak to nie pomoże to spróbowałbym usunać obydwa pakiety co mają konflikt i wtedy jest zainstalować.

dodi
Beginner
Posty: 137
Rejestracja: 24 maja 2006, 19:00

Post autor: dodi » 19 czerwca 2006, 22:33

odinstalowałem wszystkie, przelamal sie dist-upgrade i zainstalowalem ponownie - dziala :)
dzieki i pzd

Verdan
Posty: 80
Rejestracja: 06 czerwca 2006, 17:49

Post autor: Verdan » 20 czerwca 2006, 15:27

.... I należało by zgłosić błąd, bo jest ewidentny.

Kod: Zaznacz cały

man reportbug
Pozdrawiam,
V.

Awatar użytkownika
LiNiO
Posty: 25
Rejestracja: 23 maja 2006, 20:27
Lokalizacja: Zamość

Post autor: LiNiO » 25 czerwca 2006, 08:03

a jeśli już musisz mieć zainstalowany pakiet, który zgłasza błędy nadpisania (i wiesz co robisz ;) to zawsze możesz wpisać:

Kod: Zaznacz cały

dpkg -i --force-overwrite /var/cache/apt/archives/libevent-rpc-perl_0.90-1_all.deb
Chociaż tutaj prawdopodobnie pomogłoby wcześniejsze wykonanie:

Kod: Zaznacz cały

apt-get remove event-rpc-perl
pozdrówka
LiNiO

Zablokowany