Problem z apt-get install Temat rozwiązany

Ogólne pytania dotyczące systemu
Janek
Posty: 14
Rejestracja: 17 listopada 2017, 23:43

Re: Problem z apt-get install

Post autor: Janek » 18 listopada 2017, 10:13

Podaje końcówke

Kod: Zaznacz cały

Ign.  https://packagecloud.io jessie/main Translation-pl                       
Pobieranie:36 https://packagecloud.io jessie/main Translation-en [162 B]       
Ign.  https://packagecloud.io jessie/main Translation-en                       
Pobrano 24,6 kB w 6s (3671 B/s)                                                
Czytanie list pakietów... Gotowe
Aczkolwiek reszta to samo

Awatar użytkownika
marcin1982
Moderator
Posty: 1635
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Problem z apt-get install

Post autor: marcin1982 » 18 listopada 2017, 10:22

Teraz chcę coś potwierdzić, pokaż:

Kod: Zaznacz cały

dpkg -l | grep idle-python3.4

Kod: Zaznacz cały

dpkg -l | grep lxlauncher

Kod: Zaznacz cały

dpkg -l | grep wordpress

Janek
Posty: 14
Rejestracja: 17 listopada 2017, 23:43

Re: Problem z apt-get install

Post autor: Janek » 18 listopada 2017, 10:27

Kod: Zaznacz cały

dpkg -l | grep idle-python3.4
rc  idle-python3.4                        3.4.2-1                                    all          IDE for Python (v3.4) using Tkinte

Kod: Zaznacz cały

dpkg -l | grep lxlauncher
rc  lxlauncher                            0.2.4-1                                    amd64        LXDE launcher for netbooks

Kod: Zaznacz cały

dpkg -l | grep wordpress
rc  wordpress                             4.1+dfsg-1+deb8u14                         all          weblog manager

Awatar użytkownika
marcin1982
Moderator
Posty: 1635
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Problem z apt-get install

Post autor: marcin1982 » 18 listopada 2017, 10:29

Nie tak ... :D

Jeszcze raz:

Kod: Zaznacz cały

apt-cache policy idle-python3.4 lxlauncher wordpress

Janek
Posty: 14
Rejestracja: 17 listopada 2017, 23:43

Re: Problem z apt-get install

Post autor: Janek » 18 listopada 2017, 10:33

Kod: Zaznacz cały

apt-cache policy idle-python3.4 lxlauncher wordpress
idle-python3.4:
  Zainstalowana: (brak)
  Kandydująca:   3.4.2-1
  Tabela wersji:
     3.4.2-1 0
        500 http://ftp.pl.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status
lxlauncher:
  Zainstalowana: (brak)
  Kandydująca:   0.2.4-1
  Tabela wersji:
     0.2.4-1 0
        500 http://ftp.pl.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status
wordpress:
  Zainstalowana: (brak)
  Kandydująca:   4.1+dfsg-1+deb8u15
  Tabela wersji:
     4.1+dfsg-1+deb8u15 0
        500 http://security.debian.org/ jessie/updates/main amd64 Packages
     4.1+dfsg-1+deb8u14 0
        500 http://ftp.pl.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status
@edit

3.4 odpala ide 2.7, ale 3.5 odapla idle dla 3.5 pythona

Awatar użytkownika
marcin1982
Moderator
Posty: 1635
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Problem z apt-get install

Post autor: marcin1982 » 18 listopada 2017, 10:37

Spokojnie, pomału ... trzeba to do porządku najpierw doprowadzić.

Teraz usuniemy pakiety, które nie są zainstalowane, a pozostały ich pliki konfiguracyjne:

Kod: Zaznacz cały

for NAME in $(dpkg -l | grep "^rc" | awk '{print $2}'); do apt-get --purge remove $NAME; done
Jeśli będą przy tym problemy, pokaż wynik. Jeśli pójdzie gładko -jeszcze raz:

Kod: Zaznacz cały

apt-get update && apt-get -s dist-upgrade

Janek
Posty: 14
Rejestracja: 17 listopada 2017, 23:43

Re: Problem z apt-get install

Post autor: Janek » 18 listopada 2017, 10:43

Kod: Zaznacz cały

for NAME in $(dpkg -l | grep "^rc" | awk '{print $2}'); do apt-get --purge remove $NAME; done
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Należy uruchomić "apt-get -f install", aby naprawić poniższe problemy:
Następujące pakiety mają niespełnione zależności:
 python3-uno : Wymaga: libreoffice-core (= 1:4.3.3-2+deb8u7) ale 1:4.3.3-2+deb8u9 ma zostać zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać "apt-get -f install" bez pakietów (lub podać rozwiązanie).
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Należy uruchomić "apt-get -f install", aby naprawić poniższe problemy:
Następujące pakiety mają niespełnione zależności:
 python3-uno : Wymaga: libreoffice-core (= 1:4.3.3-2+deb8u7) ale 1:4.3.3-2+deb8u9 ma zostać zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać "apt-get -f install" bez pakietów (lub podać rozwiązanie).
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Należy uruchomić "apt-get -f install", aby naprawić poniższe problemy:




Awatar użytkownika
marcin1982
Moderator
Posty: 1635
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Problem z apt-get install

Post autor: marcin1982 » 18 listopada 2017, 10:45

Pokaż w takim razie:

Kod: Zaznacz cały

apt-get -s remove python3-uno
Wrócimy do tego później. Najpierw trzeba doprowadzić do systuacji, w której system będzie się dało normalnie zaktualizować. To jest nawarstwienie problemów prawdopodobnie związanych z używaniem zewnętrznych repozytoriów/ PPA ...

Janek
Posty: 14
Rejestracja: 17 listopada 2017, 23:43

Re: Problem z apt-get install

Post autor: Janek » 18 listopada 2017, 10:48

Kod: Zaznacz cały

apt-get -s remove python3-uno
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Następujące pakiety zostaną USUNIĘTE:
  python3-uno
0 aktualizowanych, 0 nowo instalowanych, 1 usuwanych i 45 nieaktualizowanych.
65 nie w pełni zainstalowanych lub usuniętych.
Remv python3-uno [1:4.3.3-2+deb8u7]
Conf libssl1.0.0 (1.0.1t-1+deb8u7 Debian-Security:8/oldstable [amd64])
Conf libssl1.0.0:i386 (1.0.1t-1+deb8u7 Debian-Security:8/oldstable [i386])
Conf libavutil54 (6:11.11-1~deb8u1 Debian-Security:8/oldstable [amd64])
Conf libavutil54:i386 (6:11.11-1~deb8u1 Debian-Security:8/oldstable [i386])
Conf libavresample2:i386 (6:11.11-1~deb8u1 Debian-Security:8/oldstable [i386])
Conf libavresample2 (6:11.11-1~deb8u1 Debian-Security:8/oldstable [amd64])
Conf libavcodec56 (6:11.11-1~deb8u1 Debian-Security:8/oldstable [amd64])
Conf libavcodec56:i386 (6:11.11-1~deb8u1 Debian-Security:8/oldstable [i386])
Conf libavformat56 (6:11.11-1~deb8u1 Debian-Security:8/oldstable [amd64])
Conf libcurl3 (7.38.0-4+deb8u7 Debian-Security:8/oldstable [amd64])
Conf libcurl3-gnutls (7.38.0-4+deb8u7 Debian-Security:8/oldstable [amd64])
Conf libnss3 (2:3.26-1+debu8u3 Debian-Security:8/oldstable [amd64])
Conf uno-libs3 (4.3.3-2+deb8u9 Debian-Security:8/oldstable [amd64])
Conf ure (4.3.3-2+deb8u9 Debian-Security:8/oldstable [amd64])
Conf fonts-opensymbol (2:102.6+LibO4.3.3-2+deb8u9 Debian-Security:8/oldstable [all])
Conf libreoffice-style-galaxy (1:4.3.3-2+deb8u9 Debian-Security:8/oldstable [all])
Conf libreoffice-style-tango (1:4.3.3-2+deb8u9 Debian-Security:8/oldstable [all])
Conf libreoffice-common (1:4.3.3-2+deb8u9 Debian-Security:8/oldstable [all])
Conf libreoffice-core (1:4.3.3-2+deb8u9 Debian-Security:8/oldstable [amd64])
Conf curl (7.38.0-4+deb8u7 Debian-Security:8/oldstable [amd64])
Conf dh-python (1.20141111-2 Debian:8.9/oldstable [all])
Conf python3 (3.4.2-2 Debian:8.9/oldstable [amd64])
Conf python3-apt (0.9.3.12 Debian:8.9/oldstable [amd64])
Conf python3-pkg-resources (5.5.1-1 Debian:8.9/oldstable [all])
Conf python3-chardet (2.3.0-1 Debian:8.9/oldstable [all])
Conf python3-six (1.8.0-1 Debian:8.9/oldstable [all])
Conf python3-debian (0.1.27 Debian:8.9/oldstable [all])
Conf gdebi-core (0.9.5.5+nmu1 Debian:8.9/oldstable [all])
Conf python3-gi (3.14.0-1 Debian:8.9/oldstable [amd64])
Conf gdebi (0.9.5.5+nmu1 Debian:8.9/oldstable [all])
Conf python3-brlapi (5.2~20141018-5 Debian:8.9/oldstable [amd64])
Conf python3-cairo (1.10.0+dfsg-4+b1 Debian:8.9/oldstable [amd64])
Conf python3-louis (2.5.3-3 Debian:8.9/oldstable [all])
Conf python3-pyatspi (2.14.0+dfsg-1 Debian:8.9/oldstable [all])
Conf python3-xdg (0.25-4 Debian:8.9/oldstable [all])
Conf python3-speechd (0.8-7 Debian:8.9/oldstable [all])
Conf gnome-orca (3.14.0-4+deb8u1 Debian:8.9/oldstable [all])
Conf libcurl4-gnutls-dev (7.38.0-4+deb8u7 Debian-Security:8/oldstable [amd64])
Conf libreoffice-base-drivers (1:4.3.3-2+deb8u9 Debian-Security:8/oldstable [amd64])
Conf libreoffice-base-core (1:4.3.3-2+deb8u9 Debian-Security:8/oldstable [amd64])
Conf libreoffice-base (1:4.3.3-2+deb8u9 Debian-Security:8/oldstable [amd64])
Conf libreoffice-calc (1:4.3.3-2+deb8u9 Debian-Security:8/oldstable [amd64])
Conf libreoffice-draw (1:4.3.3-2+deb8u9 Debian-Security:8/oldstable [amd64])
Conf libreoffice-gtk (1:4.3.3-2+deb8u9 Debian-Security:8/oldstable [amd64])
Conf libreoffice-impress (1:4.3.3-2+deb8u9 Debian-Security:8/oldstable [amd64])
Conf libreoffice-math (1:4.3.3-2+deb8u9 Debian-Security:8/oldstable [amd64])
Conf libreoffice-writer (1:4.3.3-2+deb8u9 Debian-Security:8/oldstable [amd64])
Conf libssl-doc (1.0.1t-1+deb8u7 Debian-Security:8/oldstable [all])
Conf libssl-dev (1.0.1t-1+deb8u7 Debian-Security:8/oldstable [amd64])
Conf mysql-common (5.5.58-0+deb8u1 Debian-Security:8/oldstable [all])
Conf mysql-server (5.5.58-0+deb8u1 Debian-Security:8/oldstable [all])
Conf python3-colorama (0.3.2-1 Debian:8.9/oldstable [all])
Conf python3-dbus (1.2.0-2+b3 Debian:8.9/oldstable [amd64])
Conf python3-distlib (0.1.9-1 Debian:8.9/oldstable [all])
Conf python3-html5lib (0.999-3 Debian:8.9/oldstable [all])
Conf python3-urllib3 (1.9.1-3 Debian:8.9/oldstable [all])
Conf python3-requests (2.4.3-6 Debian:8.9/oldstable [all])
Conf python3-setuptools (5.5.1-1 Debian:8.9/oldstable [all])
Conf python3-pip (1.5.6-5 Debian:8.9/oldstable [all])
Conf unattended-upgrades (0.83.3.2+deb8u1 Debian:8.9/oldstable, Debian-Security:8/oldstable [all])
Conf python3-software-properties (0.92.25debian1 Debian:8.9/oldstable [all])
Conf software-properties-common (0.92.25debian1 Debian:8.9/oldstable [all])
Conf python3-wheel (0.24.0-1 Debian:8.9/oldstable [all])
Conf ufw (0.33-2 Debian:8.9/oldstable [all])


Awatar użytkownika
marcin1982
Moderator
Posty: 1635
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Problem z apt-get install

Post autor: marcin1982 » 18 listopada 2017, 10:53

Dobra, wklej sobie gdzieś ten powyższy wynik i wykonaj bez -s, ale z opcją --purge. Obserwuj dokładnie co system chce usunąć:

Kod: Zaznacz cały

apt-get --purge remove python3-uno
Jeśli nie zauważysz katastrofy to znowu podaj pełny wynik:

Kod: Zaznacz cały

apt-get update && apt-get dist-upgrade

Zablokowany