Problem z apt-get install Temat rozwiązany

Ogólne pytania dotyczące systemu
Janek
Posty: 14
Rejestracja: 17 listopada 2017, 23:43

Re: Problem z apt-get install

Post autor: Janek » 18 listopada 2017, 11:05

Jedyne co ostatnio nie instalowałem przez apt-get było dpkg -i skypeforlinux-64.deb z tego co pamiętam. Nie wiem czy ktoś mi z systemu nie usunął pythona3 bo była sytuacja gdzie linucha musiałem udostępnić. Aczkolwiek to było jakiś czas temu i chyba coś od tamtej pory instalowałem. Mi się wydaje że pod python3 odpala python2, a różnice są spore pomiędzy tymi dwoma wersjami i wysupuje się.

Kod: Zaznacz cały

dpkg: błąd przetwarzania pakietu python3-uno (--purge):
 pakiet jest w złym stanie - powinien zostać przeinstalowany przed usunięciem
Wystąpiły błędy podczas przetwarzania:
 python3-uno
E: Sub-process /usr/bin/dpkg returned an error code (1)
Czy jakieś usunięcie ręczne python3-uno bądz libereoffice wchodzi w grę ?

Awatar użytkownika
marcin1982
Moderator
Posty: 1635
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Problem z apt-get install

Post autor: marcin1982 » 18 listopada 2017, 11:10

Pakiet libreoffice-core nie jest zainstalowany, to nie ma czego usuwać.

Spróbuj ręcznie tak usunąć:

Kod: Zaznacz cały

dpkg --remove --force-remove-reinstreq python3-uno
Potem znowu ...

Kod: Zaznacz cały

apt-get update && apt-get dist-upgrade

Janek
Posty: 14
Rejestracja: 17 listopada 2017, 23:43

Re: Problem z apt-get install

Post autor: Janek » 18 listopada 2017, 11:55

Okej to już chyba wiemy co uwalone. Postanowłem uruchomić py3clean i py3compile z python3.5. Teraz dostaje dla apt-get upgrade i -f install, dodam także ,żę
przy upgrade już zaczeło wykonywać i dopiero po paru min wywaliło:

Kod: Zaznacz cały

apt-get upgrade
dpkg: błąd przetwarzania pakietu dh-python (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Wystąpiły błędy podczas przetwarzania:
 python3
 python3-apt
 python3-pkg-resources
 python3-chardet
 python3-six
 python3-debian
 gdebi-core
 python3-gi
 gdebi
 python3-brlapi
 python3-cairo
 python3-louis
 python3-pyatspi
 python3-xdg
 python3-speechd
 gnome-orca
 python3-colorama
 python3-dbus
 python3-distlib
 python3-html5lib
 python3-urllib3
 python3-requests
 python3-setuptools
 python3-pip
 unattended-upgrades
 python3-software-properties
 software-properties-common
 python3-uno
 python3-wheel
 ufw
 dh-python
E: Sub-process /usr/bin/dpkg returned an error code (1)

Awatar użytkownika
marcin1982
Moderator
Posty: 1635
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Problem z apt-get install

Post autor: marcin1982 » 18 listopada 2017, 12:15

A możesz pokazać cały zestaw pakietów, których dotyczy aktualizacja itd?

Kod: Zaznacz cały

apt-get dist-upgrade

Janek
Posty: 14
Rejestracja: 17 listopada 2017, 23:43

Re: Problem z apt-get install

Post autor: Janek » 18 listopada 2017, 12:21

Kod: Zaznacz cały

apt-get dist-upgrade
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Obliczanie aktualizacji...Gotowe
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
31 nie w pełni zainstalowanych lub usuniętych.
Po tej operacji zostanie dodatkowo użyte 0 B miejsca na dysku.
Kontynuować? [T/n] t
Konfigurowanie pakietu python3 (3.4.2-2) ...
running python rtupdate hooks for python3.4...
/usr/share/python3/runtime.d/dh-python.rtupdate: 5: /usr/share/python3/runtime.d/dh-python.rtupdate: py3clean: not found
error running python rtupdate hook dh-python
/usr/share/python3/runtime.d/gdebi-core.rtupdate: 5: /usr/share/python3/runtime.d/gdebi-core.rtupdate: py3clean: not found
error running python rtupdate hook gdebi-core
/usr/share/python3/runtime.d/gdebi.rtupdate: 5: /usr/share/python3/runtime.d/gdebi.rtupdate: py3clean: not found
error running python rtupdate hook gdebi
/usr/share/python3/runtime.d/python3-uno.rtupdate: 5: /usr/share/python3/runtime.d/python3-uno.rtupdate: py3clean: not found
error running python rtupdate hook python3-uno
dpkg: błąd przetwarzania pakietu python3 (--configure):
 podproces zainstalowany skrypt post-installation zwrócił kod błędu 4
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-apt:
 python3-apt zależy od python3 (<< 3.5); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-apt zależy od python3 (>= 3.4~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-apt (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-pkg-resources:
 python3-pkg-resources zależy od python3:any (>= 3.3); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-pkg-resources zależy od python3:any (<< 3.5); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-pkg-resources (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-chardet:
 python3-chardet zależy od python3; jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-chardet zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-chardet zależy od python3-pkg-resources; jednakże:
  Pakiet python3-pkg-resources nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-chardet (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-six:
 python3-six zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-six (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-debian:
 python3-debian zależy od python3-chardet; jednakże:
  Pakiet python3-chardet nie jest jeszcze skonfigurowany.
 python3-debian zależy od python3-six (>> 1.4~); jednakże:
  Pakiet python3-six nie jest jeszcze skonfigurowany.
 python3-debian zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-debian (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu gdebi-core:
 gdebi-core zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 gdebi-core zależy od python3-apt; jednakże:
  Pakiet python3-apt nie jest jeszcze skonfigurowany.
 gdebi-core zależy od python3-debian; jednakże:
  Pakiet python3-debian nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu gdebi-core (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-gi:
 python3-gi zależy od python3 (>= 3.4~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-gi zależy od python3 (<< 3.5); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-gi (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu gdebi:
 gdebi zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 gdebi zależy od gdebi-core (= 0.9.5.5+nmu1); jednakże:
  Pakiet gdebi-core nie jest jeszcze skonfigurowany.
 gdebi zależy od python3-gi; jednakże:
  Pakiet python3-gi nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu gdebi (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-brlapi:
 python3-brlapi zależy od python3 (<< 3.5); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-brlapi zależy od python3 (>= 3.4~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-brlapi (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-cairo:
 python3-cairo zależy od python3 (>= 3.4~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-cairo zależy od python3 (<< 3.5); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-cairo (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-louis:
 python3-louis zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-louis (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-pyatspi:
 python3-pyatspi zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-pyatspi zależy od python3-gi (>= 2.90.1); jednakże:
  Pakiet python3-gi nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-pyatspi (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-xdg:
 python3-xdg zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-xdg (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-speechd:
 python3-speechd zależy od python3-xdg; jednakże:
  Pakiet python3-xdg nie jest jeszcze skonfigurowany.
 python3-speechd zależy od python3; jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-speechd zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-speechd (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu gnome-orca:
 gnome-orca zależy od python3; jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 gnome-orca zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 gnome-orca zależy od python3-brlapi (>= 0.5.1); jednakże:
  Pakiet python3-brlapi nie jest jeszcze skonfigurowany.
 gnome-orca zależy od python3-cairo; jednakże:
  Pakiet python3-cairo nie jest jeszcze skonfigurowany.
 gnome-orca zależy od python3-gi (>= 3.10); jednakże:
  Pakiet python3-gi nie jest jeszcze skonfigurowany.
 gnome-orca zależy od python3-louis (>= 1.6.2); jednakże:
  Pakiet python3-louis nie jest jeszcze skonfigurowany.
 gnome-orca zależy od python3-pyatspi (>= 2.10); jednakże:
  Pakiet python3-pyatspi nie jest jeszcze skonfigurowany.
 gnome-orca zależy od python3-speechd (>= 0.8); jednakże:
  Pakiet python3-speechd nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu gnome-orca (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-colorama:
 python3-colorama zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-colorama (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-dbus:
 python3-dbus zależy od python3 (<< 3.5); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-dbus zależy od python3 (>= 3.4~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-dbus (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-distlib:
 python3-distlib zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-distlib (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-html5lib:
 python3-html5lib zależy od python3-six; jednakże:
  Pakiet python3-six nie jest jeszcze skonfigurowany.
 python3-html5lib zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-html5lib (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-urllib3:
 python3-urllib3 zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-urllib3 zależy od python3-six; jednakże:
  Pakiet python3-six nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-urllib3 (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-requests:
 python3-requests zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-requests zależy od python3-chardet; jednakże:
  Pakiet python3-chardet nie jest jeszcze skonfigurowany.
 python3-requests zależy od python3-urllib3 (>= 1.9.1); jednakże:
  Pakiet python3-urllib3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-requests (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-setuptools:
 python3-setuptools zależy od python3:any (>= 3.3); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-setuptools zależy od python3:any (<< 3.5); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-setuptools zależy od python3-pkg-resources (= 5.5.1-1); jednakże:
  Pakiet python3-pkg-resources nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-setuptools (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-pip:
 python3-pip zależy od python3-colorama; jednakże:
  Pakiet python3-colorama nie jest jeszcze skonfigurowany.
 python3-pip zależy od python3-distlib; jednakże:
  Pakiet python3-distlib nie jest jeszcze skonfigurowany.
 python3-pip zależy od python3-html5lib; jednakże:
  Pakiet python3-html5lib nie jest jeszcze skonfigurowany.
 python3-pip zależy od python3-pkg-resources; jednakże:
  Pakiet python3-pkg-resources nie jest jeszcze skonfigurowany.
 python3-pip zależy od python3-requests; jednakże:
  Pakiet python3-requests nie jest jeszcze skonfigurowany.
 python3-pip zależy od python3-setuptools; jednakże:
  Pakiet python3-setuptools nie jest jeszcze skonfigurowany.
 python3-pip zależy od python3-six; jednakże:
  Pakiet python3-six nie jest jeszcze skonfigurowany.
 python3-pip zależy od python3; jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-pip zależy od python3:any (>= 3.3.2-2~); jednakże:

dpkg: błąd przetwarzania pakietu python3-pip (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu unattended-upgrades:
 unattended-upgrades zależy od python3; jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 unattended-upgrades zależy od python3-apt; jednakże:
  Pakiet python3-apt nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu unattended-upgrades (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-software-properties:
 python3-software-properties zależy od python3 (>= 3.2.3-3~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-software-properties zależy od python3-apt (>= 0.6.20ubuntu16); jednakże:
  Pakiet python3-apt nie jest jeszcze skonfigurowany.
 python3-software-properties zależy od unattended-upgrades; jednakże:
  Pakiet unattended-upgrades nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-software-properties (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu software-properties-common:
 software-properties-common zależy od python3 (>= 3.2.3-3~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 software-properties-common zależy od python3-gi; jednakże:
  Pakiet python3-gi nie jest jeszcze skonfigurowany.
 software-properties-common zależy od python3-dbus; jednakże:
  Pakiet python3-dbus nie jest jeszcze skonfigurowany.
 software-properties-common zależy od python3-software-properties; jednakże:
  Pakiet python3-software-properties nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu software-properties-common (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-uno:
 python3-uno zależy od python3 (>= 3.4~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-uno zależy od python3 (<< 3.5); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-uno (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-wheel:
 python3-wheel zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 python3-wheel zależy od python3; jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-wheel (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu ufw:
 ufw zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.
 ufw zależy od python3; jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu ufw (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu dh-python:
 dh-python zależy od python3:any (>= 3.3.2-2~); jednakże:
  Pakiet python3 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu dh-python (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Wystąpiły błędy podczas przetwarzania:
 python3
 python3-apt
 python3-pkg-resources
 python3-chardet
 python3-six
 python3-debian
 gdebi-core
 python3-gi
 gdebi
 python3-brlapi
 python3-cairo
 python3-louis
 python3-pyatspi
 python3-xdg
 python3-speechd
 gnome-orca
 python3-colorama
 python3-dbus
 python3-distlib
 python3-html5lib
 python3-urllib3
 python3-requests
 python3-setuptools
 python3-pip
 unattended-upgrades
 python3-software-properties
 software-properties-common
 python3-uno
 python3-wheel
 ufw
 dh-python
E: Sub-process /usr/bin/dpkg returned an error code (1)

Kod: Zaznacz cały

apt-get update && apt-get -s dist-upgrade
Ign.  http://ftp.pl.debian.org jessie InRelease
Stary http://security.debian.org jessie/updates InRelease                                                  
Stary http://ftp.pl.debian.org jessie-updates InRelease                                                    
Stary http://ftp.pl.debian.org jessie Release.gpg                                                          
Stary http://security.debian.org jessie/updates/main Sources                                               
Stary http://ftp.pl.debian.org jessie Release                                                              
Stary http://ftp.pl.debian.org jessie-updates/main Sources                                                 
Stary http://security.debian.org jessie/updates/contrib Sources                                            
Stary http://ftp.pl.debian.org jessie-updates/contrib Sources                                              
Stary http://security.debian.org jessie/updates/non-free Sources                                           
Stary http://ftp.pl.debian.org jessie-updates/non-free Sources                                             
Stary https://deb.nodesource.com jessie InRelease                                                          
Stary http://security.debian.org jessie/updates/main amd64 Packages                                        
Pobieranie:1 http://ftp.pl.debian.org jessie-updates/main amd64 Packages/DiffIndex [9376 B]                
Stary http://security.debian.org jessie/updates/contrib amd64 Packages                                     
Stary http://ftp.pl.debian.org jessie-updates/contrib amd64 Packages                                       
Stary https://deb.nodesource.com jessie/main Sources                                                       
Pobieranie:2 http://ftp.pl.debian.org jessie-updates/non-free amd64 Packages/DiffIndex [736 B]             
Stary http://security.debian.org jessie/updates/non-free amd64 Packages                                    
Pobieranie:3 http://ftp.pl.debian.org jessie-updates/main i386 Packages/DiffIndex [9376 B]                 
Stary https://deb.nodesource.com jessie/main amd64 Packages                                                
Stary http://security.debian.org jessie/updates/main i386 Packages                                         
Stary http://ftp.pl.debian.org jessie-updates/contrib i386 Packages                                        
Stary https://deb.nodesource.com jessie/main i386 Packages                                                 
Stary http://security.debian.org jessie/updates/contrib i386 Packages                                      
Pobieranie:4 http://ftp.pl.debian.org jessie-updates/non-free i386 Packages/DiffIndex [736 B]              
Stary http://ftp.pl.debian.org jessie-updates/contrib Translation-en                                       
Stary http://security.debian.org jessie/updates/non-free i386 Packages                                     
Pobieranie:5 http://ftp.pl.debian.org jessie-updates/main Translation-en/DiffIndex [3688 B]                
Stary http://security.debian.org jessie/updates/contrib Translation-en                                     
Pobieranie:6 http://ftp.pl.debian.org jessie-updates/non-free Translation-en/DiffIndex [736 B]             
Stary http://security.debian.org jessie/updates/main Translation-en                                        
Stary http://ftp.pl.debian.org jessie/main Sources                                                         
Stary http://security.debian.org jessie/updates/non-free Translation-en                                    
Stary http://ftp.pl.debian.org jessie/contrib Sources                                                      
Pobieranie:7 https://deb.nodesource.com jessie/main Translation-pl_PL [162 B]                              
Stary http://ftp.pl.debian.org jessie/non-free Sources                                                     
Stary http://ftp.pl.debian.org jessie/main amd64 Packages                                                  
Stary http://ftp.pl.debian.org jessie/contrib amd64 Packages                                               
Stary http://ftp.pl.debian.org jessie/non-free amd64 Packages                                              
Pobieranie:8 https://deb.nodesource.com jessie/main Translation-pl [162 B]                                 
Stary http://ftp.pl.debian.org jessie/main i386 Packages                                                   
Stary http://ftp.pl.debian.org jessie/contrib i386 Packages                                                
Pobieranie:9 https://deb.nodesource.com jessie/main Translation-en [162 B]                                 
Stary http://ftp.pl.debian.org jessie/non-free i386 Packages                                               
Stary http://ftp.pl.debian.org jessie/contrib Translation-en                                               
Stary http://ftp.pl.debian.org jessie/main Translation-pl                                                  
Stary http://ftp.pl.debian.org jessie/main Translation-en                                                  
Pobieranie:10 https://deb.nodesource.com jessie/main Translation-pl_PL [162 B]                             
Stary http://ftp.pl.debian.org jessie/non-free Translation-en                                              
Pobieranie:11 https://deb.nodesource.com jessie/main Translation-pl [162 B]                                
Pobieranie:12 https://deb.nodesource.com jessie/main Translation-en [162 B]                                
Pobieranie:13 https://deb.nodesource.com jessie/main Translation-pl_PL [162 B]                             
Pobieranie:14 https://deb.nodesource.com jessie/main Translation-pl [162 B]                                
Pobieranie:15 https://deb.nodesource.com jessie/main Translation-en [162 B]                                
Stary https://packagecloud.io jessie InRelease                                                             
Pobieranie:16 https://deb.nodesource.com jessie/main Translation-pl_PL [162 B]                             
Pobieranie:17 https://deb.nodesource.com jessie/main Translation-pl [162 B]                                
Stary https://packagecloud.io jessie/main amd64 Packages                                                   
Pobieranie:18 https://deb.nodesource.com jessie/main Translation-en [162 B]                                
Pobieranie:19 https://deb.nodesource.com jessie/main Translation-pl_PL [162 B]                             
Ign.  https://deb.nodesource.com jessie/main Translation-pl_PL                                             
Stary https://packagecloud.io jessie/main i386 Packages                                                    
Pobieranie:20 https://deb.nodesource.com jessie/main Translation-pl [162 B]                              
Ign.  https://deb.nodesource.com jessie/main Translation-pl                                                
Pobieranie:21 https://deb.nodesource.com jessie/main Translation-en [162 B]                                
Ign.  https://deb.nodesource.com jessie/main Translation-en                                                
Pobieranie:22 https://packagecloud.io jessie/main Translation-pl_PL [162 B]                                
Pobieranie:23 https://packagecloud.io jessie/main Translation-pl [162 B]                  
Pobieranie:24 https://packagecloud.io jessie/main Translation-en [162 B]                                   
Pobieranie:25 https://packagecloud.io jessie/main Translation-pl_PL [162 B]                                
Pobieranie:26 https://packagecloud.io jessie/main Translation-pl [162 B]                                   
Pobieranie:27 https://packagecloud.io jessie/main Translation-en [162 B]                                   
Pobieranie:28 https://packagecloud.io jessie/main Translation-pl_PL [162 B]                                
Pobieranie:29 https://packagecloud.io jessie/main Translation-pl [162 B]                                   
Stary http://packages.microsoft.com stable InRelease                                                       
Stary http://packages.microsoft.com stable/main amd64 Packages                                             
Pobieranie:30 https://packagecloud.io jessie/main Translation-en [162 B]        
Pobieranie:31 https://packagecloud.io jessie/main Translation-pl_PL [162 B]                                
Pobieranie:32 https://packagecloud.io jessie/main Translation-pl [162 B]                                   
Pobieranie:33 https://packagecloud.io jessie/main Translation-en [162 B]                                   
Ign.  http://packages.microsoft.com stable/main Translation-pl_PL                                          
Pobieranie:34 https://packagecloud.io jessie/main Translation-pl_PL [162 B]                                
Ign.  https://packagecloud.io jessie/main Translation-pl_PL                                                
Ign.  http://packages.microsoft.com stable/main Translation-pl                                             
Ign.  http://packages.microsoft.com stable/main Translation-en                                             
Pobieranie:35 https://packagecloud.io jessie/main Translation-pl [162 B]                                   
Ign.  https://packagecloud.io jessie/main Translation-pl                                                   
Pobieranie:36 https://packagecloud.io jessie/main Translation-en [162 B]                                   
Ign.  https://packagecloud.io jessie/main Translation-en                                                   
Błąd  http://ppa.launchpad.net xenial InRelease                                                            
  
Błąd  http://ppa.launchpad.net xenial Release.gpg   
  Nie udało się połączyć z ppa.launchpad.net:http:
Pobrano 24,6 kB w 2min 0s (205 B/s)
Czytanie list pakietów... Gotowe
W: Nie udało się pobrać http://ppa.launchpad.net/webupd8team/java/ubuntu/dists/xenial/InRelease  

W: Nie udało się pobrać http://ppa.launchpad.net/webupd8team/java/ubuntu/dists/xenial/Release.gpg  Nie udało się połączyć z ppa.launchpad.net:http:

W: Nie udało się pobrać niektórych plików indeksu, zostały one zignorowane lub użyto ich starszej wersji.
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Obliczanie aktualizacji...Gotowe
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
31 nie w pełni zainstalowanych lub usuniętych.
Conf dh-python (1.20141111-2 Debian:8.9/oldstable [all])
Conf python3 (3.4.2-2 Debian:8.9/oldstable [amd64])
Conf python3-apt (0.9.3.12 Debian:8.9/oldstable [amd64])
Conf python3-pkg-resources (5.5.1-1 Debian:8.9/oldstable [all])
Conf python3-chardet (2.3.0-1 Debian:8.9/oldstable [all])
Conf python3-six (1.8.0-1 Debian:8.9/oldstable [all])
Conf python3-debian (0.1.27 Debian:8.9/oldstable [all])
Conf gdebi-core (0.9.5.5+nmu1 Debian:8.9/oldstable [all])
Conf python3-gi (3.14.0-1 Debian:8.9/oldstable [amd64])
Conf gdebi (0.9.5.5+nmu1 Debian:8.9/oldstable [all])
Conf python3-brlapi (5.2~20141018-5 Debian:8.9/oldstable [amd64])
Conf python3-cairo (1.10.0+dfsg-4+b1 Debian:8.9/oldstable [amd64])
Conf python3-louis (2.5.3-3 Debian:8.9/oldstable [all])
Conf python3-pyatspi (2.14.0+dfsg-1 Debian:8.9/oldstable [all])
Conf python3-xdg (0.25-4 Debian:8.9/oldstable [all])
Conf python3-speechd (0.8-7 Debian:8.9/oldstable [all])
Conf gnome-orca (3.14.0-4+deb8u1 Debian:8.9/oldstable [all])
Conf python3-colorama (0.3.2-1 Debian:8.9/oldstable [all])
Conf python3-dbus (1.2.0-2+b3 Debian:8.9/oldstable [amd64])
Conf python3-distlib (0.1.9-1 Debian:8.9/oldstable [all])
Conf python3-html5lib (0.999-3 Debian:8.9/oldstable [all])
Conf python3-urllib3 (1.9.1-3 Debian:8.9/oldstable [all])
Conf python3-requests (2.4.3-6 Debian:8.9/oldstable [all])
Conf python3-setuptools (5.5.1-1 Debian:8.9/oldstable [all])
Conf python3-pip (1.5.6-5 Debian:8.9/oldstable [all])
Conf unattended-upgrades (0.83.3.2+deb8u1 Debian:8.9/oldstable, Debian-Security:8/oldstable [all])
Conf python3-software-properties (0.92.25debian1 Debian:8.9/oldstable [all])
Conf software-properties-common (0.92.25debian1 Debian:8.9/oldstable [all])
Conf python3-uno (1:4.3.3-2+deb8u9 Debian-Security:8/oldstable [amd64])
Conf python3-wheel (0.24.0-1 Debian:8.9/oldstable [all])
Conf ufw (0.33-2 Debian:8.9/oldstable [all])

@edit

Myśle o znalezeniu komendy reinstal python3, usunięciu python3 i próby zainstalowania od nowa ale nie wiem czy mi na to pozwoli, bo teraz każda próba instalacji czegokolwiek kończy się tym co powyżej

Awatar użytkownika
marcin1982
Moderator
Posty: 1635
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Problem z apt-get install

Post autor: marcin1982 » 18 listopada 2017, 12:41

Tymczasowo albo na stałe wyłącz jeszcze to repozytorium javy:
Błąd http://ppa.launchpad.net xenial Release.gpg
Nie udało się połączyć z ppa.launchpad.net:http:
Co do pakietów zależnych pythona - spisuj wszystko co odinstalowujesz i spróbuj usunąć - tymczasowo te pakiety:

Kod: Zaznacz cały

dpkg --purge --force-all ufw gdebi-core gdebi
Ostatnią rzeczą jaką doradzam jest reinstalacja, ale to tutaj wygląda po prostu na zastarzały problem. Jak masz siłę to grzeb ręcznie. Potem możesz spróbować usuwać w ten sam sposób wszystkie/niektóre uwalone pakiety python3*, ale zwracając uwagę na to co jest usuwane, żeby nie uwalić systemu.

Janek
Posty: 14
Rejestracja: 17 listopada 2017, 23:43

Re: Problem z apt-get install

Post autor: Janek » 18 listopada 2017, 20:41

Oj Panowie historia jakich mało. Zacząłem usuwać te pakiety ręcznie jeden po drugim. Chciałem jeden pakiet przenieść żeby sprawdzić czy coś to pomoże zamiast tego przeniosłem cały home do python3 i spanikowałem i zrobiłem reboota po nim już nie mogłem się zalogować. Wtedy odpaliłem konsole i zacząłem kasować dalej te zależności jeden po drugim kiedy już usunąłem wszystko w całości, upgrade zadziałał, ale miałem czarny ekran po zalogowaniu. Wtedy sobie uświadomiłem że chyba usunąłem python3 w którym miałem cały home bo pomylił mi się mv i zrobiłem go w nie tą stronę co trzeba było. Zacząłem otwierać kolejne bowary i ściagać linux mint, jednak jako że zacząłem łapać "faze" postanowiłem poszperać w necie czy da się przywrócić te pliki, okazało się że w bashrc_history jest historia wlazłem tam i pokazało gdzie ja głupi człowiek to przeniosłem. Zacząłem się modlić żeby ten folder jeszcze tam był okazało się że jakimś cudem ten folder z python3 nie został skasowany i ten home tam jest. Przeniosłem go z powrotem w odpowiednie miejsce reboot i wszystko działa jak należy apt-get upgrade też.

Dzięki wielkie za pomoc wszystkim , a szczególnie Marcinowi który naprowadził mnie na to że odpala python3, który był uszkodzony.

System uratowany... chyba:D!!

@edit
Dla przyszłych pokoleń dokładnie co trzeba było zrobić to:

Kod: Zaznacz cały

dpkg --purge nazwa zależnosci
Tak dla każdego pakietu + usuwać

Kod: Zaznacz cały

rm /var/lib/dpkg/info/paket.remc # nie pamiętam tego rozszerzenia dokładnie
I tak do końca aż usuniecie wszystko.

Awatar użytkownika
marcin1982
Moderator
Posty: 1635
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Problem z apt-get install

Post autor: marcin1982 » 18 listopada 2017, 20:48

Ja rozumiem wzburzenie i trudną sytuację, ale na forum nie używamy wulgaryzmów. Post edytowałem.

Oznacz wątek jako rozwiązany przez dodanie [+] edytując temat - pierwszy post w wątku i zamykamy.

rm /var/lib/dpkg/info/paket.remc # nie pamiętam tego rozszerzenia dokładnie
Usuwać może nie. Można edytować "wyzwalacze", tłum. triggers - zahaszować, przesunąć w inne miejsce.

Po drugie - staraj się używać apt-get dist-upgrade. Link z wyjaśnieniem podałem wcześniej.

Zablokowany