[+] rc.local w debian 9

Ogólne pytania dotyczące systemu
Efyr
Posty: 6
Rejestracja: 17 października 2015, 16:08

[+] rc.local w debian 9

Post autor: Efyr » 10 sierpnia 2017, 13:08

Witam
Jestem niezbyt zaawansowany użytkownikiem debiana. Używam serwera chmury seafile. Aby mi startował automatycznie przy uruchomieniu dodawałem na końcu pliku etc/rc.local linie:

Kod: Zaznacz cały

/root/seafile-server/seafile.sh start &
(sleep 10; /root/seafile-server/seahub.sh start) &
exit 0


Wskazywały one ścieżki do skryptów startowych, jeden musiał być z opóźnieniem, bo występowały błędy

Przeinstalowałem debiana na najnowszy z numerem 9 i tam nie ma pliku /etc/rc.local
Stworzyłem go przez nano, ale i tak nie startuje. Jak najłatwiej sobie z tym poradzić?
Ostatnio zmieniony 10 sierpnia 2017, 23:15 przez Efyr, łącznie zmieniany 1 raz.

Awatar użytkownika
dedito
Moderator
Posty: 2245
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: rc.local w debian 9

Post autor: dedito » 10 sierpnia 2017, 13:39

viewtopic.php?f=18&t=34578

Kod: Zaznacz cały

systemctl enable rc-local
systemctl start rc-local.service

Efyr
Posty: 6
Rejestracja: 17 października 2015, 16:08

Re: rc.local w debian 9

Post autor: Efyr » 10 sierpnia 2017, 14:35

Dziękuję za pomoc. Wieczorem jak będę w domu sprawdzę czy mi zadziała i dam znać

PS. z tamtego podlinkowanego tematu:

Kod: Zaznacz cały

 chmod 755 /etc/rc.local
też wykonać?

Awatar użytkownika
dedito
Moderator
Posty: 2245
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: rc.local w debian 9

Post autor: dedito » 10 sierpnia 2017, 16:28

Jeżeli tego wcześniej nie zrobiłeś, to tak, plik powinien mieć atrybut wykonywalności.

Efyr
Posty: 6
Rejestracja: 17 października 2015, 16:08

Re: rc.local w debian 9

Post autor: Efyr » 10 sierpnia 2017, 18:25

Zrobiłem chmod 755 /etc/rc.local

Przed resetem próbowałem jeszcze komendę

Kod: Zaznacz cały

systemctl enable rc-local
ale wywalało błąd:

Kod: Zaznacz cały

systemctl enable rc-local
The unit files have no installation config (WantedBy, RequiredBy, Also, Alias
settings in the [Install] section, and DefaultInstance for template units).
This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
   .wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
   a requirement dependency on it.
3) A unit may be started when needed via activation (socket, path, timer,
   D-Bus, udev, scripted systemctl call, ...).
4) In case of template units, the unit is meant to be enabled with some
   instance name specified.
Po tym błędzie drugiej komendy nie próbowałem. Zrobiłem reset i poszło

Więc ostatecznie chyba wystarczyło stworzyć plik oraz nadać mu prawa wykonywalności - może się innym przyda, cóż błąd laika

Dziękuję serdecznie za pomoc

Awatar użytkownika
dedito
Moderator
Posty: 2245
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: rc.local w debian 9

Post autor: dedito » 10 sierpnia 2017, 18:39

W takim razie oznacz wątek zgodnie z regulaminem forum

Awatar użytkownika
Morfik
Beginner
Posty: 112
Rejestracja: 21 lutego 2009, 21:00

Re: rc.local w debian 9

Post autor: Morfik » 10 sierpnia 2017, 19:13

Ten powyższy błąd, to nie błąd. Poza tym, w pliku usługi jest stosowna informacja:

Kod: Zaznacz cały

$ systemctl cat rc.local.service
# /lib/systemd/system/rc-local.service
...
# This unit gets pulled automatically into multi-user.target by
# systemd-rc-local-generator if /etc/rc.local is executable.

Efyr
Posty: 6
Rejestracja: 17 października 2015, 16:08

Re: [+] rc.local w debian 9

Post autor: Efyr » 10 sierpnia 2017, 23:17

Ok. Czyli możliwe, że to właśnie zadziałało. Ja potraktowałem ten komunikat jako błąd. Dziękuję za wyjaśnienie.

A że sprawę rozwiązałem oznaczyłem odpowiednio temat.

Jeszcze raz serdecznie dziękuję wszystkim za pomoc

Zablokowany