Problem z instalacj

Ogólne pytania dotyczące systemu
adam3
Posty: 3
Rejestracja: 05 marca 2015, 10:40

Problem z instalacją kadu na Wheezy 7.8

Post autor: adam3 » 05 marca 2015, 11:11

Witam wszystkich.Jestem początkującym użytkownikiem debiana, przeszedłem ze slackware i chciałem spróbować sił na tym systemie.Zainstalowałem ostatnią wersje stabilną.Dotychczas jakoś sobie na nim radziłem, ale z instalacją kadu nie mogę sobie poradzić i męczę się z tymi zależnościami itp.Dochodzi do tego że np libqute4 z czymś tam sugeruje mi usunięcie libgadu i kadu w aptitude.. i nie tylko to i wkółko macieju.Kadu jakie chce zainstalowac to wersja 1.3.1.Ściągnałem następujące pliki: kadu_1.3-1_i386.deb kadu-dev_1.3-1_i386.deb libkadu_1.3-1_i386.deb kadu-common_1.3-1_all.deb kadu-themes_1.3-1_all.deb do jednego katalogu i wydaje polecenie dpkg -i *deb i dostaje takie cos:

Kod: Zaznacz cały

 (Odczytywanie bazy danych ... 94167 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do zastąpienia pakietu kadu 1.3-1 (wykorzystując kadu_1.3-1_i386.deb) ...
Rozpakowywanie pakietu zastępującego kadu ...
Przygotowywanie do zastąpienia pakietu kadu-common 1.3-1 (wykorzystując kadu-common_1.3-1_all.deb) ...
Rozpakowywanie pakietu zastępującego kadu-common ...
Przygotowywanie do zastąpienia pakietu kadu-dev 1.3-1 (wykorzystując kadu-dev_1.3-1_i386.deb) ...
Rozpakowywanie pakietu zastępującego kadu-dev ...
Przygotowywanie do zastąpienia pakietu kadu-themes 1.3-1 (wykorzystując kadu-themes_1.3-1_all.deb) ...
Rozpakowywanie pakietu zastępującego kadu-themes ...
Przygotowywanie do zastąpienia pakietu libkadu 1.3-1 (wykorzystując libkadu_1.3-1_i386.deb) ...
Rozpakowywanie pakietu zastępującego libkadu ...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu kadu:
 kadu zależy od libqca2-plugin-ossl; jednakże:
  Pakiet libqca2-plugin-ossl nie jest zainstalowany.
 kadu zależy od libqt4-sql-sqlite; jednakże:
  Pakiet libqt4-sql-sqlite nie jest zainstalowany.
 kadu zależy od libqt4-svg (>= 4:4.5.3); jednakże:
  Pakiet libqt4-svg nie jest zainstalowany.
 kadu zależy od libgadu3 (>= 1:1.12.0~pre+r1278); jednakże:
  Pakiet libgadu3 nie jest zainstalowany.
 kadu zależy od libgcrypt20 (>= 1.6.0); jednakże:
  Pakiet libgcrypt20 nie jest zainstalowany.
 kadu zależy od libmpdclient2 (>= 2.1); jednakże:
  Pakiet libmpdclient2 nie jest zainstalowany.
 kadu zależy od libotr5 (>= 4.0.0); jednakże:
  Pakiet libotr5 nie jest zainstalowany.
 kadu zależy od libphonon4 (>= 4:4.2.0); jednakże:
  Pakiet libphonon4 nie jest zainstalowany.
 kadu zależy od libqt4-declarative (>= 4:4.7.0~beta1); jednakże:
  Pakiet libqt4-declarative nie jest zainstalowany.
 kadu zależy od libqt4-network (>= 4:4.5.3); j
dpkg: błąd przetwarzania kadu (--install):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Konfigurowanie pakietu kadu-common (1.3-1) ...
Konfigurowanie pakietu kadu-dev (1.3-1) ...
Konfigurowanie pakietu kadu-themes (1.3-1) ...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libkadu:
 libkadu zależy od libarchive13; jednakże:
  Pakiet libarchive13 nie jest zainstalowany.
 libkadu zależy od libqt4-declarative (>= 4:4.7.0~rc1); jednakże:
  Pakiet libqt4-declarative nie jest zainstalowany.
 libkadu zależy od libqt4-network (>= 4:4.7.0~beta1); jednakże:
  Pakiet libqt4-network nie jest zainstalowany.
 libkadu zależy od libqt4-script (>= 4:4.5.3); jednakże:
  Pakiet libqt4-script nie jest zainstalowany.
 libkadu zależy od libqt4-sql (>= 4:4.5.3); jednakże:
  Pakiet libqt4-sql nie jest zainstalowany.
 libkadu zależy od libqt4-svg (>= 4:4.5.3); jednakże:
  Pakiet libqt4-svg nie jest zainstalowany.
 libkadu zależy od libqt4-xmlpatterns (>= 4:4.5.3); jednakże:
  Pakiet libqt4-xmlpatterns nie jest zainstalowany.
 libkadu zależy od libqtwebkit4 (>= 2.1.0~2011week13); jednakże:
  Pakiet libqtwebkit4 nie jest zainstalowany.
 libkadu zależy od libstdc++6 (>= 4.9); jednakże:
  Wersją libstdc++6:i386 w system
dpkg: błąd przetwarzania libkadu (--install):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Przetwarzanie wyzwalaczy pakietu man-db...
Przetwarzanie wyzwalaczy pakietu menu...
Przetwarzanie wyzwalaczy pakietu desktop-file-utils...
Przetwarzanie wyzwalaczy pakietu hicolor-icon-theme...
Wystąpiły błędy podczas przetwarzania:
 kadu
 libkadu
I gdy np próbuje zainstalować pakiet libqt4-declarative to znowu tworzy mi się drzewo że brakuje kolejnych pakietów żeby móc zainstalować ten pakiet, i gdy instaluje któryś z nich np wymagane libqt4-network to wraca do punktu wyjscia (ten pakiet się nie instaluje).Troche pomotane, sam się w tym chyba zamotałem już.A sugerowana apt-get install -f nic nie daje.Pewnie znajać życie ja coś źle robie, ale dopiero zaczynam swoja przygodę z tym systemem więc prosze o wyrozumiałość.Debiana wybrałem bo sprzet jest leciwy jest, 8 letni z 1 GB Ram.A środowisko to LXDE.Dlatego jak zainstalować kadu i się pozbyć tych problemów z zależnościami? A nie chce juz motać bardziej w tych pakietach żeby nie popsuć niczego.Będę wdzięczny za pomoc.Pozdrawiam.

nowa25
Posty: 10
Rejestracja: 17 listopada 2014, 10:46

Post autor: nowa25 » 05 marca 2015, 11:53

Witam
Zainstaluj wersję kadu (0.11.2-1) dla wheezy z repozytorium debiana, jeżeli chcesz nowsza wersję to polecam poradnik entries/259-Przepakietowywanie

Awatar użytkownika
Yampress
Administrator
Posty: 6176
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Post autor: Yampress » 05 marca 2015, 18:52

nowa25 pisze:Witam
Zainstaluj wersję kadu (0.11.2-1) dla wheezy z repozytorium debiana, jeżeli chcesz nowsza wersję to polecam poradnik entries/259-Przepakietowywanie

Aktualnie ciagnie wersje 1.2 z jessie, której w normalny sposób nie da się przepakietować na wheezym. I trzeba nie żle się namęczyć, a komuś kto nie potrafi to odradzam.
Pozostaje repo Matiego http://repozytorium.mati75.eu jako backport

adam3
Posty: 3
Rejestracja: 05 marca 2015, 10:40

Post autor: adam3 » 05 marca 2015, 23:48

nowa25 pisze:Witam
Zainstaluj wersję kadu (0.11.2-1) dla wheezy z repozytorium debiana, jeżeli chcesz nowsza wersję to polecam poradnik entries/259-Przepakietowywanie
Dzięki za próbę pomocy, próbuje instalować wspomnianą wersję ale cały czas jest to samo, choć zaczęło się obiecująco

Kod: Zaznacz cały

/home/adam/Pobrane/kadu# dpkg -i *deb
Wybieranie wcześniej niewybranego pakietu kadu.
(Odczytywanie bazy danych ... 142966 plików i katalogów obecnie zainstalowanych.)
Rozpakowywanie pakietu kadu (z kadu_0.11.2-1_i386.deb) ...
Wybieranie wcześniej niewybranego pakietu kadu-common.
Rozpakowywanie pakietu kadu-common (z kadu-common_0.11.2-1_all.deb) ...
Wybieranie wcześniej niewybranego pakietu kadu-external-modules.
Rozpakowywanie pakietu kadu-external-modules (z kadu-external-modules_0.11.2-1_i386.deb) ...
Wybieranie wcześniej niewybranego pakietu kadu-themes.
Rozpakowywanie pakietu kadu-themes (z kadu-themes_0.11.2-1_all.deb) ...
Wybieranie wcześniej niewybranego pakietu libgadu3.
Rozpakowywanie pakietu libgadu3 (z libgadu3_1.11.2-1+deb7u2_i386.deb) ...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu kadu:
 kadu zależy od libqca2-plugin-ossl; jednakże:
  Pakiet libqca2-plugin-ossl nie jest zainstalowany.
 kadu zależy od libqt4-sql-sqlite; jednakże:
  Pakiet libqt4-sql-sqlite nie jest zainstalowany.
 kadu zależy od libqt4-svg; jednakże:
  Pakiet libqt4-svg nie jest zainstalowany.
 kadu zależy od libindicate-qt1 (>= 0.2.5); jednakże:
  Pakiet libindicate-qt1 nie jest zainstalowany.
 kadu zależy od libmpdclient2 (>= 2.1); jednakże:
  Pakiet libmpdclient2 nie jest zainstalowany.
 kadu zależy od libphonon4 (>= 4:4.2.0); jednakże:
  Pakiet libphonon4 nie jest zainstalowany.
 kadu zależy od libqca2 (>= 2.0.2); jednakże:
  Pakiet libqca2 nie jest zainstalowany.
 kadu zależy od libqt4-dbus (>= 4:4.6.1); jednakże:
  Pakiet libqt4-dbus nie jest zainstalowany.
 kadu zależy od libqt4-network (>= 4:4.7.0~beta1); jednakże:
  Pakiet libqt4-network nie jest zainstalowany.
 kadu zależy od libqt4-script (>= 4:4.5.3); jednakże:
  Pakiet 
dpkg: błąd przetwarzania kadu (--install):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Konfigurowanie pakietu kadu-common (0.11.2-1) ...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu kadu-external-modules:
 kadu-external-modules zależy od kadu (>= 0.10.0-2); jednakże:
  Pakiet kadu nie jest jeszcze skonfigurowany.
 kadu-external-modules zależy od libqt4-script (>= 4:4.5.3); jednakże:
  Pakiet libqt4-script nie jest zainstalowany.

dpkg: błąd przetwarzania kadu-external-modules (--install):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Konfigurowanie pakietu kadu-themes (0.11.2-1) ...
Konfigurowanie pakietu libgadu3 (1:1.11.2-1+deb7u2) ...
Przetwarzanie wyzwalaczy pakietu desktop-file-utils...
Przetwarzanie wyzwalaczy pakietu gnome-menus...
Przetwarzanie wyzwalaczy pakietu menu...
Przetwarzanie wyzwalaczy pakietu man-db...
Przetwarzanie wyzwalaczy pakietu hicolor-icon-theme...
Wystąpiły błędy podczas przetwarzania:
 kadu
 kadu-external-modules
ale później znowu to samo czyli..

Kod: Zaznacz cały

root@kutyla:/home/adam/Pobrane/kadu# apt-get install  libqt4-script
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Należy uruchomić "apt-get -f install", aby naprawić poniższe problemy:
Następujące pakiety mają niespełnione zależności:
 kadu : Wymaga: libqca2-plugin-ossl ale nie zostanie zainstalowany
        Wymaga: libqt4-sql-sqlite ale nie zostanie zainstalowany
        Wymaga: libqt4-svg ale nie zostanie zainstalowany
        Wymaga: libindicate-qt1 (>= 0.2.5) ale nie da się go zainstalować
        Wymaga: libmpdclient2 (>= 2.1) ale nie da się go zainstalować
        Wymaga: libphonon4 (>= 4:4.2.0) ale nie zostanie zainstalowany
        Wymaga: libqca2 (>= 2.0.2) ale nie zostanie zainstalowany
        Wymaga: libqt4-dbus (>= 4:4.6.1) ale nie zostanie zainstalowany
        Wymaga: libqt4-network (>= 4:4.7.0~beta1) ale nie zostanie zainstalowany
        Wymaga: libqt4-sql (>= 4:4.5.3) ale nie zostanie zainstalowany
        Wymaga: libqt4-xml (>= 4:4.5.3) ale nie zostanie zainstalowany
        Wymaga: libqt4-xmlpatterns (>= 4:4.5.3) ale nie zostanie zainstalowany
        Wymaga: libqtcore4 (>= 4:4.7.0~beta1) ale nie zostanie zainstalowany
        Wymaga: libqtgui4 (>= 4:4.7.0~rc1) ale nie zostanie zainstalowany
        Wymaga: libqtwebkit4 (>= 2.1.0~2011week13) ale nie zostanie zainstalowany
        Wymaga: phonon ale nie zostanie zainstalowany
 libqt4-script : Wymaga: libqtcore4 (= 4:4.8.2+dfsg-11) ale nie zostanie zainstalowany
                 Wymaga: libqtdbus4 (= 4:4.8.2+dfsg-11) ale nie zostanie zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać "apt-get -f install" bez pakietów (lub podać rozwiązanie).
root@kutyla:/home/adam/Pobrane/kadu# apt-get install libqca2-plugin-ossl 
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Należy uruchomić "apt-get -f install", aby naprawić poniższe problemy:
Następujące pakiety mają niespełnione zależności:
 kadu : Wymaga: libqt4-sql-sqlite ale nie zostanie zainstalowany
        Wymaga: libqt4-svg ale nie zostanie zainstalowany
        Wymaga: libindicate-qt1 (>= 0.2.5) ale nie da się go zainstalować
        Wymaga: libmpdclient2 (>= 2.1) ale nie da się go zainstalować
        Wymaga: libphonon4 (>= 4:4.2.0) ale nie zostanie zainstalowany
        Wymaga: libqca2 (>= 2.0.2) ale nie zostanie zainstalowany
        Wymaga: libqt4-dbus (>= 4:4.6.1) ale nie zostanie zainstalowany
        Wymaga: libqt4-network (>= 4:4.7.0~beta1) ale nie zostanie zainstalowany
        Wymaga: libqt4-script (>= 4:4.5.3) ale nie zostanie zainstalowany
        Wymaga: libqt4-sql (>= 4:4.5.3) ale nie zostanie zainstalowany
        Wymaga: libqt4-xml (>= 4:4.5.3) ale nie zostanie zainstalowany
        Wymaga: libqt4-xmlpatterns (>= 4:4.5.3) ale nie zostanie zainstalowany
        Wymaga: libqtcore4 (>= 4:4.7.0~beta1) ale nie zostanie zainstalowany
        Wymaga: libqtgui4 (>= 4:4.7.0~rc1) ale nie zostanie zainstalowany
        Wymaga: libqtwebkit4 (>= 2.1.0~2011week13) ale nie zostanie zainstalowany
        Wymaga: phonon ale nie zostanie zainstalowany
 kadu-external-modules : Wymaga: libqt4-script (>= 4:4.5.3) ale nie zostanie zainstalowany
 libqca2-plugin-ossl : Wymaga: libqca2 (>= 2.0.2) ale nie zostanie zainstalowany
                       Wymaga: libqtcore4 (>= 4:4.8.0~) ale nie zostanie zainstalowany
E:  Niespełnione zależności. Proszę spróbować wykonać "apt-get -f install"  bez pakietów (lub podać rozwiązanie).
I później np chce zainstalowac libqca2 i wraca do punktu wyjścia (nie instaluje się).Pewnie ja coś robię nie tak i problem jest banalny i dlatego chciałbym poznać rozwiązanie tego.Teraz ćwicze na virtualboxie na innym sprzęcie żeby odpowiednio wszystko zainstalowac.Bawiłem się w aptitude i usuwało mi pakiety potrzebne do instalacji kadu, np jak coś z libq4 to usuwało mi libkadu itp, zgłupiałem totalnie.Dlatego problem pewnie jest banalny i ja coś mieszam w tych pakietach, może jakaś kolejność musi być zachowana? jak to wszystko naraz zainstalować żeby się to nie gryzło i wzajemnie nie wywalało w aptitude?

Awatar użytkownika
ilin
Senior Member
Posty: 2287
Rejestracja: 26 sierpnia 2007, 11:54
Lokalizacja: PRLu

Post autor: ilin » 06 marca 2015, 06:48

Kod: Zaznacz cały

aptitude update

Kod: Zaznacz cały

aptitude install kadu

nowa25
Posty: 10
Rejestracja: 17 listopada 2014, 10:46

Post autor: nowa25 » 06 marca 2015, 12:53

Spróbuj odinstalować obecne kadu i zalezności z nim związane, które do tej pory instalowałeś

Kod: Zaznacz cały

aptitude --purge remove kadu

Kod: Zaznacz cały

aptitude autoremove kadu
a potem zrób to co napisał ilin

Wydaje mi się, że na siłę zainstalowałeś różne wersje kadu i zależności, które teraz się gryzą. Musisz wyczyścić poprzednią instalację programu i zainstalować go od nowa.

adam3
Posty: 3
Rejestracja: 05 marca 2015, 10:40

Post autor: adam3 » 07 marca 2015, 09:29

Dzięki za pomoc, poradziłem sobie, i zrobiłem dokładnie tak jak pisałaś, usunąłem poprzednie śmieci po kadu i zainstalowałem to 11.2, brakowało wtedy tez pakietów ale instalacja ich poszła bez żadnego gryzienia itp a kadu działa, więc problem rozwiązany.

Awatar użytkownika
marcin1982
Moderator
Posty: 1721
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Post autor: marcin1982 » 07 marca 2015, 10:14

Proszę oznaczyć wątek jako rozwiązany zgodnie z regulaminem forum.

Awatar użytkownika
Yampress
Administrator
Posty: 6176
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Post autor: Yampress » 08 marca 2015, 10:05

Wiesz powoli już czas zastanawiać się nad przejściem na Jessie. Wydanie Jessie jako stable to kwestia tygodni. Już jest w miare stabilne i dobrze chodzi. No i wersja kadu wyższa. Ja mam 1.5, ale może wkrótce będzie 2. W repo jest 1.2 Ale na Jessie chodzi tez oryginalne gg. Więc jeśli lubisz reklamy chodzi dobrze bez kłopotów z zależnościami. Rozpakowujesz , uruchamiasz i chodzi.

ODPOWIEDZ