Aktualizacja apta w ga

Ogólne pytania dotyczące systemu
Kamzor
Posty: 63
Rejestracja: 28 kwietnia 2010, 05:01
Lokalizacja: Zieleniec/Wrocław

Aktualizacja apta w gałęzi testowej Debiana

Post autor: Kamzor » 24 maja 2012, 20:33

Hej.
O
d jakiegoś tygodnia polecenie:

Kod: Zaznacz cały

aptitude full-upgrade
próbuje zaktualizować pakiet apt, ale wyświetla następujący problem z zależnościami:

Kod: Zaznacz cały

libept1 : Depends: libapt-pkg4.10 which is a virtual package.
Co powinienem zrobić? Aptitude proponuje usunąć pakiet libept1.Czy to jest bezpieczne? Nie wiem nawet do czego to służy?

Awatar użytkownika
DaVidoSS
Junior Member
Posty: 875
Rejestracja: 06 marca 2010, 11:26
Lokalizacja: ~/

Post autor: DaVidoSS » 24 maja 2012, 20:46

Pokaż /etc/apt/sources.list

Kamzor
Posty: 63
Rejestracja: 28 kwietnia 2010, 05:01
Lokalizacja: Zieleniec/Wrocław

Post autor: Kamzor » 24 maja 2012, 20:54

Kod: Zaznacz cały

kamzor@red:~$ cat /etc/apt/sources.list
deb http://ftp.pl.debian.org/debian/ wheezy main contrib non-free
deb-src http://ftp.pl.debian.org/debian/ wheezy main contrib non-free


deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

Awatar użytkownika
DaVidoSS
Junior Member
Posty: 875
Rejestracja: 06 marca 2010, 11:26
Lokalizacja: ~/

Post autor: DaVidoSS » 24 maja 2012, 21:24

Zapewne należy zamienić pakiet libept1 na libept1.4.10 lub nowszy. Pakiet libept1 występuje w Squeeze.

Pokaż:

Kod: Zaznacz cały

apt-get update
apt-cache policy libept1*


Kamzor
Posty: 63
Rejestracja: 28 kwietnia 2010, 05:01
Lokalizacja: Zieleniec/Wrocław

Post autor: Kamzor » 24 maja 2012, 21:51

Kod: Zaznacz cały

root@red:/home/kamzor# apt-cache policy libept1*
libept1.4.12:
  Installed: 1.0.6.1
  Candidate: 1.0.6.1
  Version table:
 *** 1.0.6.1 0
        500 http://ftp.pl.debian.org/debian/ wheezy/main amd64 Packages
        100 /var/lib/dpkg/status
libept-dev:
  Installed: (none)
  Candidate: 1.0.6.1
  Version table:
     1.0.6.1 0
        500 http://ftp.pl.debian.org/debian/ wheezy/main amd64 Packages
libept1:
  Installed: 1.0.5
  Candidate: 1.0.5
  Version table:
 *** 1.0.5 0
        100 /var/lib/dpkg/status

Kod: Zaznacz cały

root@red:/home/kamzor# aptitude search libept
[  0%] Reading package lists
p   libept-dev                      - High-level library for managing Debian pac
i   libept1                         - High-level library for managing Debian pac
i A libept1.4.12                    - High-level library for managing Debian pac

Awatar użytkownika
DaVidoSS
Junior Member
Posty: 875
Rejestracja: 06 marca 2010, 11:26
Lokalizacja: ~/

Post autor: DaVidoSS » 24 maja 2012, 22:09

Pokaż jeszcze:

Kod: Zaznacz cały

aptitude show libept1
aptitude show libept1.4.12

olx

Post autor: olx » 26 maja 2012, 16:27

U mnie też są problemy z aktualizacją.

Kod: Zaznacz cały

Następujące pakiety mają niespełnione zależności:
 libatk-adaptor-data : W konflikcie z: libatk-adaptor-schemas ale zainstalowana jest wersja 2.4.0-2.
 libept1 : Wymaga: libapt-pkg4.10 który jest pakietem wirtualnym.
Następujące działania rozwiążą problemy z zależnościami:

     Usunięcie następujących pakietów:                     
1)     libept1                                             

     Zatrzymanie bieżących wersji następujących pakietów:  
2)     libatk-adaptor-data [niezainstalowany]              

     Pozostawienie następujących problemów z zależnościami:
3)     libatk-adaptor poleca libatk-adaptor-data    

Kod: Zaznacz cały

apt-cache policy libept1*

libept1.4.12:
  Zainstalowana: (brak)
  Kandydująca:   1.0.6.1
  Tabela wersji:
     1.0.6.1 0
        500 [URL]http://ftp.pl.debian.org/debian/[/URL] testing/main amd64 Packages
libept-dev:
  Zainstalowana: (brak)
  Kandydująca:   1.0.6.1
  Tabela wersji:
     1.0.6.1 0
        500 [URL]http://ftp.pl.debian.org/debian/[/URL] testing/main amd64 Packages
libept1:
  Zainstalowana: 1.0.5
  Kandydująca:   1.0.5
  Tabela wersji:
 *** 1.0.5 0
        100 /var/lib/dpkg/status

Kod: Zaznacz cały

aptitude show libept1

Pakiet: libept1                              
Stan: zainstalowany
Zainstalowany automatycznie: nie
Wersja: 1.0.5
Priorytet: ważny
Sekcja: libs
Opiekun: Enrico Zini <enrico@debian.org>
Architektura: amd64
Rozmiar rozpakowanego: 446 k
Wymaga: libapt-pkg4.10, libc6 (>= 2.2.5), libgcc1 (>= 1:4.1.1), libstdc++6 (>=
        4.4.0), libxapian22, zlib1g (>= 1:1.1.4)
Opis: High-level library for managing Debian package information
 The library defines a very minimal framework in which many sources of data
 about Debian packages can be implemented and queried together. 
 
 The library includes four data sources: 
 
 * APT: access the APT database 
 * Debtags: access the Debtags tag information 
 * Popcon: access Popcon package scores 
 * The Xapian index built by apt-xapian-index 
   
 This is the shared library.

Kod: Zaznacz cały

aptitude show libept1.4.12

Pakiet: libept1.4.12                         
Nowy: tak
Stan: niezainstalowany
Wersja: 1.0.6.1
Priorytet: ważny
Sekcja: libs
Opiekun: Enrico Zini <enrico@debian.org>
Architektura: amd64
Rozmiar rozpakowanego: 381 k
Wymaga: libapt-pkg4.12 (>= 0.8.16~exp9), libc6 (>= 2.4), libgcc1 (>= 1:4.1.1),
        libstdc++6 (>= 4.4.0), libxapian22, zlib1g (>= 1:1.2.6)
Opis: Wysokopoziomowa biblioteka do zarządzania informacjami o pakietach Debiana
 Biblioteka ta tworzy bardzo minimalny szkielet, w którym wiele źródeł danych o
 pakietach Debiana może zostać zaimplementowanych i przetwarzanych razem. 
 
 Biblioteka ta zawiera cztery źródła danych: 
 
 * APT: dostęp do bazy APT 
 * Debtags: dostęp do Debtags (informacji o tagach) 
 * Popcon: dostęp do Popcon (indeksu popularności) 
 * Indeks Xapian zbudowany przez apt-xapian-index 
   
 Jest to biblioteka współdzielona.


Awatar użytkownika
DaVidoSS
Junior Member
Posty: 875
Rejestracja: 06 marca 2010, 11:26
Lokalizacja: ~/

Post autor: DaVidoSS » 27 maja 2012, 01:37

libept1 można śmiało usunąć poprzez np.:

Kod: Zaznacz cały

apt-get dist-upgrade

ODPOWIEDZ