Raspberry łączenie z wifi podczas uruchamiania

Tematy związane z RPI
sebo
Posty: 6
Rejestracja: 02 lutego 2017, 13:23

Raspberry łączenie z wifi podczas uruchamiania

Post autor: sebo » 17 lipca 2017, 08:02

Mam problem z prawidłowym skonfigurowaniem interfejsu wlan0 aby automatycznie łączył się z wifi podczas bootowania. W tej chwili po uruchomieniu RPI nie łączy się z siecią wifi, ale wystarczy choć na chwilę wpiąć kabel sieci Ethernet do przewodowej karty sieciowej, a po chwili rpi łączy się z wifi.
Może ktoś z Was miał podobny problem i zna rozwiązanie tego problemu ?
Dodam jeszcze, że dodałem do pliku /etc/rc.local wpis:
Ifup wlan0

To też się nie sprawdziło.


Moja konfiguracja:
Plik /etc/network/interfaces

Kod: Zaznacz cały

auto wlan0 
allow-hotplug wlan0 
iface wlan0 inet static 
address ******** 
netmask ********** 
gateway ********** 
dns-nameservers ******** 
wpa-passphrase *********
wpa-ssid ********** 
wpa-scan-ssid 1 
metric 1

auto eth0 
allow-hotplug eth0 
iface eth0 inet static 
address *********** 
netmask ************ 
gateway ************ 
dns-nameservers *******

Awatar użytkownika
dedito
Moderator
Posty: 2245
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Raspberry łączenie z wifi podczas uruchamiania

Post autor: dedito » 17 lipca 2017, 08:50

A jaki masz system na tym Rpi?
Odwiedzałeś stronę producenta? -> https://www.raspberrypi.org/documentati ... /wireless/

Awatar użytkownika
marcin1982
Moderator
Posty: 1636
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Raspberry łączenie z wifi podczas uruchamiania

Post autor: marcin1982 » 23 lipca 2017, 11:10

sebo
Do prezentacji wyników poleceń z konsoli proszę używać tagów CODE.

ODPOWIEDZ