[+]Problem z połączenem WIFI (WPA_SUPPLICANT)

Masz problemy z siecią bądź internetem? Zapytaj tu
Eido
Posty: 6
Rejestracja: 14 czerwca 2019, 12:08

[+]Problem z połączenem WIFI (WPA_SUPPLICANT)

Post autor: Eido » 14 czerwca 2019, 12:29

Cześć wszystkim. Na początku pragnę poinformować, że jeśli chodzi o Debiana jestem totalnym żółtodziobem. Mam problem z zagadnieniem z tematu. Korzystałem z tego poradnika: https://pl.wikibooks.org/wiki/Debian_-_ ... a/Internet
Po zainstalowaniu pakietu wpa supplicant nie pokazuje mi interfrejsu WLAN, co za tym idzie nie mogę nic zrobić dalej. Gdzie popełniam błąd? Może korzystam nie z tej paczki? Poniżej zdjęcie z terminala. Pozdrawiam i czekam na pomoc ;)

Awatar użytkownika
dedito
Moderator
Posty: 2950
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z połączenem WIFI (WPA_SUPPLICANT)

Post autor: dedito » 14 czerwca 2019, 12:50

Pewnie brakuje firmware do karty.
Pokaż

Kod: Zaznacz cały

lspci -nk
lub

Kod: Zaznacz cały

lsusb
jeśli karta jest na USB.

Eido
Posty: 6
Rejestracja: 14 czerwca 2019, 12:08

Re: Problem z połączenem WIFI (WPA_SUPPLICANT)

Post autor: Eido » 14 czerwca 2019, 13:09

Wpisałem. Oto co mi wyświetliło:

Kod: Zaznacz cały

00:00.0 0600: 8086:0154 (rev 09)
	Subsystem: 17aa:21f3
	Kernel driver in use: ivb_uncore
00:02.0 0300: 8086:0166 (rev 09)
	Subsystem: 17aa:21f3
	Kernel driver in use: i915
	Kernel modules: i915
00:14.0 0c03: 8086:1e31 (rev 04)
	Subsystem: 17aa:21f3
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci
00:16.0 0780: 8086:1e3a (rev 04)
	Subsystem: 17aa:21f3
	Kernel driver in use: mei_me
	Kernel modules: mei_me
00:16.3 0700: 8086:1e3d (rev 04)
	Subsystem: 17aa:21f3
	Kernel driver in use: serial
00:19.0 0200: 8086:1502 (rev 04)
	Subsystem: 17aa:21f3
	Kernel driver in use: e1000e
	Kernel modules: e1000e
00:1a.0 0c03: 8086:1e2d (rev 04)
	Subsystem: 17aa:21f3
	Kernel driver in use: ehci-pci
	Kernel modules: ehci_pci
00:1b.0 0403: 8086:1e20 (rev 04)
	Subsystem: 17aa:21f3
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
00:1c.0 0604: 8086:1e10 (rev c4)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.1 0604: 8086:1e12 (rev c4)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.2 0604: 8086:1e14 (rev c4)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1d.0 0c03: 8086:1e26 (rev 04)
	Subsystem: 17aa:21f3
	Kernel driver in use: ehci-pci
	Kernel modules: ehci_pci
00:1f.0 0601: 8086:1e55 (rev 04)
	Subsystem: 17aa:21f3
	Kernel driver in use: lpc_ich
	Kernel modules: lpc_ich
00:1f.2 0106: 8086:1e03 (rev 04)
	Subsystem: 17aa:21f3
	Kernel driver in use: ahci
	Kernel modules: ahci
00:1f.3 0c05: 8086:1e22 (rev 04)
	Subsystem: 17aa:21f3
	Kernel driver in use: i801_smbus
	Kernel modules: i2c_i801
02:00.0 0880: 1180:e823 (rev 07)
	Subsystem: 17aa:21f3
	Kernel driver in use: sdhci-pci
	Kernel modules: sdhci_pci
03:00.0 0280: 8086:0085 (rev 34)
	Subsystem: 8086:1311
	Kernel modules: iwlwifi
Ostatnio zmieniony 14 czerwca 2019, 13:41 przez Eido, łącznie zmieniany 1 raz.

Awatar użytkownika
dedito
Moderator
Posty: 2950
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z połączenem WIFI (WPA_SUPPLICANT)

Post autor: dedito » 14 czerwca 2019, 13:20

Sterownik iwlwifi wygląda na załadowany.
Pokaż teraz:

Kod: Zaznacz cały

ip link
dmesg | grep -i iwl
rfkill list all
I napisz co to za sprzęt na którym instalujesz Debiana.

Eido
Posty: 6
Rejestracja: 14 czerwca 2019, 12:08

Re: Problem z połączenem WIFI (WPA_SUPPLICANT)

Post autor: Eido » 14 czerwca 2019, 13:42

Proszę:

Kod: Zaznacz cały

jakub@eido:~$ sudo ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s25: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000
    link/ether 28:d2:44:26:ad:bd brd ff:ff:ff:ff:ff:ff
jakub@eido:~$ sudo dmesg | grep -i iw1
jakub@eido:~$ sudo rfkill list all
0: tpacpi_bluetooth_sw: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

Awatar użytkownika
dedito
Moderator
Posty: 2950
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z połączenem WIFI (WPA_SUPPLICANT)

Post autor: dedito » 14 czerwca 2019, 13:48

Napisz co to za sprzęt na którym instalujesz Debiana.
Którego Debiana instalujesz, podaj link do obrazu.

Eido
Posty: 6
Rejestracja: 14 czerwca 2019, 12:08

Re: Problem z połączenem WIFI (WPA_SUPPLICANT)

Post autor: Eido » 14 czerwca 2019, 13:54

Sprzęt na którym pracuję to laptop Lenevo thinkpad T430. System pobierałem z tej strony: https://cdimage.debian.org/debian-cd/cu ... bt-hybrid/
Wersja z lxde.

Awatar użytkownika
dedito
Moderator
Posty: 2950
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z połączenem WIFI (WPA_SUPPLICANT)

Post autor: dedito » 14 czerwca 2019, 14:01

Zainstaluj paczkę firmware-iwlwifi.
https://wiki.debian.org/iwlwifi

Eido
Posty: 6
Rejestracja: 14 czerwca 2019, 12:08

Re: Problem z połączenem WIFI (WPA_SUPPLICANT)

Post autor: Eido » 14 czerwca 2019, 14:15

Niestety nadal jest to samo :(

Kod: Zaznacz cały

jakub@eido:~$ cd Pulpit
jakub@eido:~/Pulpit$ ls
firmware-iwlwifi_20161130-5_all.deb  wifi.odt  wpasupplicant_2.4-1+deb9u4_amd64.deb
jakub@eido:~/Pulpit$ sudo dpkg -i firmware-iwlwifi_20161130-5_all.deb
[sudo] hasło użytkownika jakub: 
Wybieranie wcześniej niewybranego pakietu firmware-iwlwifi.
(Odczytywanie bazy danych ... 154961 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu firmware-iwlwifi_20161130-5_all.deb ...
Rozpakowywanie pakietu firmware-iwlwifi (20161130-5) ...
Konfigurowanie pakietu firmware-iwlwifi (20161130-5) ...
jakub@eido:~/Pulpit$ sudo iwconfig
lo        no wireless extensions.

enp0s25   no wireless extensions.

jakub@eido:~/Pulpit$ sudo dpkg -i wpasupplicant_2.4-1+deb9u4_amd64.deb
(Odczytywanie bazy danych ... 155027 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu wpasupplicant_2.4-1+deb9u4_amd64.deb ...
Rozpakowywanie pakietu wpasupplicant (2:2.4-1+deb9u4) nad (2:2.4-1+deb9u4) ...
Konfigurowanie pakietu wpasupplicant (2:2.4-1+deb9u4) ...
Przetwarzanie wyzwalaczy pakietu dbus (1.10.26-0+deb9u1)...
Przetwarzanie wyzwalaczy pakietu man-db (2.7.6.1-2)...
jakub@eido:~/Pulpit$ sudo iwconfig
lo        no wireless extensions.

enp0s25   no wireless extensions.

Awatar użytkownika
dedito
Moderator
Posty: 2950
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z połączenem WIFI (WPA_SUPPLICANT)

Post autor: dedito » 14 czerwca 2019, 17:19

Spróbuj najnowszego z sid http://ftp.pl.debian.org/debian/pool/no ... -1_all.deb
Po instalacji najnowszego firmware wymagane przeładowanie modułu iwlwifi lub restart systemu.

Zablokowany