[+] Zamontowanie serwera NAS

Masz problemy z siecią bądź internetem? Zapytaj tu
pottuka
Posty: 6
Rejestracja: 25 kwietnia 2017, 00:07

[+] Zamontowanie serwera NAS

Post autor: pottuka » 25 kwietnia 2017, 00:16

Dobry wieczór,
nie mogę w żaden ze znanych mi sposobów podmontować dysku sieciowego.
NAS: d-link DNS327L
Debian Jessie
Sytuacja:
mount -t nfs .... wyrzuca mount.nfs4: Connection timed out

Kod: Zaznacz cały

 ps -A | grep rpc
  433 ?        00:00:00 rpcbind
  446 ?        00:00:00 rpc.statd
  451 ?        00:00:00 rpciod
  460 ?        00:00:00 rpc.idmapd

Kod: Zaznacz cały

iptables -S
-P INPUT ACCEPT
-P FORWARD ACCEPT
-P OUTPUT ACCEPT

Kod: Zaznacz cały

rpcinfo -p 192.168.0.172
rpcinfo: can't contact portmapper: RPC: Remote system error - Connection refused
Mogę pingować ten serwer, mogę użyć panelu sterowania w przeglądarce.

Googlam to od przedwczoraj, jakieś sugestie :) ?

Awatar użytkownika
LordRuthwen
Moderator
Posty: 1784
Rejestracja: 18 września 2009, 21:45
Lokalizacja: klikash?

Re: Zamontowanie serwera NAS

Post autor: LordRuthwen » 25 kwietnia 2017, 07:19

A showmount coś pokazuje?

pottuka
Posty: 6
Rejestracja: 25 kwietnia 2017, 00:07

Re: Zamontowanie serwera NAS

Post autor: pottuka » 25 kwietnia 2017, 11:00

Hm pokazuje:

Kod: Zaznacz cały

showmount
clnt_create: RPC: Program not registered

Kod: Zaznacz cały

showmount -e X.X.X.X
clnt_create: RPC: Port mapper failure - Unable to receive: errno 111 (Connection refused)
A mogłoby być tak, że to z powodu mojego kiepskiego routera od netprovidera nie ma dostępu.... ?

Awatar użytkownika
LordRuthwen
Moderator
Posty: 1784
Rejestracja: 18 września 2009, 21:45
Lokalizacja: klikash?

Re: Zamontowanie serwera NAS

Post autor: LordRuthwen » 25 kwietnia 2017, 11:38

portmap ci czasem nie słucha na 127.0.0.1?
Jeśli tak, to masz 2 rozwiązania:

Kod: Zaznacz cały

dpkg-reconfigure portmap
lub edytuj /etc/default/portmap i wywal odpowiednią opcję z OPTIONS.

pottuka
Posty: 6
Rejestracja: 25 kwietnia 2017, 00:07

Re: Zamontowanie serwera NAS

Post autor: pottuka » 25 kwietnia 2017, 11:57

Dzięki za szybką odpowiedź, brzmi rozsądnie, może słucha, tyle że:
reconfigure portmap nie działa, ten pakiet jest chyba zastąpiony w całości przez rpcbind, którego rekonfigurowałem, ale nadal pokazują się te same błędy.
Nawiązując do powyższego, chciałem to już raz edytować, ale w Jessie nie ma ani /default/portmap ani /default/rpcbind. Wiesz co zastąpiło ten plik?

Awatar użytkownika
LordRuthwen
Moderator
Posty: 1784
Rejestracja: 18 września 2009, 21:45
Lokalizacja: klikash?

Re: Zamontowanie serwera NAS

Post autor: LordRuthwen » 25 kwietnia 2017, 13:26

Ja mam coś takiego:

Kod: Zaznacz cały

/etc/init/rpcbind.conf
/etc/init/portmap-wait.conf
Zawsze możesz poszukać czy nie masz czegoś jeszcze:

Kod: Zaznacz cały

sudo find / -type f -name "portmap*"
sudo find / -type f -name "rpcbind*"
A takie coś znalazłem:
portmap defaults to only listening for NFS connection attempts on 127.0.0.1 (localhost)

pottuka
Posty: 6
Rejestracja: 25 kwietnia 2017, 00:07

Re: Zamontowanie serwera NAS

Post autor: pottuka » 25 kwietnia 2017, 15:49

U mnie jest to /etc/init.d/rpcbind ale nie widzę niczego do ustawienia w pliku, wygląda to tak:

Kod: Zaznacz cały

#!/bin/sh
#
# start/stop rpcbind daemon.

### BEGIN INIT INFO
# Provides:          rpcbind
# Required-Start:    $network $local_fs
# Required-Stop:     $network $local_fs
# Default-Start:     S
# Default-Stop:      0 1 6
# Short-Description: RPC portmapper replacement
# Description:       rpcbind is a server that converts RPC (Remote
#                    Procedure Call) program numbers into DARPA
#                    protocol port numbers. It must be running in
#                    order to make RPC calls. Services that use
#                    RPC include NFS and NIS.
### END INIT INFO

test -f /sbin/rpcbind || exit 0

. /lib/lsb/init-functions

OPTIONS="-w"
STATEDIR=/run/rpcbind
PIDFILE=/run/rpcbind.pid

if [ -f /etc/default/rpcbind ]
then
    . /etc/default/rpcbind
elif [ -f /etc/rpcbind.conf ]
then
    . /etc/rpcbind.conf
fi

start ()
{
    if [ ! -d $STATEDIR ] ; then
        mkdir $STATEDIR
    fi
    if [ ! -O $STATEDIR ] ; then
        log_begin_msg "$STATEDIR not owned by root"
        log_end_msg 1
        exit 1
    fi
    if [ ! -f $STATEDIR/rpcbind.xdr ]
    then
        touch $STATEDIR/rpcbind.xdr
    fi
    if [ ! -f $STATEDIR/portmap.xdr ]
    then
        touch $STATEDIR/portmap.xdr
    fi
    [ -x /sbin/restorecon ] && /sbin/restorecon $STATEDIR/*.xdr
    pid=$( pidofproc /sbin/rpcbind )
    if [ -n "$pid" ]
    then
        log_action_msg "Already running: rcpbind"
        exit 0
    fi
    log_begin_msg "Starting rpcbind daemon..."
    start-stop-daemon --start --quiet --oknodo --exec /sbin/rpcbind -- "$@"
    pid=$( pidofproc /sbin/rpcbind )
    echo -n "$pid" >"$PIDFILE"
    # /run/sendsigs.omit.d is created by /etc/init.d/mountkernfs.sh
    ln -sf "$PIDFILE" /run/sendsigs.omit.d/rpcbind
    log_end_msg $?

}

stop ()
{
    log_begin_msg "Stopping rpcbind daemon..."
    start-stop-daemon --stop --quiet --oknodo --exec /sbin/rpcbind
    rm -f "$PIDFILE"
    log_end_msg $?
}

case "$1" in
    start)
        if init_is_upstart; then
            exit 1
        fi
        start $OPTIONS
        ;;
    stop)
        if init_is_upstart; then
            exit 0
        fi
        stop
        ;;
    restart|force-reload)
        if init_is_upstart; then
            exit 1
        fi
        stop
        start $OPTIONS
        ;;
    status)
        status_of_proc /sbin/rpcbind rpcbind && exit 0 || exit $?
        ;;
    *)
        log_success_msg "Usage: /etc/init.d/rpcbind {start|stop|force-reload|restart|status}"
        exit 1
        ;;
esac

exit 0
Natomiast mam coś nowego, dodałem parę opcji do mount i:

Kod: Zaznacz cały

 mount -v -o tcp -t nfs 192.168.0.173:/Volume_1 /mnt/NAS
mount.nfs: timeout set for Tue Apr 25 15:50:17 2017
mount.nfs: trying text-based options 'tcp,vers=4,addr=192.168.0.173,clientaddr=192.168.0.197'
mount.nfs: mount(2): Connection refused
Pokazuje, że jest refused czyli od strony NASa albo routera, czy źle mi się wydaję?

Wpadełem też na użycie nmapa

Kod: Zaznacz cały

Not shown: 994 closed ports
PORT     STATE SERVICE
80/tcp   open  http
139/tcp  open  netbios-ssn
443/tcp  open  https
445/tcp  open  microsoft-ds
515/tcp  open  printer
3306/tcp open  mysql
jakoś mi tu brakuje portu 111 dla nfs...

pottuka
Posty: 6
Rejestracja: 25 kwietnia 2017, 00:07

Re: Zamontowanie serwera NAS

Post autor: pottuka » 25 kwietnia 2017, 17:15

Jest zmiana :)
Kliknąłem enable NFS share na NASie . I nie był on w network settings, nawet nie w share settings, nie w system management tylko pod Applications.... pogratulować lokalizacji. (a wcześniej oczywiście zaznaczyłem w shares, że chcę nfs, nic nie dało bez tego w apps)
Timout error znikł teraz jest tylko: mount.nfs: access denied by server while mounting

Awatar użytkownika
marcin1982
Moderator
Posty: 1626
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Zamontowanie serwera NAS

Post autor: marcin1982 » 25 kwietnia 2017, 17:46

Pokaż wynik:

Kod: Zaznacz cały

showmount -e X.X.X.X
Iksy to IP NAS'a.

pottuka
Posty: 6
Rejestracja: 25 kwietnia 2017, 00:07

Re: Zamontowanie serwera NAS

Post autor: pottuka » 25 kwietnia 2017, 19:29

Rozwiązane, LordRuthwen dzięki za sugestie.
Znalazłem po 10 godzinach taki link: http://forums.dlink.com/index.php?topic=39388.0
Należy używając panelu sterowania w przeglądarce:
- co oczywiste ustawić na serwerze dlinka katalogi do share'owania (management->account management) i zaznaczyć tam nfs
- i mniej oczywiste, po pierwsze w okienku host podać nie adres NASa a adresy możliwe do podłączania, czyli ja wpisałem 192.168.0.0/24 (całą sieć), a po drugie przejść do management->applications i tam zlokalizować jeszcze raz nfs i zaznaczyć po raz drugi na tak.
- montowanie poleceniem

Kod: Zaznacz cały

mount.nfs IP-NASa:/realpath /mnt/...
realpath (czyli nie Volume_1/mójkatalog) znajdujemy w network shares po kliknięciu ikonki nfs

poproszę o oznaczenie tematu jako solved

Zablokowany