[+] Debian Jessie a Wifi - iwlwifi nie rozwiązuje problemu

Masz problemy z siecią bądź internetem? Zapytaj tu
dr_beardie
Posty: 3
Rejestracja: 24 lipca 2016, 11:45

[+] Debian Jessie a Wifi - iwlwifi nie rozwiązuje problemu

Post autor: dr_beardie » 24 lipca 2016, 12:27

Witam. To mój pierwszy post tutaj i biorąc pod uwagę moje zaparcie względem konfiguracji Debiana - zapewne nie ostatni. ;)

Zainstalowałem sobie jakiś czas temu gołą wersję Debiana Jessie stable, do którego później dołożyłem Fluxboxa. Póki co używam kabla do łączenia się z Internetem, ale docelowo w planach jest łączność wifi. No właśnie - w planach. Jakaś nieznana siła mi to uniemożliwia.

Miałem wcześniej okazję z powodzeniem skonfigurować wifi dla Debiana z xfce na tym samym sprzęcie, więc podążam podobną procedurą co wtedy. Dla pewności wpisuję w emulatorze terminala polecenie lspci i uzyskuję następującą nazwę karty: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]. Chwila zabawy z Googlem i znajduję ten poradnik, do którego się stosuję - wszystko robiąc przez su a nie sudo. Z jakiegoś powodu polecenie modprobe nie chce działać, wyrzucając błędy, ale to nic - ostatnio też tak było, lecz wystarczył restart komputera, żeby trybiki w systemie zaskoczyły odpowiednio. Na pierwszy rzut oka wydawać by się mogło, że jest w porządku - po instalacji iwlwifi znikają powiadomienia o braku pewnych plików powiązanych z kartą do łączności bezprzewodowej. Niestety, kiedy odpalam wicd widzę, że nie widzę... na liście widnieje wyłącznie łączność przewodowa, bez żadnych innych opcji do wyboru. Wpisuję zatem w terminalu iwconfig, żeby zobaczyć w czym rzecz, a moim oczom ukazuje się:

Kod: Zaznacz cały

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
lo        no wireless extensions.
Przyjmuję inną strategię - googluje rozwiązania po modelu laptopa (Lenovo Y570 Ideapad), nie po karcie wifi. Znajduję tę stronę, gdzie istnieje odniesienie do jakiejś brakującej paczki (firmware-brcm80211), ale jej instalacja również niczego nie zmienia. Wifi jak nie było tak nie ma, a ja głowię się nad tym, co może być problemem. Przeszukałem to forum, przeszukałem każde inne, ale najwidoczniej nikt nie miał podobnego kłopotu z powołaniem łączności bezprzewodowej do życia. Uprzejmie zatem proszę o jakiekolwiek wskazówki. Naprawdę nie chcę zwijać tego systemu z dysku. :)

Tak dla jasności - system nie stoi na dualboocie, jeśli to ma w czymkolwiek pomóc.
Ostatnio zmieniony 24 lipca 2016, 21:55 przez dr_beardie, łącznie zmieniany 1 raz.

ww71
Beginner
Posty: 390
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: Debian Jessie a Wifi - iwlwifi nie rozwiązuje problemu

Post autor: ww71 » 24 lipca 2016, 16:06

U mnie jest tak, że nie może być zainstalowany jednocześnie WICD i Network-manager, i korzystając z WICD musiałem odinstalowac network-manager. W WICD w Preferencjach/interfejs bezprzewodowy : trzeba wpisać:

Kod: Zaznacz cały

 wlan0
I dopiero szukać sieci wifi.

Kod: Zaznacz cały

ifconfig wlan0 up

dr_beardie
Posty: 3
Rejestracja: 24 lipca 2016, 11:45

Re: Debian Jessie a Wifi - iwlwifi nie rozwiązuje problemu

Post autor: dr_beardie » 24 lipca 2016, 17:22

Wpisanie wlan0 i restart załatwiły sprawę. :) W moim poprzednim podejściu do ustawiania wifi wicd zaskoczył automatycznie i nie wymagał w ogóle grzebania w preferencjach - stąd moje zdziwienie przy bieżącej próbie. Dziękuję bardzo za poradę, kolejny kamień milowy można uznać za osiągnięty. ;)

Zablokowany