Hotspot nie ma po

Masz problemy z siecią bądź internetem? Zapytaj tu
Awatar użytkownika
kodama
Junior Member
Posty: 633
Rejestracja: 23 maja 2010, 22:30
Lokalizacja: Poznań

Hotspot nie ma połączenia z internetem

Post autor: kodama » 28 lipca 2015, 15:56

Temat powiązany z tym: threads/32768-Hotspot-przy-wykorzystaniu-laptopa
Mam zainstalowany
hostapd i działa

Kod: Zaznacz cały

kodama@jupiter:~$ cat /etc/hostapd/hostapd.conf 
interface=wlan0
driver=nl80211
ssid=jupiter
hw_mode=g
channel=1
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=3
wpa_passphrase=12341234
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP

Kod: Zaznacz cały

kodama@jupiter:~$ sudo systemctl status hostapd.service
● hostapd.service - LSB: Advanced IEEE 802.11 management daemon
   Loaded: loaded (/etc/init.d/hostapd)
   Active: active (running) since wto 2015-07-28 15:39:57 CEST; 6min ago
  Process: 664 ExecStart=/etc/init.d/hostapd start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/hostapd.service
           └─1076 /usr/sbin/hostapd -B -P /run/hostapd.pid /etc/hostapd/hosta...

lip 28 15:40:26 jupiter hostapd[1076]: wlan0: STA 64:89:9a:75:03:8a IEEE 80...ed
lip 28 15:40:26 jupiter hostapd[1076]: wlan0: STA 64:89:9a:75:03:8a IEEE 80...1)
lip 28 15:40:27 jupiter hostapd[1076]: wlan0: STA 64:89:9a:75:03:8a RADIUS:...00
lip 28 15:40:27 jupiter hostapd[1076]: wlan0: STA 64:89:9a:75:03:8a WPA: pa...N)
lip 28 15:44:32 jupiter hostapd[1076]: wlan0: STA 64:89:9a:75:03:8a IEEE 80...ed
lip 28 15:44:33 jupiter hostapd[1076]: wlan0: STA 64:89:9a:75:03:8a IEEE 80...E)
lip 28 15:44:36 jupiter hostapd[1076]: wlan0: STA 64:89:9a:75:03:8a IEEE 80...ed
lip 28 15:44:36 jupiter hostapd[1076]: wlan0: STA 64:89:9a:75:03:8a IEEE 80...1)
lip 28 15:44:36 jupiter hostapd[1076]: wlan0: STA 64:89:9a:75:03:8a RADIUS:...01
lip 28 15:44:36 jupiter hostapd[1076]: wlan0: STA 64:89:9a:75:03:8a WPA: pa...N)
Hint: Some lines were ellipsized, use -l to show in full.
isc-dhcp-server

Kod: Zaznacz cały

kodama@jupiter:~$ grep -v '^#' /etc/dhcp/dhcpd.conf
ddns-update-style none;
authoritative;
log-facility local7;

subnet 192.168.0.0 netmask 255.255.255.0 {
        range 192.168.0.2 192.168.0.10;
        option domain-name-servers 8.8.4.4, 8.8.8.8;
        option routers 192.168.0.1;
}

Kod: Zaznacz cały

kodama@jupiter:~$ sudo systemctl status isc-dhcp-server.service 
● isc-dhcp-server.service - LSB: DHCP server
   Loaded: loaded (/etc/init.d/isc-dhcp-server)
   Active: active (running) since wto 2015-07-28 15:39:59 CEST; 9min ago
  Process: 669 ExecStart=/etc/init.d/isc-dhcp-server start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/isc-dhcp-server.service
           └─1074 /usr/sbin/dhcpd -q -cf /etc/dhcp/dhcpd.conf -pf /var/run/dh...

lip 28 15:39:57 jupiter dhcpd[1074]: Server starting service.
lip 28 15:39:59 jupiter isc-dhcp-server[669]: Starting ISC DHCP server: dhcpd.
lip 28 15:40:27 jupiter dhcpd[1074]: DHCPREQUEST for 192.168.0.3 from 64:89...n0
lip 28 15:40:27 jupiter dhcpd[1074]: DHCPACK on 192.168.0.3 to 64:89:9a:75:...n0
lip 28 15:40:27 jupiter dhcpd[1074]: DHCPREQUEST for 192.168.0.3 from 64:89...n0
lip 28 15:40:27 jupiter dhcpd[1074]: DHCPACK on 192.168.0.3 to 64:89:9a:75:...n0
lip 28 15:44:37 jupiter dhcpd[1074]: DHCPREQUEST for 192.168.0.3 from 64:89...n0
lip 28 15:44:37 jupiter dhcpd[1074]: DHCPACK on 192.168.0.3 to 64:89:9a:75:...n0
lip 28 15:44:37 jupiter dhcpd[1074]: DHCPREQUEST for 192.168.0.3 from 64:89...n0
lip 28 15:44:37 jupiter dhcpd[1074]: DHCPACK on 192.168.0.3 to 64:89:9a:75:...n0
Hint: Some lines were ellipsized, use -l to show in full.
I mam jeszcze taki prościutki skrypt do dodawania regułki do iptables i łączenia z netem

Kod: Zaznacz cały

 sudo iptables -t nat -A POSTROUTING -s 192.168.0.0/16 -o ppp0 -j MASQUERADE
sudo wvdial a1
I teraz jest pewna zagwozdka. W takiej konfiguracji jak jest powyżej to nie chce działać prawidłowo. Owszem, urządzenie klienckie dostaje adres ip, można się łączyć np. przez ssh z komputerem, jednak po załapaniu połączenia z aero (na komputerze) klienci nadal nie mają internetu. W tym momencie następuje jednak ALE (zawsze jest jakieś ale ;) ), jeżeli ja wywalę te dwie pierwsze usługi z autostartu:

Kod: Zaznacz cały

systemctl disable hostapd.service
systemctl disable isc-dhcp-server.service
A po włączeniu komputera uruchomię to tak:

Kod: Zaznacz cały

sudo service hostapd start

sudo service isc-dhcp-server start

 sudo iptables -t nat -A POSTROUTING -s 192.168.0.0/16 -o ppp0 -j MASQUERADE

sudo wvdial a1
czyli de fakto otrzymam to samo, obydwie usługi się podniosą - to wtedy internet śmiga. Ktoś jest mi w stanie wytłumaczyć w którym miejscu mam jakiś błąd?

liske1
Beginner
Posty: 106
Rejestracja: 12 maja 2012, 13:54

Post autor: liske1 » 29 lipca 2015, 01:12

Podaj dmesg, oraz spróbuj wpisać 4 polecenia do /etc/rc.local (bez sudo i wyłącz autostart).

Awatar użytkownika
kodama
Junior Member
Posty: 633
Rejestracja: 23 maja 2010, 22:30
Lokalizacja: Poznań

Post autor: kodama » 29 lipca 2015, 16:19

Po dodaniu do rc.local działa. Tylko... czemu? :] Ja chciałem, żeby to tak ładnie było, po Bożemu :) No ale dobra, tak też może zostać, skoro działa ;)

liske1
Beginner
Posty: 106
Rejestracja: 12 maja 2012, 13:54

Post autor: liske1 » 29 lipca 2015, 17:29

Być może któraś usługa jest zależna od innej, a system uruchamia te usługi na odwrót, przez co jedna nie uruchamia się właściwie. Jakbyś podał polecenie dmesg to byśmy wiedzieli więcej.

Awatar użytkownika
kodama
Junior Member
Posty: 633
Rejestracja: 23 maja 2010, 22:30
Lokalizacja: Poznań

Post autor: kodama » 29 lipca 2015, 20:05

Proszę bardzo:, dmesg zaraz po uruchomieniu komputera:
dmesg kiedy są wpisy w rc.local - to działa :) http://pastebin.com/e8c8YWgz
kiedy uruchamiam ze skryptu - też działa http://pastebin.com/hNK6c7cw
kiedy jest w autostarcie jako usługa - nie działa http://pastebin.com/Swxw8MT0

Awatar użytkownika
marcin1982
Moderator
Posty: 1722
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Post autor: marcin1982 » 29 lipca 2015, 21:05

Pokaż wynik komendy z użyciem usługi w autostarcie - wtedy kiedy nie działa:

Kod: Zaznacz cały

journalctl -b -u hostapd.service

Awatar użytkownika
kodama
Junior Member
Posty: 633
Rejestracja: 23 maja 2010, 22:30
Lokalizacja: Poznań

Post autor: kodama » 30 lipca 2015, 08:02

Proszę bardzo
hostaps

Kod: Zaznacz cały

-- Logs begin at czw 2015-07-30 07:59:59 CEST, end at czw 2015-07-30 08:02:27 CEST. --
lip 30 08:00:21 jupiter hostapd[683]: Starting advanced IEEE 802.11 management: hostapd.
lip 30 08:00:50 jupiter hostapd[1095]: wlan0: STA 64:89:9a:75:03:8a IEEE 802.11: authenticated
lip 30 08:00:50 jupiter hostapd[1095]: wlan0: STA 64:89:9a:75:03:8a IEEE 802.11: associated (aid 1)
lip 30 08:00:52 jupiter hostapd[1095]: wlan0: STA 64:89:9a:75:03:8a RADIUS: starting accounting session 55B9BD75-00000000
lip 30 08:00:52 jupiter hostapd[1095]: wlan0: STA 64:89:9a:75:03:8a WPA: pairwise key handshake completed (RSN)
i jeszcze dla isc-dhcp-server

Kod: Zaznacz cały

-- Logs begin at czw 2015-07-30 07:59:59 CEST, end at czw 2015-07-30 08:03:37 CE
lip 30 08:00:17 jupiter dhcpd[736]: Internet Systems Consortium DHCP Server 4.3.
lip 30 08:00:17 jupiter dhcpd[736]: Copyright 2004-2014 Internet Systems Consort
lip 30 08:00:17 jupiter dhcpd[1019]: Internet Systems Consortium DHCP Server 4.3
lip 30 08:00:17 jupiter dhcpd[1019]: Copyright 2004-2014 Internet Systems Consor
lip 30 08:00:17 jupiter dhcpd[1019]: All rights reserved.
lip 30 08:00:17 jupiter dhcpd[1019]: For info, please visit https://www.isc.org/
lip 30 08:00:17 jupiter dhcpd[1019]: Wrote 2 leases to leases file.
lip 30 08:00:21 jupiter dhcpd[1093]: Server starting service.
lip 30 08:00:23 jupiter isc-dhcp-server[688]: Starting ISC DHCP server: dhcpd.
lip 30 08:00:56 jupiter dhcpd[1093]: DHCPREQUEST for 192.168.0.3 from 64:89:9a:7
lip 30 08:00:56 jupiter dhcpd[1093]: DHCPACK on 192.168.0.3 to 64:89:9a:75:03:8a
lip 30 08:00:56 jupiter dhcpd[1093]: DHCPREQUEST for 192.168.0.3 from 64:89:9a:7
lip 30 08:00:56 jupiter dhcpd[1093]: DHCPACK on 192.168.0.3 to 64:89:9a:75:03:8a


ODPOWIEDZ