[+]wlp2s0: state DORMANT

Masz problemy z siecią bądź internetem? Zapytaj tu
Awatar użytkownika
korbielow
Beginner
Posty: 288
Rejestracja: 29 marca 2014, 20:37

[+]wlp2s0: state DORMANT

Post autor: korbielow » 29 września 2018, 20:12

Cos przedobrzyłem i przestało działąc mi wifi...
Mam
02:00.0 Network controller: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter (rev 01)

Kod: Zaznacz cały

wlp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state DORMANT 
Jak przeinstalowac te sterowniki albo zmienic interfejsu status na UP?

Kod: Zaznacz cały

root@debian:/etc# cat /etc/debian_version
buster/sid
Próbowałem, ale bez efektów

Kod: Zaznacz cały

root@debian:/etc# ip link set dev wlp2s0 down
root@debian:/etc# ip link set dev wlp2s0 up
root@debian:/etc# ip address
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 5c:26:0a:43:bd:7f brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.6/24 brd 192.168.2.255 scope global dynamic noprefixroute eno1
       valid_lft 85925sec preferred_lft 85925sec
    inet6 fe80::5e26:aff:fe43:bd7f/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wlp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state DORMANT group default qlen 1000
    link/ether 68:a3:c4:40:0c:02 brd ff:ff:ff:ff:ff:ff
1000

Kod: Zaznacz cały

root@debian:/etc# apt-get update && apt-get install firmware-brcm80211
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Stary:2 http://ftp.pl.debian.org/debian testing InRelease                             
Stary:3 http://security.debian.org testing/updates InRelease                                                    
Stary:4 http://dl.google.com/linux/chrome/deb stable Release                                                    
Ign:5 http://ppa.launchpad.net/robert-ancell/sane-backends/ubuntu cosmic InRelease                      
Pobieranie:6 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu cosmic InRelease [15,4 kB]
Błąd:7 http://ppa.launchpad.net/robert-ancell/sane-backends/ubuntu cosmic Release
  404  Not Found [IP: 91.189.95.83 80]
Błąd:6 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu cosmic InRelease
  Następujące podpisy nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY 531EE72F4C9D234C
Czytanie list pakietów... Gotowe
E: The repository 'http://ppa.launchpad.net/robert-ancell/sane-backends/ubuntu cosmic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Błąd GPG: http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu cosmic InRelease: Następujące podpisy nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY 531EE72F4C9D234C
E: The repository 'http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu cosmic InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
root@debian:/etc# modprobe -r brcmsmac ; modprobe brcmsmac
Ostatnio zmieniony 29 września 2018, 21:01 przez korbielow, łącznie zmieniany 1 raz.

Awatar użytkownika
korbielow
Beginner
Posty: 288
Rejestracja: 29 marca 2014, 20:37

Re: wlp2s0: state DORMANT

Post autor: korbielow » 29 września 2018, 21:01

Ok znalazłem przyczyne.
po uzyciu tej komendy problemy sie zaczely

Kod: Zaznacz cały

apt install broadcom-sta-dkms
Po wykonaniu

Kod: Zaznacz cały

apt purge broadcom-sta-dkms
Wszystko wróciło do normy
wlp2s0b1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP

Zablokowany