[+] RMVB - jak to odtworzy

Tematy związane z oprogramowaniem, instalacją, konfiguracją
Awatar użytkownika
ilin
Senior Member
Posty: 2292
Rejestracja: 26 sierpnia 2007, 11:54
Lokalizacja: PRLu

Post autor: ilin » 11 czerwca 2009, 19:07

Mplayera również do muzyki używam.
Moim zdaniem brzmi najlepiej ze wszystkich odtwarzaczy.
Ale alsie jakiś czas temu podziękowalem na rzecz OSS4.

Mówimy o czystym brzmieniu muzyki nie zmienionej equalizerami.
Moim zdaniem audacious czym nowsza wersja tym gorszy.

Awatar użytkownika
lis6502
Member
Posty: 1798
Rejestracja: 05 listopada 2008, 20:14
Lokalizacja: Miasto Szybowców

Post autor: lis6502 » 11 czerwca 2009, 19:16

ilin pisze:Moim zdaniem audacious czym nowsza wersja tym gorszy.
Tutaj częściowo się zgodzę. Jeśli ktoś poważnie myśli o tym odtwarzaczu, to tylko w wersji < 2. Dla miłośników QT jest alternatywa, nawet stabilna, jak na numerek wersji: qmmp, niedostępna jeszcze jako pakiet Debiana.

Awatar użytkownika
dowoszek
Posty: 65
Rejestracja: 13 kwietnia 2007, 16:04

Post autor: dowoszek » 11 czerwca 2009, 19:25

U mnie audacious sprawuje się bardzo dobrze. W ustawieniach można zaznaczyć opcję pominięcia wszelkich equalizerów itp.
Może spróbuję OSS - pamiętam, że niedawno propagowałeś toto na DUG ;-)

miataro
Posty: 9
Rejestracja: 21 października 2009, 15:43

Post autor: miataro » 26 października 2009, 22:23

chomik pisze:
thalcave pisze:To ja inaczej spytam masz system 32u bitowy czy 64?
dla 64bitowego Linuksa jest paczka w64codecs
Chyba 64 bit nie jestem do końca pewien jak to sprawdzić?
W przypadku Debiana Lenny amd64 działa takie coś:
w /etc/apt/sources.list jest wpis:

Kod: Zaznacz cały

deb [url]http://www.debian-multimedia.org[/url] lenny main
deb [url]ftp://ftp.debian-multimedia.org[/url] lenny main
Wiadomo klucz ale to już wcześniej było podane jak i co.

Jeśli to jest to wtedy tylko:

Kod: Zaznacz cały

aptitude install w64codecs
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie... Gotowe
Odczyt dodatkowych informacji o stanie
Inicjalizacja stanów pakietów... Gotowe
Odczyt opisów zadań... Gotowe
Następujące NOWE pakiety zostaną zainstalowane:
  w64codecs
0 pakietów aktualizowanych, 1 instalowanych, 0 do usunięcia i 0 nie aktualizowanych.
Do pobrania 200kB archiwów. Zajęte po rozpakowaniu: 504kB.
Zapisywanie dodatkowych informacji o stanie... Gotowe
Pobieranie:1 [url]http://www.debian-multimedia.org[/url] lenny/main w64codecs 1:20071007-0.3 [200kB]
Pobrano 200kB w 10s (19,9kB/s)
Zaznaczenie poprzednio niezaznaczonego pakietu w64codecs.
(Odczytywanie bazy danych ... 162432 plików i katalogów obecnie zainstalowanych.)
Rozpakowanie w64codecs (z .../w64codecs_1%3a20071007-0.3_amd64.deb) ...
Konfigurowanie w64codecs (1:20071007-0.3) ...
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie... Gotowe
Odczyt dodatkowych informacji o stanie
Inicjalizacja stanów pakietów... Gotowe
Zapisywanie dodatkowych informacji o stanie... Gotowe
Odczyt opisów zadań... Gotowe
i nie działa, zainstalowało się pięknie. Ale test na pierwszym lepszym rmvb wyszedł negatywnie, zarówno pod totemem jak i pod mplayerem. Szukam dalej.


Znalezione.
  1. Powyższe można zastosować ale nie ma gwarancji, że na Twojej maszynie zadziała.
  2. Aby zadziałało zrobiłem tak:[list:87c680e8eb]- pobrałem kodeki do mplayera ze strony: http://www.mplayerhq.hu/design7/dload.html
    - po rozpakowaniu przekopiowałem do:

    Kod: Zaznacz cały

    /usr/lib/codecs
    - następnie pozbyłem się alsy a zainstalowałem oss4, bardzo czytelnie opisuje to ilin w FAQ na DUG (tak Google znalazło, czy tu jest nie wiem, nie szukałem).
[*] rmvb działają z mplayerem bez najmniejszego problemu pod Lennym amd46.[/list :o :87c680e8eb]A teraz słówko do ilina.
Przy konfiguracji mplayera takie małe spostrzeżenie:

Kod: Zaznacz cały

~/.mplayer/gui.conf
linia 14: ao_driver = "oss"
przynajmniej ja musiałem tu zmienić.

Ps: Pozdrowienia dla wszystkich moderatorów, którzy mają siłę i ochotę dłubać w postach, aby stały się one czytelne.

Awatar użytkownika
ilin
Senior Member
Posty: 2292
Rejestracja: 26 sierpnia 2007, 11:54
Lokalizacja: PRLu

Post autor: ilin » 27 października 2009, 08:25

Dla gmplayera można to zrobić w trybie graficznym:
Peferences -> zakładka Audio -> oss

Jeszcze trzeba by wziąć pod uwagę smplayera :)

sidjestgit
Beginner
Posty: 181
Rejestracja: 06 grudnia 2008, 17:55

Post autor: sidjestgit » 27 października 2009, 23:54

U mnie mplayer i kaffeine wyswietlaly blad przy rmvb.
Zainstalowalem vlc i problem znikl (debian squeeze)
moze?

Kod: Zaznacz cały

apt-get install vlc

Awatar użytkownika
ilin
Senior Member
Posty: 2292
Rejestracja: 26 sierpnia 2007, 11:54
Lokalizacja: PRLu

Post autor: ilin » 28 października 2009, 07:09

Z tego co zauważyłem to ostatnie wersje mplayera przy odtwarzaniu rmvb nawet nie korzystają z kodeków w32 tylko z wbudowanych ffmpeg.

rom
Posty: 10
Rejestracja: 29 grudnia 2009, 09:46

Post autor: rom » 29 grudnia 2009, 12:24

Odświeżam temat.
Nie działają mi filmy rmvb, działa tylko dźwięk. Ale moja sytuacja jest bardziej złożona. Pozostałe filmy działają tylko w Totemie, ale nie w innych playerach. W innych playerach był odtwarzany tylko dźwięk, dlatego je odinstalowałem.
U mnie nie działają standardowe porady z tego forum (ani z innych).
Mam Debiana Lenny amd64. Repozytoria sprawdzone, nie mieszane z innymi wydaniami. System zaktualizowany.
Zainstalowane kodeki w64codecs, gstreamer, xine.
Aptitude nie znajduje pakietu w32codecs. Kodeki w32codecs pobrałem w formie archiwum i rozpakowałem /usr/lib/codecs oraz /usr/local/lib/codecs
Nadal nie ma obrazu w Totemie przy odtwarzaniu rmvb. Totem próbuje sam wyszukać odpowiedni kodek, ale bez powodzenia: "Nie znaleziono pasującej aplikacji".
(Aż tak bardzo nie zależy mi na samych filmach rmvb, ale nie lubię, kiedy coś mi nie działa ;-) )

[edycja]
Znalazłem rozwiązanie połowiczne. Doinstalowałem Mplayer, który odtwarza rmvb, ale tylko z terminala (w innym przypadku tylko dźwięk).

Kod: Zaznacz cały

biosocjozwarcie@debian:~$ mplayer '/media/data/Videos/Edukacyjne/film.rmvb' 
MPlayer dev-SVN-r26940
CPU: Intel(R) Core(TM)2 Duo CPU     P7350  @ 2.00GHz (Family: 6, Model: 23, Stepping: 6)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /media/data/Videos/Edukacyjne/film.rmvb.
REAL file format detected.
Stream description: Audio Stream
Stream mimetype: audio/x-pn-realaudio
[real] Audio stream found, -aid 0
Stream description: Video Stream
Stream mimetype: video/x-pn-realvideo
[real] Video stream found, -vid 1
Stream mimetype: logical-fileinfo
VIDEO:  [RV40]  640x480  24bpp  23.000 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:
 comment: 
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
[VO_TDFXFB] Can't open /dev/fb0: No such file or directory.
s3fb: can't open /dev/fb0: No such file or directory
==========================================================================
Opening video decoder: [realvid] RealVideo decoder
Selected video codec: [rv3040] vfm: realvid (Linux RealPlayer 10 RV30/40 decoder)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, s16le, 64.1 kbit/4.54% (ratio: 8010->176400)
Selected audio codec: [ffcook] afm: ffmpeg (FFmpeg COOK audio decoder)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 640 x 480 (preferred colorspace: Planar I420)
VDec: using Planar I420 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 640x480 => 640x480 Planar I420 
No bind found for key 'JOY_AXIS2_PLUS'.                          0 
A:  12.4 V:  12.4 A-V:  0.000 ct: -0.054 286/286 17%  0%  1.0% 3 0 

MPlayer interrupted by signal 15 in module: sleep_timer
A:  12.4 V:  12.4 A-V:  0.000 ct: -0.054 287/287 17%  0%  1.0% 3 0
W tym przypadku Mplayer można zamknąć tylko przez zabicie procesu.

Gdy uruchamiam film przez 'otwórz za pomocą Mplayer' pokazuje się okno Mplayera z komunikatem błędu:

Kod: Zaznacz cały

Error opening/initializing the selected video_out (-vo) device.
Po zamknięciu komunikatu, okno znika, a pojawia się tylko panel sterujący Mpalyera i odtwarza wyłącznie dźwięk.[/code]

[edycja2]
Rozwiązanie znalazłem tutaj http://ubuntuforums.org/showthread.php?t=20039
Dla mnie takie rozwiązanie jest wystarczające. Jednak chętnie zapoznam się z Waszymi sugestiami odnośnie Totema.

Awatar użytkownika
ilin
Senior Member
Posty: 2292
Rejestracja: 26 sierpnia 2007, 11:54
Lokalizacja: PRLu

Post autor: ilin » 30 grudnia 2009, 09:05

To rozwiązanie jest juz na tym forum kilkakrotnie podawane.

Najlepiej odpalić mplayera w konsoli

Kod: Zaznacz cały

mplayer film.rmvb -vo x11

Kod: Zaznacz cały

mplayer film.rmvb -vo xv

Kod: Zaznacz cały

mplayer film.rmvb -vo gl

Kod: Zaznacz cały

mplayer film.rmvb -vo gl2
Zobaczyć na którym najlepiej działa i taki sterownik video ustawić w pliku konfiguracyjnym.

2000adam
Posty: 60
Rejestracja: 03 marca 2009, 13:54

Post autor: 2000adam » 07 marca 2010, 20:42

Witam wszystkich.
Podepnę się do tematu. Nie mogę odtworzyć filmu rmvb. Wszystkie porady z tego tematu u mnie nie skuteczne. Uruchomiłem w konsoli mplayera ale jest tylko głos, obrazu nie ma.

Kod: Zaznacz cały

debian:/home/adam# mplayer /home/adam/Niewinna/Niewinna.rmvb -vo gl
MPlayer dev-SVN-r26940
CPU: AMD Duron(tm) processor (Family: 6, Model: 7, Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /home/adam/Niewinna/Niewinna.rmvb.
REAL file format detected.
Stream description: Audio Stream
Stream mimetype: audio/x-pn-realaudio
[real] Audio stream found, -aid 0
Stream description: Video Stream
Stream mimetype: video/x-pn-realvideo
[real] Video stream found, -vid 1
Stream mimetype: logical-fileinfo
VIDEO:  [RV40]  640x352  24bpp  30.000 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:
 comment: 
[gl] using extended formats. Use -vo gl:nomanyfmts if playback fails.
==========================================
Opening video decoder: [realvid] RealVideo decoder
Error: /usr/lib/codecs/drvc.so: cannot open shared object file: No such file or directory
Win32 LoadLibrary failed to load: drvc.so, /usr/lib/codecs/drvc.so, /usr/lib/win32/drvc.so, /usr/local/lib/win32/drvc.so
Error loading dll
ERROR: Could not open required DirectShow codec drvc.so.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
Win32 LoadLibrary failed to load: drvc.dll, /usr/lib/codecs/drvc.dll, /usr/lib/win32/drvc.dll, /usr/local/lib/win32/drvc.dll
Error loading dll
ERROR: Could not open required DirectShow codec drvc.dll.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
Error: /usr/lib/codecs/drv4.so.6.0: cannot open shared object file: No such file or directory
Win32 LoadLibrary failed to load: drv4.so.6.0, /usr/lib/codecs/drv4.so.6.0, /usr/lib/win32/drv4.so.6.0, /usr/local/lib/win32/drv4.so.6.0
Error loading dll
ERROR: Could not open required DirectShow codec drv4.so.6.0.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
Win32 LoadLibrary failed to load: drv43260.dll, /usr/lib/codecs/drv43260.dll, /usr/lib/win32/drv43260.dll, /usr/local/lib/win32/drv43260.dll
Error loading dll
ERROR: Could not open required DirectShow codec drv43260.dll.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
Error: /usr/lib/codecs/drvc.bundle/Contents/MacOS/drvc: cannot open shared object file: No such file or directory
Win32 LoadLibrary failed to load: drvc.bundle/Contents/MacOS/drvc, /usr/lib/codecs/drvc.bundle/Contents/MacOS/drvc, /usr/lib/win32/drvc.bundle/Contents/MacOS/drvc, /usr/local/lib/win32/drvc.bundle/Contents/MacOS/drvc
Error loading dll
ERROR: Could not open required DirectShow codec drvc.bundle/Contents/MacOS/drvc.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Cannot find codec matching selected -vo and video format 0x30345652.
Read DOCS/HTML/en/codecs.html!
==========================================
==========================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, s16le, 64.1 kbit/4.54% (ratio: 8010->176400)
Selected audio codec: [ffcook] afm: ffmpeg (FFmpeg COOK audio decoder)
==========================================
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:  45.5 (45.4) of 5362.0 ( 1:29:22.0)  1.5% 

Exiting... (End of file)
debian:/home/adam# mplayer /home/adam/Niewinna/Niewinna.rmvb -vo gl2
MPlayer dev-SVN-r26940
CPU: AMD Duron(tm) processor (Family: 6, Model: 7, Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /home/adam/Niewinna/Niewinna.rmvb.
REAL file format detected.
Stream description: Audio Stream
Stream mimetype: audio/x-pn-realaudio
[real] Audio stream found, -aid 0
Stream description: Video Stream
Stream mimetype: video/x-pn-realvideo
[real] Video stream found, -vid 1
Stream mimetype: logical-fileinfo
VIDEO:  [RV40]  640x352  24bpp  30.000 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:
 comment: 
==========================================
Opening video decoder: [realvid] RealVideo decoder
Error: /usr/lib/codecs/drvc.so: cannot open shared object file: No such file or directory
Win32 LoadLibrary failed to load: drvc.so, /usr/lib/codecs/drvc.so, /usr/lib/win32/drvc.so, /usr/local/lib/win32/drvc.so
Error loading dll
ERROR: Could not open required DirectShow codec drvc.so.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
Win32 LoadLibrary failed to load: drvc.dll, /usr/lib/codecs/drvc.dll, /usr/lib/win32/drvc.dll, /usr/local/lib/win32/drvc.dll
Error loading dll
ERROR: Could not open required DirectShow codec drvc.dll.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
Error: /usr/lib/codecs/drv4.so.6.0: cannot open shared object file: No such file or directory
Win32 LoadLibrary failed to load: drv4.so.6.0, /usr/lib/codecs/drv4.so.6.0, /usr/lib/win32/drv4.so.6.0, /usr/local/lib/win32/drv4.so.6.0
Error loading dll
ERROR: Could not open required DirectShow codec drv4.so.6.0.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
Win32 LoadLibrary failed to load: drv43260.dll, /usr/lib/codecs/drv43260.dll, /usr/lib/win32/drv43260.dll, /usr/local/lib/win32/drv43260.dll
Error loading dll
ERROR: Could not open required DirectShow codec drv43260.dll.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
Error: /usr/lib/codecs/drvc.bundle/Contents/MacOS/drvc: cannot open shared object file: No such file or directory
Win32 LoadLibrary failed to load: drvc.bundle/Contents/MacOS/drvc, /usr/lib/codecs/drvc.bundle/Contents/MacOS/drvc, /usr/lib/win32/drvc.bundle/Contents/MacOS/drvc, /usr/local/lib/win32/drvc.bundle/Contents/MacOS/drvc
Error loading dll
ERROR: Could not open required DirectShow codec drvc.bundle/Contents/MacOS/drvc.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Cannot find codec matching selected -vo and video format 0x30345652.
Read DOCS/HTML/en/codecs.html!
==========================================
==========================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, s16le, 64.1 kbit/4.54% (ratio: 8010->176400)
Selected audio codec: [ffcook] afm: ffmpeg (FFmpeg COOK audio decoder)
==========================================
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 647.1 (10:47.0) of 5362.0 ( 1:29:22.0)  1.6% 

Exiting... (End of file)
debian:/home/adam# 

ODPOWIEDZ