Mail Serwer

Tematy związane z oprogramowaniem, instalacją, konfiguracją
baudi
Posty: 9
Rejestracja: 01 kwietnia 2021, 11:10

Mail Serwer

Post autor: baudi » 01 kwietnia 2021, 12:21

Witam

Dla testów postanowiłem postawić swój serwer pocztowy. Zainstalowałem Postfix + Sasl bez problemowo i wiadomości mogę wysyłać. Chciałbym również odbierać pocztę więc postanowiłem zainstalować Cyrusa no i tu zaczęły się moje kłopoty. Podczas instalacji system wyrzuca mi coś takiego:

Kod: Zaznacz cały

:/# apt-get install cyrus-imapd
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie... Gotowe
cyrus-imapd is already the newest version (3.0.8-6+deb10u5).
Następujące pakiety zostały zainstalowane automatycznie i nie są już więcej wymagane:
  accountsservice apg bogofilter bogofilter-bdb bogofilter-common bolt brasero-common cdrdao cheese-common coinor-libcbc3 coinor-libcgl1 coinor-libclp1 coinor-libcoinmp1v5 coinor-libcoinutils3v5 coinor-libosi1v5 dleyna-server
  dns-root-data dnsmasq-base evince-common evolution-common evolution-data-server-common fonts-droid-fallback fonts-noto-mono fonts-opensymbol fwupd fwupd-amd64-signed gir1.2-accountsservice-1.0 gir1.2-clutter-gst-3.0 gir1.2-dazzle-1.0
  gir1.2-gck-1 gir1.2-gcr-3 gir1.2-gdm-1.0 gir1.2-gmenu-3.0 gir1.2-gnomebluetooth-1.0 gir1.2-ibus-1.0 gir1.2-mediaart-2.0 gir1.2-mutter-3 gir1.2-nm-1.0 gir1.2-nma-1.0 gir1.2-packagekitglib-1.0 gir1.2-polkit-1.0 gir1.2-rsvg-2.0
  gir1.2-tracker-2.0 gir1.2-upowerglib-1.0 gir1.2-zpj-0.0 gnome-control-center-data gnome-session-bin gnome-session-common gnome-software-common gnome-todo-common gnupg-l10n gnupg-utils gpg gpg-agent gpg-wks-server gpgconf gpgsm
  gstreamer1.0-clutter-3.0 gstreamer1.0-gtk3 hyphen-en-us libabw-0.1-1 libaccountsservice0 libappstream-glib8 libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libatomic1 libavahi-gobject0 libavahi-ui-gtk3-0 libayatana-appindicator3-1
  libayatana-ido3-0.4-0 libayatana-indicator3-7 libblas3 libboost-atomic1.67.0 libboost-chrono1.67.0 libboost-date-time1.67.0 libboost-filesystem1.67.0 libboost-iostreams1.67.0 libboost-locale1.67.0 libboost-system1.67.0
  libboost-thread1.67.0 libburn4 libcacard0 libcamel-1.2-62 libcdio-cdda2 libcdio-paranoia2 libcdr-0.1-1 libclucene-contribs1v5 libclucene-core1v5 libclutter-gst-3.0-0 libcolamd2 libcue2 libcupsimage2 libdazzle-1.0-0 libdbusmenu-glib4
  libdbusmenu-gtk3-4 libdc1394-22 libdca0 libde265-0 libdjvulibre-text libdjvulibre21 libdleyna-connector-dbus-1.0-1 libdleyna-core-1.0-3 libdmapsharing-3.0-2 libe-book-0.1-1 libeot0 libepubgen-0.1-1 libetonyek-0.1-1
  libexttextcat-2.0-0 libfaad2 libfluidsynth1 libfreehand-0.1-1 libfreerdp2-2 libfwupd2 libgail-3-0 libgcab-1.0-0 libgdata-common libgdm1 libgfortran5 libgif7 libgnome-autoar-gtk-0-0 libgnome-menu-3-0 libgnome-todo libgom-1.0-0
  libgpgme11 libgpgmepp6 libgpod-common libgpod4 libgs9 libgs9-common libgsl23 libgslcblas0 libgstreamer-plugins-bad1.0-0 libgtkspell3-3-0 libgupnp-igd-1.0-4 libgxps2 libibus-1.0-5 libijs-0.35 libilmbase23 libiptcdata0 libisofs6
  libjbig2dec0 libjte1 libkate1 libkpathsea6 libksba8 liblapack3 liblirc-client0 liblua5.2-0 liblua5.3-0 libmhash2 libminiupnpc17 libmjpegutils-2.1-0 libmms0 libmodplug1 libmpcdec6 libmpeg2encpp-2.1-0 libmplex2-2.1-0 libmspub-0.1-1
  libmtp-common libmtp-runtime libmtp9 libmusicbrainz5-2 libmusicbrainz5cc2v5 libmwaw-0.3-3 libmythes-1.2-0 libnatpmp1 libndp0 libneon27-gnutls libnfs12 libnice10 libnma0 libnpth0 libnss-myhostname libnumbertext-1.0-0 libodfgen-0.1-1
  libofa0 libopenal-data libopenal1 libopenexr23 liborcus-0.14-0 libosinfo-1.0-0 libpagemaker-0.0-0 libpaper-utils libpaper1 libperl4-corelibs-perl libphodav-2.0-0 libphodav-2.0-common libphonenumber7 libprotobuf17 libpst4 libquadmath0
  libquvi-scripts-0.9 libqxp-0.0-0 libraw19 libreoffice-help-en-us libreofficekit-data librevenge-0.0-0 libsgutils2-2 libsmbios-c2 libsndio7.0 libsoundtouch1 libspandsp2 libspectre1 libsrtp2-1 libstaroffice-0.0-0 libsuitesparseconfig5
  libsynctex2 libtagc0 libtalloc2 libteamdctl0 libtevent0 libtotem-plparser-common libtracker-miner-2.0-0 libtss2-esys0 libtss2-udev libusbredirhost1 libusbredirparser1 libvisio-0.1-1 libvo-aacenc0 libvo-amrwbenc0 libvulkan1
  libwbclient0 libwildmidi2 libwinpr2-2 libwpd-0.10-10 libwpg-0.3-3 libwps-0.4-4 libxmlb1 libxmlsec1 libxmlsec1-nss libyajl2 libytnef0 libzapojit-0.0-0 libzbar0 libzmf-0.0-0 lp-solve lua-bitop lua-expat lua-json lua-lpeg lua-socket
  media-player-info mobile-broadband-provider-info mousetweaks mythes-en-us osinfo-db pinentry-curses poppler-data python-talloc python3-debian python3-distro-info python3-httplib2 python3-mako python3-markupsafe rhythmbox-data
  shotwell-common spice-client-glib-usb-acl-helper switcheroo-control totem-common tpm2-abrmd transmission-common unattended-upgrades usb.ids usbutils xwayland
Aby je usunąć należy użyć "apt autoremove".
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 2 nieaktualizowanych.
4 nie w pełni zainstalowanych lub usuniętych.
Po tej operacji zostanie dodatkowo użyte 0 B miejsca na dysku.
Kontynuować? [T/n] t
Konfigurowanie pakietu cyrus-common (3.0.8-6+deb10u5) ...
Creating/updating cyrus user account...
Użytkownik "cyrus" jest już członkiem grupy "sasl".
cyrus-common: Creating empty user_deny database...touch: nie można dotknąć '/var/lib/imap/user_deny.db': Nie ma takiego pliku ani katalogu
dpkg: błąd przetwarzania pakietu cyrus-common (--configure):
 podproces zainstalowany pakiet cyrus-common skrypt post-installation zwrócił kod błędu 1
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu cyrus-clients:
 cyrus-clients zależy od cyrus-common (>= 3.0.8); jednakże:
  Pakiet cyrus-common nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu cyrus-clients (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu cyrus-admin:
 cyrus-admin zależy od cyrus-common; jednakże:
  Pakiet cyrus-common nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu cyrus-admin (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu cyrus-imapd:
 cyrus-imapd zależy od cyrus-common (= 3.0.8-6+deb10u5); jednakże:
  Pakiet cyrus-common nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu cyrus-imapd (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Przetwarzanie wyzwalaczy pakietu libc-bin (2.28-10)...
Wystąpiły błędy podczas przetwarzania:
 cyrus-common
 cyrus-clients
 cyrus-admin
 cyrus-imapd
E: Sub-process /usr/bin/dpkg returned an error code (1)
Próbowałem robić update, upgrade, próbowałem również tak:

Kod: Zaznacz cały

/# dpkg --configure -a
dpkg: ostrzeżenie: "ldconfig" nie odnaleziono w PATH lub nie jest wykonywalny
dpkg: ostrzeżenie: "start-stop-daemon" nie odnaleziono w PATH lub nie jest wykonywalny
dpkg: błąd: 2 oczekiwane programy nieznalezione w PATH lub niebędące wykonywalnymi
Uwaga: Zmienna PATH dla konta administratora zawiera zwykle katalogi /usr/local/sbin, /usr/sbin oraz /sbin
no i cały czas stoję w miejscu i nie mam już pomysłów co mógłbym zrobić...czy jest ktoś kto byłby w stanie podsunąć mi rozwiązanie tego problemu ? czy czeka mnie reinstalacja systemu i konfigurowanie wszystkiego na nowo ?

Awatar użytkownika
dedito
Moderator
Posty: 3304
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Mail Serwer

Post autor: dedito » 01 kwietnia 2021, 12:33

Stosuj znaczniki kodu.
Uwaga: Zmienna PATH dla konta administratora zawiera zwykle katalogi /usr/local/sbin, /usr/sbin oraz /sbin
Na konto roota wchodź przez

Kod: Zaznacz cały

su -

baudi
Posty: 9
Rejestracja: 01 kwietnia 2021, 11:10

Re: Mail Serwer

Post autor: baudi » 01 kwietnia 2021, 14:53

Przed wykonaniem powyższych rzeczy byłem zalogowany na koncie root. Czy pomimo tego każdą komendę mam poprzedzać su ?. Wydaje mi się, że temat jest ciężki do ogarnięcia ponieważ posiadam wersję graficzną Debian'a a po restarcie systemu odpala mi się w interfejsie tekstowym.

Awatar użytkownika
dedito
Moderator
Posty: 3304
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Mail Serwer

Post autor: dedito » 01 kwietnia 2021, 17:14

Nic nie pisałem o poprzedzaniu komend tylko o wchodzeniu na konto root.
Jak się logujesz bezpośrednio z konsoli tekstowej na konto root to powinno być w porządku.
Sprawdź sobie zmienną PATH, bo najwyraźniej coś masz z nią nie tak.
Przechodzenie na roota przez su powoduje taki efekt.

baudi
Posty: 9
Rejestracja: 01 kwietnia 2021, 11:10

Re: Mail Serwer

Post autor: baudi » 01 kwietnia 2021, 18:53

Tak, źle zrozumiałem. Sprawdzę tą zmienną a jak nie pyknie to po prostu postawię na nowo w końcu to tylko dla testów i zabawa. Dzięki za podpowiedź ☺️

fnmirk
Senior Member
Posty: 8105
Rejestracja: 03 grudnia 2007, 06:37

Re: Mail Serwer

Post autor: fnmirk » 01 kwietnia 2021, 20:59

baudi pisze:Sprawdzę tą zmienną a jak nie pyknie to po prostu postawię na nowo w końcu to tylko dla testów i zabawa.
Zabawa, z której nic nie wynika. Sądzisz, że jak będziesz instalował wielokrotnie system to się czegoś nauczysz? Tylko się zniechęcisz.

Zacznij od zajrzenia do dokumentacji:

https://www.debian.org/doc/manuals/debi ... ex.en.html

W rozdziale: 1.1.4. The root shell prompt

Jest napisane:
Type "su -l" from any user shell prompt.

This does not preserve the environment of the current user.
Co oznacza, że nie zachowuje środowiska bieżącego użytkownika. Czyli wszystkie zmienne środowiskowe są właściwe dla administratora systemu. Jeżeli nie użyjesz wymienionej opcji to po zalogowaniu się na konto administratora systemu wszystkie zmienne środowiskowe będą właściwe dla konta użytkownika, z którego wykonałeś przełączenie się na konto administracyjne.
man su pisze: OPTIONS
...

-, -l, --login

Start the shell as a login shell with an environment similar to a real login:
...
Więcej sam przeczytaj w dokumentacji.
baudi pisze:Przed wykonaniem powyższych rzeczy byłem zalogowany na koncie root.
Czyli, jak sam przeczytasz (jak będziesz chciał), to logowanie, logowaniu nierówne, tak wynika z dokumentacji i co potwierdza działanie systemu.

baudi
Posty: 9
Rejestracja: 01 kwietnia 2021, 11:10

Re: Mail Serwer

Post autor: baudi » 01 kwietnia 2021, 21:17

Jasne, że przeczytam, weekend przede mną, dzięki!

ODPOWIEDZ