[+] Problem z aktualizacją gstreamer Temat rozwiązany

Tematy związane z oprogramowaniem, instalacją, konfiguracją
kacuranis
Posty: 12
Rejestracja: 28 października 2017, 19:38

Re: Problem z aktualizacją gstreamer

Post autor: kacuranis » 03 stycznia 2018, 19:01

n i n i n i n i nic to dalej ta sama śpiewka o wywaleniu gnome

Awatar użytkownika
dedito
Moderator
Posty: 2944
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z aktualizacją gstreamer

Post autor: dedito » 03 stycznia 2018, 19:55

To spróbujmy jeszcze tak:

Kod: Zaznacz cały

aptitude update && aptitude full-upgrade

kacuranis
Posty: 12
Rejestracja: 28 października 2017, 19:38

Re: Problem z aktualizacją gstreamer

Post autor: kacuranis » 03 stycznia 2018, 20:12

Kod: Zaznacz cały

root@none01i:/home/none02# aptitude update && aptitude full-upgrade
Stary  http://security.debian.org testing/updates InRelease
Stary  http://www.deb-multimedia.org testing InRelease
Stary  http://ftp.pl.debian.org/debian testing InRelease
                                                  
Następujące pakiety zostaną zaktualizowane:       
  gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0 gstreamer1.0-plugins-base 
  libjavascriptcoregtk-4.0-18 libwebkit2gtk-4.0-37{b} 
  libwebkit2gtk-4.0-37-gtk2{b} 
6 pakietów aktualizowanych, 0 instalowanych, 0 do usunięcia i 0 nieaktualizowanych.
Do pobrania 26,8 MB/28,3 MB archiwów. Zajęte po rozpakowaniu: 4792 kB.
Następujące pakiety mają niespełnione zależności:
 libwebkit2gtk-4.0-37 : Wymaga: libgstreamer-plugins-bad1.0-0 (< 1.13) but 1:1.10.4-dmo2 is installed
 libwebkit2gtk-4.0-37-gtk2 : Wymaga: libgstreamer-plugins-bad1.0-0 (< 1.13) but 1:1.10.4-dmo2 is installed
otwarte: 21; zamknięte: 624; odroczone: 1; konflikty: 1                       oNastępujące działania rozwiążą problemy z zależnościami:

     Zatrzymanie bieżących wersji następujących pakietów:
1)     gir1.2-javascriptcoregtk-4.0 [2.16.3-2 (now)]     
2)     gir1.2-webkit2-4.0 [2.16.3-2 (now)]               
3)     libjavascriptcoregtk-4.0-18 [2.16.3-2 (now)]      
4)     libwebkit2gtk-4.0-37 [2.16.3-2 (now)]             
5)     libwebkit2gtk-4.0-37-gtk2 [2.16.3-2 (now)]        



Zaakceptować rozwiązanie? [Y/n/q/?] n
Następujące działania rozwiążą problemy z zależnościami:

     Usunięcie następujących pakietów:                   
1)     libwebkit2gtk-4.0-37-gtk2 [2.16.3-2 (now)]        

     Zatrzymanie bieżących wersji następujących pakietów:
2)     gir1.2-javascriptcoregtk-4.0 [2.16.3-2 (now)]     
3)     gir1.2-webkit2-4.0 [2.16.3-2 (now)]               
4)     libjavascriptcoregtk-4.0-18 [2.16.3-2 (now)]      
5)     libwebkit2gtk-4.0-37 [2.16.3-2 (now)]             



Zaakceptować rozwiązanie? [Y/n/q/?] n
Następujące działania rozwiążą problemy z zależnościami:

      Usunięcie następujących pakietów:                   
1)      gir1.2-gepub-0.5 [0.5.2-2 (now, testing)]         
2)      gir1.2-webkit2-4.0 [2.16.3-2 (now)]               
3)      gnome [1:3.22+7 (now, testing)]                   
4)      gnome-core [1:3.22+7 (now, testing)]              
5)      gnome-documents [3.26.1-3 (now, testing)]         
6)      gnome-maps [3.26.2-2 (now, testing)]              
7)      gnome-sushi [3.24.0-3 (now, testing)]             
8)      rhythmbox-plugins [3.4.2-1 (now, testing)]        
9)      task-gnome-desktop [3.42 (now, testing)]          

      Instalacja następujących pakietów:                  
10)     libreoffice-gtk2 [1:5.4.4-1 (testing)]            
11)     lxlauncher [0.2.5-1 (testing)]                    
12)     task-lxde-desktop [3.42 (testing)]                
13)     xsane [0.999-5 (testing)]                         
14)     xsane-common [0.999-5 (testing)]                  

      Zatrzymanie bieżących wersji następujących pakietów:
15)     libjavascriptcoregtk-4.0-18 [2.16.3-2 (now)]      
16)     libwebkit2gtk-4.0-37 [2.16.3-2 (now)]             
17)     libwebkit2gtk-4.0-37-gtk2 [2.16.3-2 (now)]        

      Leave the following dependencies unresolved:        
18)     nautilus poleca gnome-sushi                       
19)     rhythmbox poleca rhythmbox-plugins                
20)     task-gnome-desktop poleca gnome                   



Zaakceptować rozwiązanie? [Y/n/q/?] 

Awatar użytkownika
yossarian
Beginner
Posty: 241
Rejestracja: 28 lutego 2009, 22:46
Lokalizacja: Kraina Deszczowców

Re: Problem z aktualizacją gstreamer

Post autor: yossarian » 03 stycznia 2018, 20:19

Na cholerę ci repozytorium deb-multimedia?

Tak się właśnie czasem kończy bezmyślne korzystanie z lewych repozytoriów.

Awatar użytkownika
dedito
Moderator
Posty: 2944
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z aktualizacją gstreamer

Post autor: dedito » 03 stycznia 2018, 20:24

Spróbuj jeszcze wybrać n pod kątem innych rozwiązań.

Awatar użytkownika
yossarian
Beginner
Posty: 241
Rejestracja: 28 lutego 2009, 22:46
Lokalizacja: Kraina Deszczowców

Re: Problem z aktualizacją gstreamer

Post autor: yossarian » 03 stycznia 2018, 20:34

To nic nie da.
Tam jest jakaś radziecka numeracja wersji tego pakietu z deb-multimedia.

Trzeba ręcznie wskazać aptitude numer wersji pakietu do zainstalowania:

Kod: Zaznacz cały

man aptitude
albo po prostu nie używać nieoficjalnych repozytoriów deb-multimedia bo takie problemy będą co jakiś czas powracać.

kacuranis
Posty: 12
Rejestracja: 28 października 2017, 19:38

Re: Problem z aktualizacją gstreamer

Post autor: kacuranis » 03 stycznia 2018, 20:47

Potwierdzam nic n sensownego nie proponuje

Awatar użytkownika
dedito
Moderator
Posty: 2944
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z aktualizacją gstreamer

Post autor: dedito » 03 stycznia 2018, 20:48

Ja używam deb-multimedia od około 4 edycji wstecz (utrzymuję testinga) i nie notowałem większych problemów w tym temacie choć często czytam, że te repo jest "be" i należy się go wystrzegać.
Pokaż jeszcze co będzie chciał zrobić po:

Kod: Zaznacz cały

aptitude remove gstreamer1.0-plugins-base

kacuranis
Posty: 12
Rejestracja: 28 października 2017, 19:38

Re: Problem z aktualizacją gstreamer

Post autor: kacuranis » 03 stycznia 2018, 21:12

Kod: Zaznacz cały

root@none01i:/home/none02# aptitude remove gstreamer1.0-plugins-base
Następujące pakiety zostaną USUNIĘTE:             
  gstreamer1.0-plugins-base libcdparanoia0{u} 
0 pakietów aktualizowanych, 0 instalowanych, 2 do usunięcia i 5 nieaktualizowanych.
Do pobrania 0 B archiwów. Zwolnione po rozpakowaniu: 3126 kB.
Następujące pakiety mają niespełnione zależności:
 brasero : Wymaga: gstreamer1.0-plugins-base (>= 0.11.92) but it is not going to be installed
 gstreamer1.0-plugins-good : Wymaga: gstreamer1.0-plugins-base but it is not going to be installed
 gstreamer1.0-plugins-bad : Wymaga: gstreamer1.0-plugins-base but it is not going to be installed
 libfarstream-0.2-5 : Wymaga: gstreamer1.0-plugins-base but it is not going to be installed
 gnome-sound-recorder : Wymaga: gstreamer1.0-plugins-base but it is not going to be installed
 libevview3-3 : Wymaga: gstreamer1.0-plugins-base but it is not going to be installed
 gnome-core : Wymaga: gstreamer1.0-plugins-base (>= 1.10) but it is not going to be installed
 libcheese8 : Wymaga: gstreamer1.0-plugins-base (>= 0.11.0) but it is not going to be installed
 totem : Wymaga: gstreamer1.0-plugins-base (>= 1.6.0) but it is not going to be installed
 rhythmbox : Wymaga: gstreamer1.0-plugins-base (>= 1.4.0) but it is not going to be installed
 sound-juicer : Wymaga: gstreamer1.0-plugins-base but it is not going to be installed
otwarte: 45; zamknięte: 223; odroczone: 3; konflikty: 3                       .Następujące działania rozwiążą problemy z zależnościami:

      Usunięcie następujących pakietów:                                      
1)      brasero [3.12.2-4 (now, testing)]                                    
2)      cheese [3.26.0-3 (now, testing)]                                     
3)      empathy [3.25.90+really3.12.14-1 (now, testing)]                     
4)      evince [3.26.0-2 (now, testing)]                                     
5)      gir1.2-evince-3.0 [3.26.0-2 (now, testing)]                          
6)      gnome [1:3.22+7 (now, testing)]                                      
7)      gnome-contacts [3.26-2 (now, testing)]                               
8)      gnome-control-center [1:3.26.2-1 (now, testing)]                     
9)      gnome-core [1:3.22+7 (now, testing)]                                 
10)     gnome-documents [3.26.1-3 (now, testing)]                            
11)     gnome-sound-recorder [3.24.0.1-2 (now, testing)]                     
12)     gnome-sushi [3.24.0-3 (now, testing)]                                
13)     gnome-video-effects [0.4.3-1 (now, testing)]                         
14)     gstreamer1.0-plugins-bad [1:1.10.4-dmo2 (now)]                       
15)     gstreamer1.0-plugins-good [1.12.4-1 (now, testing)]                  
16)     libcheese-gtk25 [3.26.0-3 (now, testing)]                            
17)     libcheese8 [3.26.0-3 (now, testing)]                                 
18)     libevview3-3 [3.26.0-2 (now, testing)]                               
19)     libfarstream-0.2-5 [0.2.8-2 (now, testing)]                          
20)     libpurple-bin [2.12.0-1 (now, testing)]                              
21)     libpurple0 [2.12.0-1+b1 (now, testing)]                              
22)     libtelepathy-farstream3 [0.6.2-1+b1 (now, testing)]                  
23)     rhythmbox [3.4.2-1 (now, testing)]                                   
24)     rhythmbox-plugin-cdrecorder [3.4.2-1 (now, testing)]                 
25)     rhythmbox-plugins [3.4.2-1 (now, testing)]                           
26)     rygel-playbin [0.36.0-1 (now, testing)]                              
27)     sound-juicer [3.24.0-2 (now, testing)]                               
28)     task-gnome-desktop [3.42 (now, testing)]                             
29)     telepathy-haze [0.8.0-2.1 (now, testing)]                            
30)     totem [3.26.0-3 (now, testing)]                                      
31)     totem-plugins [3.26.0-3 (now, testing)]                              

      Instalacja następujących pakietów:                                     
32)     libreoffice-gtk2 [1:5.4.4-1 (testing)]                               
33)     lxlauncher [0.2.5-1 (testing)]                                       
34)     mupdf [1.11+ds1-2 (testing)]                                         
35)     task-lxde-desktop [3.42 (testing)]                                   
36)     xsane [0.999-5 (testing)]                                            
37)     xsane-common [0.999-5 (testing)]                                     

      Leave the following dependencies unresolved:                           
38)     libbrasero-media3-1 poleca gstreamer1.0-plugins-good                 
39)     gnome-bluetooth poleca gnome-control-center | unity-control-center   
40)     gnome-online-accounts poleca gnome-control-center (>= 3.6.1)         
41)     gnome-shell poleca gnome-control-center (>= 1:3.25.2)                
42)     libgstreamer-plugins-base1.0-0 poleca gstreamer1.0-plugins-base      
43)     libreoffice-avmedia-backend-gstreamer poleca gstreamer1.0-plugins-bad
44)     nautilus poleca gnome-sushi                                          
45)     rhythmbox-data poleca rhythmbox                                      
46)     rygel poleca gstreamer1.0-plugins-base                               
47)     rygel poleca gstreamer1.0-plugins-good                               
48)     task-gnome-desktop poleca gnome                                      
49)     libwebkit2gtk-4.0-37 poleca gstreamer1.0-plugins-base                
50)     libwebkit2gtk-4.0-37 poleca gstreamer1.0-plugins-good                



Zaakceptować rozwiązanie? [Y/n/q/?]
n-ki też nic sensownego nie proponują

Awatar użytkownika
dedito
Moderator
Posty: 2944
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z aktualizacją gstreamer

Post autor: dedito » 03 stycznia 2018, 21:27

No to jeśli dobrze rozumiem kolegę @yossarian to chodzi mu o:

Kod: Zaznacz cały

aptitude install gstreamer1.0-plugins-bad=1.12.4-2

Zablokowany