[+] Problem z aktualizacją gstreamer Temat rozwiązany

Tematy związane z oprogramowaniem, instalacją, konfiguracją
kacuranis
Posty: 12
Rejestracja: 28 października 2017, 19:38

[+] Problem z aktualizacją gstreamer

Post autor: kacuranis » 03 stycznia 2018, 13:35

Witam czy ktoś by mnie naprowadził na rozwiązanie tego problemu

Kod: Zaznacz cały

root@none01i:/home/none02# aptitude upgrade
Uzupełnianie niespełnionych zależności...         
Następujące pakiety zostaną zaktualizowane:
  gstreamer1.0-plugins-base 
1 pakietów aktualizowanych, 0 instalowanych, 0 do usunięcia i 5 nieaktualizowanych.
Do pobrania 0 B/1565 kB archiwów. Zajęte po rozpakowaniu: 117 kB.
Kontynuować? [Y/n/?] y
Odczytywanie dzienników zmian... Zrobione         
(Odczytywanie bazy danych ... 288200 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu .../gstreamer1.0-plugins-base_1.12.4-1_i386.deb ...
Rozpakowywanie pakietu gstreamer1.0-plugins-base:i386 (1.12.4-1) nad (1.10.4-1) ...
dpkg: błąd przetwarzania archiwum /var/cache/apt/archives/gstreamer1.0-plugins-base_1.12.4-1_i386.deb (--unpack):
 próba nadpisania "/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstrawparse.so", który istnieje także w pakiecie gstreamer1.0-plugins-bad:i386 1:1.10.4-dmo2
dpkg-deb: błąd: wklej subprocess was killed by signal (Przerwany potok)
Wystąpiły błędy podczas przetwarzania:
 /var/cache/apt/archives/gstreamer1.0-plugins-base_1.12.4-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
                                                  
Ostatnio zmieniony 03 stycznia 2018, 23:26 przez kacuranis, łącznie zmieniany 1 raz.

Awatar użytkownika
dedito
Moderator
Posty: 2881
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z aktualizacją gstreamer

Post autor: dedito » 03 stycznia 2018, 13:48

Pokaż wynik

Kod: Zaznacz cały

apt-cache policy

kacuranis
Posty: 12
Rejestracja: 28 października 2017, 19:38

Re: Problem z aktualizacją gstreamer

Post autor: kacuranis » 03 stycznia 2018, 14:19

Kod: Zaznacz cały

root@none01i:/home/none02# apt-cache policy
Plików pakietów:
 100 /var/lib/dpkg/status
     release a=now
 500 http://repo.vivaldi.com/stable/deb stable/main i386 Packages
     release o=Vivaldi Technologies,a=stable,l=Official Vivaldi package repository,c=main,b=i386
     origin repo.vivaldi.com
 500 http://www.deb-multimedia.org testing/non-free i386 Packages
     release v=0.0,o=Unofficial Multimedia Packages,a=testing,n=buster,l=Unofficial Multimedia Packages,c=non-free,b=i386
     origin www.deb-multimedia.org
 500 http://www.deb-multimedia.org testing/main i386 Packages
     release v=0.0,o=Unofficial Multimedia Packages,a=testing,n=buster,l=Unofficial Multimedia Packages,c=main,b=i386
     origin www.deb-multimedia.org
 500 http://ftp.pl.debian.org/debian testing/contrib i386 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=contrib,b=i386
     origin ftp.pl.debian.org
 500 http://ftp.pl.debian.org/debian testing/non-free i386 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=non-free,b=i386
     origin ftp.pl.debian.org
 500 http://ftp.pl.debian.org/debian testing/main i386 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=main,b=i386
     origin ftp.pl.debian.org
Przypięte pakiety:

Awatar użytkownika
dedito
Moderator
Posty: 2881
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z aktualizacją gstreamer

Post autor: dedito » 03 stycznia 2018, 15:57

A sory, zapomniałem jeszcze o:

Kod: Zaznacz cały

apt-cache policy gstreamer1.0-plugins-base
oraz

Kod: Zaznacz cały

apt-cache policy gstreamer1.0-plugins-bad

kacuranis
Posty: 12
Rejestracja: 28 października 2017, 19:38

Re: Problem z aktualizacją gstreamer

Post autor: kacuranis » 03 stycznia 2018, 16:23

Kod: Zaznacz cały

none02@none01i:~$ apt-cache policy gstreamer1.0-plugins-base
gstreamer1.0-plugins-base:
  Zainstalowana: 1.10.4-1
  Kandydująca:   1.12.4-1
  Tabela wersji:
     1.12.4-1 500
        500 http://ftp.pl.debian.org/debian testing/main i386 Packages
 *** 1.10.4-1 100
        100 /var/lib/dpkg/status

Kod: Zaznacz cały

none02@none01i:~$ apt-cache policy gstreamer1.0-plugins-bad
gstreamer1.0-plugins-bad:
  Zainstalowana: 1:1.10.4-dmo2
  Kandydująca:   1:1.10.4-dmo2
  Tabela wersji:
 *** 1:1.10.4-dmo2 100
        100 /var/lib/dpkg/status
     1.12.4-dmo1 500
        500 http://www.deb-multimedia.org testing/main i386 Packages
     1.12.4-2 500
        500 http://ftp.pl.debian.org/debian testing/main i386 Packages

Awatar użytkownika
dedito
Moderator
Posty: 2881
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z aktualizacją gstreamer

Post autor: dedito » 03 stycznia 2018, 17:38

Spróbuj to zrobić tak:

Kod: Zaznacz cały

apt-get remove gstreamer1.0-plugins-bad
Jakby chciał coś więcej jeszcze usunąć to wklej tu co, będziemy myśleć co z tym fantem zrobić.
Potem:

Kod: Zaznacz cały

apt-get update && apt-get dist-upgrade
i ewentualnie potem jeszcze:

Kod: Zaznacz cały

apt-get install gstreamer1.0-plugins-bad

kacuranis
Posty: 12
Rejestracja: 28 października 2017, 19:38

Re: Problem z aktualizacją gstreamer

Post autor: kacuranis » 03 stycznia 2018, 17:49

Kod: Zaznacz cały

root@none01i:/home/none02# apt-get remove gstreamer1.0-plugins-bad
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Następujące pakiety zostały zainstalowane automatycznie i nie są już więcej wymagane:
  alacarte apg brasero brasero-cdrkit cheese-common dvdauthor empathy-common
  gnome-control-center-data growisofs gstreamer1.0-nice libdiscid0 libfaac0
  libfaad2 libflite1 libfluidsynth1 libfolks-telepathy25
  libgstreamer-plugins-bad1.0-0 libgupnp-igd-1.0-4 liblilv-0-0 liblrdf0
  libmeanwhile1 libmjpegutils-2.1-0 libmms0 libmpeg2encpp-2.1-0
  libmplex2-2.1-0 libnice10 libnss-myhostname libofa0 libopenh264-2
  libserd-0-0 libsord-0-0 libsoundtouch1 libspandsp2 libsratom-0-0 libsrtp0
  libvo-aacenc0 libwildmidi-config libwildmidi2 libx265-116 libzbar0
  libzephyr4 mousetweaks pidgin-data realmd sound-juicer telepathy-gabble
  telepathy-salut
Aby je usunąć należy użyć "apt autoremove".
Następujące pakiety zostaną USUNIĘTE:
  cheese empathy gnome gnome-contacts gnome-control-center gnome-core
  gnome-video-effects gstreamer1.0-plugins-bad libcheese-gtk25 libcheese8
  libfarstream-0.2-5 libpurple-bin libpurple0 libtelepathy-farstream3
  task-gnome-desktop telepathy-haze
0 aktualizowanych, 0 nowo instalowanych, 16 usuwanych i 6 nieaktualizowanych.
Po tej operacji zostanie zwolnione 27,6 MB miejsca na dysku.
Kontynuować? [T/n] 

Awatar użytkownika
dedito
Moderator
Posty: 2881
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z aktualizacją gstreamer

Post autor: dedito » 03 stycznia 2018, 17:59

Nie no gnome nie chcemy raczej usuwać?
Sprawdź przez aptitude, powinien zaproponować coś lepszego.

Kod: Zaznacz cały

aptitude remove gstreamer1.0-plugins-bad

kacuranis
Posty: 12
Rejestracja: 28 października 2017, 19:38

Re: Problem z aktualizacją gstreamer

Post autor: kacuranis » 03 stycznia 2018, 18:20

oczywiście że nie chcę usuwać gnoma

Kod: Zaznacz cały

root@none01i:/home/none02# aptitude remove gstreamer1.0-plugins-bad
Następujące pakiety zostaną USUNIĘTE:             
  gstreamer1.0-plugins-bad libfaac0{u} libfaad2{u} libflite1{u} 
  libfluidsynth1{u} libgstreamer-plugins-bad1.0-0{u} liblilv-0-0{u} 
  liblrdf0{u} libmjpegutils-2.1-0{u} libmms0{u} libmpeg2encpp-2.1-0{u} 
  libmplex2-2.1-0{u} libofa0{u} libopenh264-2{u} libserd-0-0{u} 
  libsord-0-0{u} libsoundtouch1{u} libspandsp2{u} libsratom-0-0{u} 
  libsrtp0{u} libvo-aacenc0{u} libwildmidi-config{u} libwildmidi2{u} 
  libx265-116{u} libzbar0{u} 
0 pakietów aktualizowanych, 0 instalowanych, 25 do usunięcia i 6 nieaktualizowanych.
Do pobrania 0 B archiwów. Zwolnione po rozpakowaniu: 40,9 MB.
Następujące pakiety mają niespełnione zależności:
 gnome-video-effects : Wymaga: gstreamer1.0-plugins-bad but it is not going to be installed
 libfarstream-0.2-5 : Wymaga: gstreamer1.0-plugins-bad but it is not going to be installed
 libcheese8 : Wymaga: gstreamer1.0-plugins-bad (>= 1.4) but it is not going to be installed
otwarte: 17; zamknięte: 432; odroczone: 1; konflikty: 1                       oNastępujące działania rozwiążą problemy z zależnościami:

      Usunięcie następujących pakietów:                                      
1)      cheese [3.26.0-3 (now, testing)]                                     
2)      empathy [3.25.90+really3.12.14-1 (now, testing)]                     
3)      gnome [1:3.22+7 (now, testing)]                                      
4)      gnome-contacts [3.26-2 (now, testing)]                               
5)      gnome-control-center [1:3.26.2-1 (now, testing)]                     
6)      gnome-core [1:3.22+7 (now, testing)]                                 
7)      gnome-video-effects [0.4.3-1 (now, testing)]                         
8)      libcheese-gtk25 [3.26.0-3 (now, testing)]                            
9)      libcheese8 [3.26.0-3 (now, testing)]                                 
10)     libfarstream-0.2-5 [0.2.8-2 (now, testing)]                          
11)     libpurple-bin [2.12.0-1 (now, testing)]                              
12)     libpurple0 [2.12.0-1+b1 (now, testing)]                              
13)     libtelepathy-farstream3 [0.6.2-1+b1 (now, testing)]                  
14)     task-gnome-desktop [3.42 (now, testing)]                             
15)     telepathy-haze [0.8.0-2.1 (now, testing)]                            

      Instalacja następujących pakietów:                                     
16)     libreoffice-gtk2 [1:5.4.4-1 (testing)]                               
17)     lxlauncher [0.2.5-1 (testing)]                                       
18)     task-lxde-desktop [3.42 (testing)]                                   
19)     xsane [0.999-5 (testing)]                                            
20)     xsane-common [0.999-5 (testing)]                                     

      Leave the following dependencies unresolved:                           
21)     gnome-bluetooth poleca gnome-control-center | unity-control-center   
22)     gnome-online-accounts poleca gnome-control-center (>= 3.6.1)         
23)     gnome-shell poleca gnome-control-center (>= 1:3.25.2)                
24)     libreoffice-avmedia-backend-gstreamer poleca gstreamer1.0-plugins-bad
25)     task-gnome-desktop poleca gnome                                      
26)     totem poleca gstreamer1.0-plugins-bad                                



Zaakceptować rozwiązanie? [Y/n/q/?] 

Awatar użytkownika
dedito
Moderator
Posty: 2881
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z aktualizacją gstreamer

Post autor: dedito » 03 stycznia 2018, 18:42

Daj n i sprawdź co zaproponuje i z znowu n, aż wyczerpią mu się pomysły.
Najwyżej spróbujemy zatrzymać tą paczkę, aby nie była "upgrejdowana".

Zablokowany