[+]Problem z zależnościami

Tematy związane z oprogramowaniem, instalacją, konfiguracją
Awatar użytkownika
korbielow
Beginner
Posty: 325
Rejestracja: 29 marca 2014, 20:37

[+]Problem z zależnościami

Post autor: korbielow » 18 grudnia 2017, 22:14

Witam
Mam Debiana 9 i nie moge sobie poradzic z zależnosciami. Ciagle mam jakies problemy podaje przykład:

Kod: Zaznacz cały

root@debian:/home/rafal# apt-get install firefox
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Należy uruchomić "apt --fix-broken install", aby je naprawić.
Następujące pakiety mają niespełnione zależności:
 kolourpaint4:i386 : Wymaga: kde-runtime:i386 ale nie zostanie zainstalowany
                     Wymaga: libkdecore5:i386 (>= 4:4.8.1) ale nie zostanie zainstalowany
                     Wymaga: libkdeui5:i386 (>= 4:4.8.1) ale nie zostanie zainstalowany
                     Wymaga: libkio5:i386 (>= 4:4.8.1) ale nie zostanie zainstalowany
                     Wymaga: libkprintutils4:i386 (>= 4:4.8.1) ale nie zostanie zainstalowany
                     Wymaga: libqimageblitz4:i386 (>= 1:0.0.4) ale nie zostanie zainstalowany
                     Wymaga: libqtcore4:i386 (>= 4:4.7.0~beta1) ale nie zostanie zainstalowany
                     Wymaga: libqtgui4:i386 (>= 4:4.8.0) ale nie zostanie zainstalowany
                     Wymaga: libstdc++6:i386 (>= 4.1.1) ale nie zostanie zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać "apt --fix-broken install" bez pakietów (lub podać rozwiązanie).
Jak dam apt --fix broken install to chce mi wywalic programy ktore potrzebuje

Kod: Zaznacz cały

root@debian:/home/rafal# apt --fix-broken install
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Naprawianie zależności... Gotowe
Następujące pakiety zostały zainstalowane automatycznie i nie są już więcej wymagane:
  aptitude-doc-en coinor-libcbc3 coinor-libcgl1 coinor-libclp1
  coinor-libcoinutils3v5 coinor-libosi1v5 cpp-4.8 deluge-common deluge-gtk
  docbook-xml docbook-xsl dvdauthor filezilla-common genisoimage geoclue-2.0
  icoutils iio-sensor-proxy kio libass5 libavdevice57 libavfilter6
  libavresample3 libboost-filesystem1.62.0 libboost-iostreams1.62.0
  libboost-program-options1.62.0 libboost-random1.62.0 libboost-system1.62.0
  libcdaudio1 libcgi-fast-perl libcgi-pm-perl libclass-accessor-perl
  libcolamd2 libcwidget3v5 libdbusmenu-qt5-2 libfcgi-perl libgeoclue-2-0
  libgpgmepp6 libgstreamer-plugins-bad0.10-0 libio-string-perl libjasper1
  libjemalloc1 libkf5archive5 libkf5attica5 libkf5auth-data libkf5auth5
  libkf5bookmarks-data libkf5bookmarks5 libkf5codecs-data libkf5codecs5
  libkf5completion-data libkf5completion5 libkf5config-data libkf5configcore5
  libkf5configgui5 libkf5configwidgets-data libkf5configwidgets5
  libkf5coreaddons-data libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-data
  libkf5dbusaddons5 libkf5globalaccel-data libkf5globalaccel5 libkf5guiaddons5
  libkf5i18n-data libkf5i18n5 libkf5iconthemes-data libkf5iconthemes5
  libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data
  libkf5jobwidgets5 libkf5kdelibs4support-data libkf5kdelibs4support5
  libkf5kdelibs4support5-bin libkf5kiocore5 libkf5kiofilewidgets5
  libkf5kiontlm5 libkf5kiowidgets5 libkf5notifications-data
  libkf5notifications5 libkf5parts-data libkf5parts-plugins libkf5parts5
  libkf5service-bin libkf5service-data libkf5service5 libkf5solid5
  libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5
  libkf5textwidgets-data libkf5textwidgets5 libkf5wallet-bin libkf5wallet-data
  libkf5wallet5 libkf5widgetsaddons-data libkf5widgetsaddons5
  libkf5windowsystem-data libkf5windowsystem5 libkf5xmlgui-data libkf5xmlgui5
  libkwalletbackend5-5 liblept5 libmariadbclient18 libmikmod3 libmimic0
  libopts25 liborcus-0.11-0 libparse-debianchangelog-perl libparted-fs-resize0
  libphonon4qt5-4 libpng12-0 libpolkit-qt5-1-1 libportmidi0 libpq5
  libqt4-script libqt4-sql libqt4-sql-mysql libqt4-svg libqt4-xmlpatterns
  libqt5script5 libqt5test5 libqt5x11extras5 libqt5xml5 libqtassistantclient4
  librubberband2 libsdl-mixer1.2 libsdl-ttf2.0-0 libsdl2-2.0-0 libslv2-9
  libsmpeg0 libsub-name-perl libsuitesparseconfig4 libtesseract-data
  libtesseract3 libva-wayland1 libvidstab1.0 libvpx1 libwebpdemux1
  libwildmidi1 libwxbase3.0-0v5 libwxgtk3.0-0v5 libxapian30 libxml2-utils
  lp-solve mtools musescore-soundfont-gm mysql-common phonon4qt5
  phonon4qt5-backend-vlc python-attr python-cffi-backend python-click
  python-colorama python-constantly python-cryptography python-enum34
  python-glade2 python-idna python-incremental python-ipaddress python-notify
  python-openssl python-pam python-pyasn1 python-pyasn1-modules python-pygame
  python-serial python-service-identity python-twisted-bin python-twisted-core
  python-twisted-web python-wxgtk3.0 python-wxversion python-zope.interface
  sgml-data syslinux syslinux-common timgm6mb-soundfont wodim
Aby je usunąć należy użyć "apt autoremove".
The following additional packages will be installed:
  hunspell-sv
Sugerowane pakiety:
  hunspell
Następujące pakiety zostaną USUNIĘTE:
  coinor-libcoinmp1v5 google-chrome-stable kolourpaint4:i386
  libboost-chrono1.62.0 libboost-python1.62.0 libkdeui5 libkf5config-bin
  libkf5dbusaddons-bin libkf5globalaccel-bin libkf5globalaccelprivate5
  libkf5iconthemes-bin libkf5xmlgui-bin libqt4-declarative libqt4-designer
  libqt4-help libqt4-scripttools libqt4-test mesa-utils playonlinux
  sonnet-plugins
Zostaną zainstalowane następujące NOWE pakiety:
  hunspell-sv
0 aktualizowanych, 1 nowo instalowanych, 20 usuwanych i 5 nieaktualizowanych.
1 nie w pełni zainstalowanych lub usuniętych.
Konieczne pobranie 828 kB archiwów.
Po tej operacji zostanie zwolnione 208 MB miejsca na dysku.
Kontynuować? [T/n] n
Przerwane.
tak wyglada moj source.list

Kod: Zaznacz cały

# Stretch 
deb http://ftp.pl.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
deb http://ftp.pl.debian.org/debian/ stretch-updates main contrib non-free 

# Backports Stretch 
deb http://ftp.pl.debian.org/debian/ stretch-backports main contrib non-free

# Debian-multimedia 
deb http://www.deb-multimedia.org/ stable main non-free
deb http://ftp.debian.org/debian stretch-backports main
## przeglądarka Opera
#deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final $
deb http://dl.google.com/linux/chrome/deb/ stable main
deb http://packages.linuxmint.com debian import

Kolejny przykład tym razem z Adobre Readerem.

Kod: Zaznacz cały

root@debian:/home/rafal/Pobrane# dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb 
Wybieranie wcześniej niewybranego pakietu adobereader-enu:i386.
(Odczytywanie bazy danych ... 158452 pliki i katalogi obecnie zainstalowane.)
Przygotowywanie do rozpakowania pakietu AdbeRdr9.5.5-1_i386linux_enu.deb ...
Rozpakowywanie pakietu adobereader-enu:i386 (9.5.5) ...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu adobereader-enu:i386:
 adobereader-enu:i386 zależy od libgtk2.0-0 (>= 2.4); jednakże:
  Pakiet libgtk2.0-0:i386 nie jest zainstalowany.

dpkg: błąd przetwarzania pakietu adobereader-enu:i386 (--install):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Przetwarzanie wyzwalaczy pakietu man-db (2.7.6.1-2)...
Wystąpiły błędy podczas przetwarzania:
 adobereader-enu:i386
root@debian:/home/rafal/Pobrane# apt-get install libgtk2.0-0:i386
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Należy uruchomić "apt --fix-broken install", aby je naprawić.
Następujące pakiety mają niespełnione zależności:
 kolourpaint4:i386 : Wymaga: kde-runtime:i386 ale nie zostanie zainstalowany
                     Wymaga: libkdecore5:i386 (>= 4:4.8.1) ale nie zostanie zainstalowany
                     Wymaga: libkdeui5:i386 (>= 4:4.8.1) ale nie zostanie zainstalowany
                     Wymaga: libkio5:i386 (>= 4:4.8.1) ale nie zostanie zainstalowany
                     Wymaga: libkprintutils4:i386 (>= 4:4.8.1) ale nie zostanie zainstalowany
                     Wymaga: libqimageblitz4:i386 (>= 1:0.0.4) ale nie zostanie zainstalowany
                     Wymaga: libqtcore4:i386 (>= 4:4.7.0~beta1) ale nie zostanie zainstalowany
                     Wymaga: libqtgui4:i386 (>= 4:4.8.0) ale nie zostanie zainstalowany
                     Wymaga: libstdc++6:i386 (>= 4.1.1) ale nie zostanie zainstalowany
 libgtk2.0-0:i386 : Wymaga: libcups2:i386 (>= 1.6.0) ale nie zostanie zainstalowany
                    Wymaga: libxcursor1:i386 (> 1.1.2) ale nie zostanie zainstalowany
                    Poleca: libgail-common:i386 ale nie zostanie zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać "apt --fix-broken install" bez pakietów (lub podać rozwiązanie).
Proszę o pomoc...

Awatar użytkownika
dedito
Moderator
Posty: 2971
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z zależnościami

Post autor: dedito » 19 grudnia 2017, 06:50

Pokaż jeszcze

Kod: Zaznacz cały

apt-cache policy

Awatar użytkownika
korbielow
Beginner
Posty: 325
Rejestracja: 29 marca 2014, 20:37

Re: Problem z zależnościami

Post autor: korbielow » 19 grudnia 2017, 07:29

Kod: Zaznacz cały

root@debian:/home/rafal# apt-cache policy
Plików pakietów:
 100 /var/lib/dpkg/status
     release a=now
 500 http://deb.playonlinux.com maverick/main i386 Packages
     release v=10.10,o=PlayOnLinux,a=maverick,n=maverick,l=PoL,c=main,b=i386
     origin deb.playonlinux.com
 500 http://deb.playonlinux.com maverick/main amd64 Packages
     release v=10.10,o=PlayOnLinux,a=maverick,n=maverick,l=PoL,c=main,b=amd64
     origin deb.playonlinux.com
 500 https://deb.opera.com/opera-stable stable/non-free i386 Packages
     release o=Opera Software ASA,a=stable,n=stable,l=The Opera web browser,c=non-free,b=i386
     origin deb.opera.com
 500 https://deb.opera.com/opera-stable stable/non-free amd64 Packages
     release o=Opera Software ASA,a=stable,n=stable,l=The Opera web browser,c=non-free,b=amd64
     origin deb.opera.com
 500 http://packages.linuxmint.com debian/import i386 Packages
     release v=1,o=linuxmint,a=debian,n=debian,l=linuxmint,c=import,b=i386
     origin packages.linuxmint.com
 500 http://packages.linuxmint.com debian/import amd64 Packages
     release v=1,o=linuxmint,a=debian,n=debian,l=linuxmint,c=import,b=amd64
     origin packages.linuxmint.com
 500 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages
     release v=1.0,o=Google, Inc.,a=stable,n=stable,l=Google,c=main,b=amd64
     origin dl.google.com
 100 http://ftp.debian.org/debian stretch-backports/main i386 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=main,b=i386
     origin ftp.debian.org
 100 http://ftp.debian.org/debian stretch-backports/main amd64 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=main,b=amd64
     origin ftp.debian.org
 500 http://www.deb-multimedia.org stable/non-free i386 Packages
     release v=9.3,o=Unofficial Multimedia Packages,a=stable,n=stretch,l=Unofficial Multimedia Packages,c=non-free,b=i386
     origin www.deb-multimedia.org
 500 http://www.deb-multimedia.org stable/non-free amd64 Packages
     release v=9.3,o=Unofficial Multimedia Packages,a=stable,n=stretch,l=Unofficial Multimedia Packages,c=non-free,b=amd64
     origin www.deb-multimedia.org
 500 http://www.deb-multimedia.org stable/main i386 Packages
     release v=9.3,o=Unofficial Multimedia Packages,a=stable,n=stretch,l=Unofficial Multimedia Packages,c=main,b=i386
     origin www.deb-multimedia.org
 500 http://www.deb-multimedia.org stable/main amd64 Packages
     release v=9.3,o=Unofficial Multimedia Packages,a=stable,n=stretch,l=Unofficial Multimedia Packages,c=main,b=amd64
     origin www.deb-multimedia.org
 100 http://ftp.pl.debian.org/debian stretch-backports/non-free i386 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=non-free,b=i386
     origin ftp.pl.debian.org
 100 http://ftp.pl.debian.org/debian stretch-backports/non-free amd64 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=non-free,b=amd64
     origin ftp.pl.debian.org
 100 http://ftp.pl.debian.org/debian stretch-backports/contrib i386 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=contrib,b=i386
     origin ftp.pl.debian.org
 100 http://ftp.pl.debian.org/debian stretch-backports/contrib amd64 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=contrib,b=amd64
     origin ftp.pl.debian.org
 100 http://ftp.pl.debian.org/debian stretch-backports/main i386 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=main,b=i386
     origin ftp.pl.debian.org
 100 http://ftp.pl.debian.org/debian stretch-backports/main amd64 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=main,b=amd64
     origin ftp.pl.debian.org
 500 http://ftp.pl.debian.org/debian stretch-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=stretch-updates,l=Debian,c=main,b=i386
     origin ftp.pl.debian.org
 500 http://ftp.pl.debian.org/debian stretch-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=stretch-updates,l=Debian,c=main,b=amd64
     origin ftp.pl.debian.org
 500 http://security.debian.org stretch/updates/non-free i386 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=non-free,b=i386
     origin security.debian.org
 500 http://security.debian.org stretch/updates/non-free amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 500 http://security.debian.org stretch/updates/contrib i386 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=contrib,b=i386
     origin security.debian.org
 500 http://security.debian.org stretch/updates/contrib amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=contrib,b=amd64
     origin security.debian.org
 500 http://security.debian.org stretch/updates/main i386 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=main,b=i386
     origin security.debian.org
 500 http://security.debian.org stretch/updates/main amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://ftp.pl.debian.org/debian stretch/non-free i386 Packages
     release v=9.3,o=Debian,a=stable,n=stretch,l=Debian,c=non-free,b=i386
     origin ftp.pl.debian.org
 500 http://ftp.pl.debian.org/debian stretch/non-free amd64 Packages
     release v=9.3,o=Debian,a=stable,n=stretch,l=Debian,c=non-free,b=amd64
     origin ftp.pl.debian.org
 500 http://ftp.pl.debian.org/debian stretch/contrib i386 Packages
     release v=9.3,o=Debian,a=stable,n=stretch,l=Debian,c=contrib,b=i386
     origin ftp.pl.debian.org
 500 http://ftp.pl.debian.org/debian stretch/contrib amd64 Packages
     release v=9.3,o=Debian,a=stable,n=stretch,l=Debian,c=contrib,b=amd64
     origin ftp.pl.debian.org
 500 http://ftp.pl.debian.org/debian stretch/main i386 Packages
     release v=9.3,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=i386
     origin ftp.pl.debian.org
 500 http://ftp.pl.debian.org/debian stretch/main amd64 Packages
     release v=9.3,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=amd64
     origin ftp.pl.debian.org
Przypięte pakiety:

Awatar użytkownika
dedito
Moderator
Posty: 2971
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z zależnościami

Post autor: dedito » 19 grudnia 2017, 08:42

Masz tam jakieś repozytoria dla ubuntu i minta.

Kod: Zaznacz cały

http://deb.playonlinux.com maverick/main
http://packages.linuxmint.com debian/import
Te mintowe repo chyba wprowadza zamieszanie (patrząc na listę paczek jakie udostępnia).
Pokaż:

Kod: Zaznacz cały

apt-cache firefox
i napisz w jakim celu masz te repozytoria.
Używać obcych repozytoriów można, ale trzeba to robić rozważnie (np. używać piningu)

Awatar użytkownika
korbielow
Beginner
Posty: 325
Rejestracja: 29 marca 2014, 20:37

Re: Problem z zależnościami

Post autor: korbielow » 19 grudnia 2017, 15:31

Kod: Zaznacz cały

root@debian:/home/rafal# apt-cache firefox
E: Nieprawidłowa operacja firefox
To jak zrobić porządek i powywalac te repo z minta i ubuntu ?

Awatar użytkownika
dedito
Moderator
Posty: 2971
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z zależnościami

Post autor: dedito » 19 grudnia 2017, 16:08

Sory, pomyłka

Kod: Zaznacz cały

apt-cache policy firefox
w sumie jakbyś chwilę pomyślał to sam byś wpadł na to gdzie był błąd w powyższym.
Porządek zrobić to swoją drogą, ale przeczytaj jeszcze raz ze zrozumieniem o czym pisałem.

Awatar użytkownika
korbielow
Beginner
Posty: 325
Rejestracja: 29 marca 2014, 20:37

Re: Problem z zależnościami

Post autor: korbielow » 19 grudnia 2017, 16:37

Kod: Zaznacz cały

oot@debian:/home/rafal# apt-cache policy firefox
firefox:
  Zainstalowana: (brak)
  Kandydująca:   (brak)
  Tabela wersji:

Nie rozumiem dlaczego jak mam w source.list tylko stretch dalej są problemy z tymi zależnościami. Jezeli chodziło ci o ptanie zwiazane z tymi repo to nie są one mi obecnie potrzebne /mint i ubuntu/.

Kod: Zaznacz cały

deb http://ftp.pl.debian.org/debian/ stretch main non-free contrib
deb-src http://ftp.pl.debian.org/debian/ stretch main non-free contrib

deb http://security.debian.org/debian-security stretch/updates main contrib non$
deb-src http://security.debian.org/debian-security stretch/updates main contrib$

# stretch-updates, previously known as 'volatile'
deb http://ftp.pl.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.pl.debian.org/debian/ stretch-updates main contrib non-free

Jest jakaś możliwość uporządkowania tego bałaganu ?

Awatar użytkownika
dedito
Moderator
Posty: 2971
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z zależnościami

Post autor: dedito » 19 grudnia 2017, 18:03

Problemy z zależnościami mogą być dalej ze względu na to, że masz już pomieszane paczki z różnych dystrybucji.
A te problemy z zależnościami musisz każdorazowo pokazywać.

Awatar użytkownika
korbielow
Beginner
Posty: 325
Rejestracja: 29 marca 2014, 20:37

Re: Problem z zależnościami

Post autor: korbielow » 19 grudnia 2017, 18:11

Czyli chyba najprostszym wyjsciem bedzie zainstalowac na nowo system ?

Awatar użytkownika
dedito
Moderator
Posty: 2971
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z zależnościami

Post autor: dedito » 19 grudnia 2017, 18:18

Niekoniecznie, można spróbować to co radził apt jeśli dalej tak radzi.
Ale przede wszystkim musisz podawać więcej informacji bo ja tu nie mam szklanej kuli.

Zablokowany