[+] Błąd ustawienia partycji.

Tematy związane z oprogramowaniem, instalacją, konfiguracją
ww71
Beginner
Posty: 338
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

[+] Błąd ustawienia partycji.

Post autor: ww71 » 04 października 2017, 18:44

Witam,
Mam nowego laptopa i mam tak ustawione partycje, że pojawia się komunikat:

Kod: Zaznacz cały

root@debian:/home/ww# fdisk -l
Dysk /dev/sda: 298,1 GiB, bajtów: 320072933376, sektorów: 625142448
Jednostki: sektorów, czyli 1 * 512 = 512 bajtów
Rozmiar sektora (logiczny/fizyczny) w bajtach: 512 / 4096
Rozmiar we/wy (minimalny/optymalny) w bajtach: 4096 / 4096
Typ etykiety dysku: dos
Identyfikator dysku: 0x577cdd7d

Urządzenie Rozruch  Początek    Koniec   Sektory Rozmiar Id Typ
/dev/sda1  *              63    208844    208782    102M  7 HPFS/NTFS/exFAT
/dev/sda2             208845 207688319 207479475     99G  7 HPFS/NTFS/exFAT
/dev/sda3          207689326 625137344 417448019  199,1G  f W95 Rozsz. (LBA)
/dev/sda5          207691776 280328191  72636416   34,7G  b W95 FAT32
/dev/sda6          280330240 327913471  47583232   22,7G 83 Linux
/dev/sda7          327915520 371312639  43397120   20,7G 83 Linux
/dev/sda8          371314688 373411839   2097152      1G 82 Linux swap / Solaris
/dev/sda9          373413888 625135615 251721728    120G 83 Linux
Partycja 1 nie zaczyna się na granicy sektora fizycznego.
Partycja 2 nie zaczyna się na granicy sektora fizycznego.
Partycja 3 nie zaczyna się na granicy sektora fizycznego.
Ustawienia są trochę wymuszone, bo nie chciałem kasować oryginalnego systemu, bo laptop ma gwarancję. Pytanie, czy takie błędy mogą powodować zawieszanie się systemu, bo już 2 razy mi sie przydarzyło w ciągu jednego dnia?
Będę wdzięczny za odpowiedź.
Pozdrawiam.
Ostatnio zmieniony 15 października 2017, 18:07 przez ww71, łącznie zmieniany 1 raz.

Awatar użytkownika
dedito
Moderator
Posty: 2141
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Błąd ustawienia partycji.

Post autor: dedito » 04 października 2017, 18:59

U mnie jest tak:

Kod: Zaznacz cały

fdisk -l
Dysk /dev/sdb: 2,7 TiB, bajtów: 3000592982016, sektorów: 5860533168
Jednostki: sektorów, czyli 1 * 512 = 512 bajtów
Rozmiar sektora (logiczny/fizyczny) w bajtach: 512 / 4096
Rozmiar we/wy (minimalny/optymalny) w bajtach: 4096 / 4096
Typ etykiety dysku: gpt
Identyfikator dysku: 19C6AC48-B1E8-4442-9F76-B8D7D9EF942A

Urządzenie Początek     Koniec    Sektory Rozmiar Typ
/dev/sdb1        34     262177     262144    128M Microsoft - zarezerwowana
/dev/sdb2    264192 5860532223 5860268032    2,7T Microsoft - dane podstawowe

Partycja 1 nie zaczyna się na granicy sektora fizycznego.
I nie ma problemów z tym związanych.
Ale dla porządku załóż sobie partycje z wyrównaniem do MB.

ww71
Beginner
Posty: 338
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: Błąd ustawienia partycji.

Post autor: ww71 » 04 października 2017, 19:07

Ok. dzięki. Czyli przyczyna inna zawieszenia się systemu.

Awatar użytkownika
dedito
Moderator
Posty: 2141
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Błąd ustawienia partycji.

Post autor: dedito » 04 października 2017, 19:11

Przyczyny szukaj w logach.

ww71
Beginner
Posty: 338
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: Błąd ustawienia partycji.

Post autor: ww71 » 04 października 2017, 19:25

Czy chodzi o logi w katalogu:
/var/log ?
Przepraszam ale nigdy tego nie robiłem. Jak bym jeszcze mógł prosić Kolegów o wskazanie w którym pliku szukać błędów w logach. Na początek za wiele to mi nie da, ale coś poczytam w necie.

Awatar użytkownika
dedito
Moderator
Posty: 2141
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Błąd ustawienia partycji.

Post autor: dedito » 04 października 2017, 19:27

/var/log/messages

ww71
Beginner
Posty: 338
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: Błąd ustawienia partycji.

Post autor: ww71 » 04 października 2017, 19:30

Ok. Dzięki.

Awatar użytkownika
dedito
Moderator
Posty: 2141
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Błąd ustawienia partycji.

Post autor: dedito » 04 października 2017, 19:32

Tu jeszcze trochę stare ale wciąż aktualne
https://debian-administration.org/artic ... em_freezes

Ja kiedyś miałem taki przypadek, że logi nic nie pomagały.
Ostatecznie znalazłem przyczynę sprzętową, zbyt niskie napięcie zasilania RAM.

ww71
Beginner
Posty: 338
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: Błąd ustawienia partycji.

Post autor: ww71 » 04 października 2017, 19:37

Ok. dzięki. Ale ja tylko po polsku :) , więc się nie przyda poradnik.
Laptop jest używany, ma swoje lata zapewne, ale powinien chodzić, zobaczymy co będzie.

Awatar użytkownika
dedito
Moderator
Posty: 2141
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Błąd ustawienia partycji.

Post autor: dedito » 04 października 2017, 19:50

Google translator, wrzucasz stronę i masz jako takie tłumaczenie.
Nawet znośnie:
https://translate.google.pl/translate?s ... t=&act=url

Zablokowany