[+] Stretch brak pliku rc.local w /etc

Tematy związane z oprogramowaniem, instalacją, konfiguracją
ww71
Beginner
Posty: 331
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

[+] Stretch brak pliku rc.local w /etc

Post autor: ww71 » 16 kwietnia 2017, 22:23

Witam,
Jak zauważyłem, nie mam pliku w Stretch:

Kod: Zaznacz cały

rc.local
w kataologu /etc .
Sam go utworzyłem wpisując prosty firewall zaproponowany przez Yampresa:

Kod: Zaznacz cały

 echo "Starting firewall"

 iptables -F

 iptables -P INPUT DROP
 iptables -P FORWARD DROP
 iptables -P OUTPUT ACCEPT

 iptables -A INPUT -i lo -j ACCEPT
 iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
Jednak nie uruchamia się przy starcie systemu, nie ma komentarza. Ciekawe bo na innym kompie jest ten plik w Stretch. Czy jest sens więc utworzyć samemu ten plik?
Pozdrawiam.
Ostatnio zmieniony 17 kwietnia 2017, 14:11 przez ww71, łącznie zmieniany 1 raz.

Awatar użytkownika
dedito
Moderator
Posty: 2102
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Stretch brak pliku rc.local w /etc

Post autor: dedito » 16 kwietnia 2017, 23:20

Ten plik jest wywoływany z /etc/init.d/rc.local
Dodatkowo ten Twój plik powinien mieć raczej atrybut wykonywalności.
Standardowo ten plik zaczyna się od:

Kod: Zaznacz cały

#!/bin/sh -e
co wskazuje na interpreter, którego system ma użyć do wykonania skryptu.

ww71
Beginner
Posty: 331
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: Stretch brak pliku rc.local w /etc

Post autor: ww71 » 16 kwietnia 2017, 23:25

Tak jest. Plik tak cały wygląda:

Kod: Zaznacz cały

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

 echo "Starting firewall"

 iptables -F

 iptables -P INPUT DROP
 iptables -P FORWARD DROP
 iptables -P OUTPUT ACCEPT

 iptables -A INPUT -i lo -j ACCEPT
 iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT

exit 0

Awatar użytkownika
dedito
Moderator
Posty: 2102
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Stretch brak pliku rc.local w /etc

Post autor: dedito » 16 kwietnia 2017, 23:30

To sprawdź zawartość /etc/init.d/rc.local pod kątem linii w stylu

Kod: Zaznacz cały

if [ -x /etc/rc.local ] then ...

ww71
Beginner
Posty: 331
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: Stretch brak pliku rc.local w /etc

Post autor: ww71 » 16 kwietnia 2017, 23:32

To już za duże progi dla mnie :), musiałby Kolega mnie tu dokładnie "za rączkę" przeprowadzić, niestety.

Awatar użytkownika
dedito
Moderator
Posty: 2102
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Stretch brak pliku rc.local w /etc

Post autor: dedito » 16 kwietnia 2017, 23:34

Nie rozumiem ... przecież wystarczy otworzyć ten plik w dowolnym edytorze lub użyć cat.
No i warto też sprawdzić czy skrypt się uruchamia zwyczajnie "z palca".

ww71
Beginner
Posty: 331
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: Stretch brak pliku rc.local w /etc

Post autor: ww71 » 16 kwietnia 2017, 23:37

Nie mam w tamtym katalogu: /etc/init.d/ pliku: rc.local

Awatar użytkownika
dedito
Moderator
Posty: 2102
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Stretch brak pliku rc.local w /etc

Post autor: dedito » 16 kwietnia 2017, 23:50

To sprawdź jeszcze

Kod: Zaznacz cały

systemctl list-units | grep rc-local
lub skorzystaj z innej metody np. iptables-persistent opisanej pod linkiem -> https://wiki.debian.org/iptables

ww71
Beginner
Posty: 331
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: Stretch brak pliku rc.local w /etc

Post autor: ww71 » 16 kwietnia 2017, 23:53

Po tej komendzie:

Kod: Zaznacz cały

systemctl list-units | grep rc-local
nic się nie dzieje, żadnych wyników.

Awatar użytkownika
dedito
Moderator
Posty: 2102
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Stretch brak pliku rc.local w /etc

Post autor: dedito » 16 kwietnia 2017, 23:57

Kod: Zaznacz cały

systemctl enable rc-local

Zablokowany