Kompilacja kadu 6.5.4 ze źróde

Tematy związane z oprogramowaniem, instalacją, konfiguracją
optimus_prime
Posty: 5
Rejestracja: 11 lutego 2010, 20:23

Kompilacja kadu 6.5.4 ze źródeł

Post autor: optimus_prime » 12 lutego 2010, 18:37

Witam.
Mam problem z instalacją najnowszej wersji Kadu. W repozytoriach wersji stabilnej znajduje się tylko wersja 0.6.0.3. Ze strony kadu pobrałem źródła, jednak podczas kompilacji wyskakują błędy. Z częścią już sobie poradziłem, jednak są kolejne. Oto log kompilacji:

Kod: Zaznacz cały

-- Subversion was not found.
-- Installation Paths:
-- Data:    /usr/share
-- Library: /usr/lib
-- Binary:  /usr/bin
-- checking for one of the modules 'libgadu>=1.9.0'
CMake Error at /usr/share/cmake-2.6/Modules/FindPkgConfig.cmake:350 (message):
  None of the required 'libgadu>=1.9.0' found
Call Stack (most recent call first):
  CMakeLists.txt:137 (pkg_search_module)


grep: /libgadu.h: No such file or directory
-- Static module: docking
-- Static module: qt4_docking
-- Dynamic module: account_management
-- Dynamic module: advanced_userlist
-- Dynamic module: alsa_sound
-- checking for one of the modules 'alsa'
CMake Error at /usr/share/cmake-2.6/Modules/FindPkgConfig.cmake:350 (message):
  None of the required 'alsa' found
Call Stack (most recent call first):
  modules/alsa_sound/CMakeLists.txt:32 (pkg_search_module)


-- Dynamic module: amarok1_mediaplayer
-- Dynamic module: audacious_mediaplayer
-- Dynamic module: autoaway
-- Dynamic module: autoresponder
-- Dynamic module: autostatus
-- Dynamic module: config_wizard
-- Dynamic module: dbus
-- Dynamic module: dcc
-- Dynamic module: default_sms
-- Dynamic module: dsp_sound
-- Dynamic module: encryption
-- checking for one of the modules 'qca2'
CMake Error at /usr/share/cmake-2.6/Modules/FindPkgConfig.cmake:350 (message):
  None of the required 'qca2' found
Call Stack (most recent call first):
  modules/encryption/CMakeLists.txt:49 (pkg_search_module)


-- Dynamic module: hints
-- Dynamic module: history
-- Dynamic module: idle
CMake Error at modules/idle/CMakeLists.txt:6 (MESSAGE):
  Could not find X11 Screen Saver extension


-- Configuring done
Instalacja nie powiod�a si� (na etapie cmake ..)
Jeśli ktoś wie co trzeba z tym zrobić, byłbym wdzięczny z pomoc.

Awatar użytkownika
shevchenko1987
Beginner
Posty: 306
Rejestracja: 23 listopada 2008, 17:00
Lokalizacja: Warta

Post autor: shevchenko1987 » 12 lutego 2010, 23:24

Sądzę że nie uda Ci się zainstalować tej wersji na Lennym. Za stare wersje pakietów.

Awatar użytkownika
ilin
Senior Member
Posty: 2292
Rejestracja: 26 sierpnia 2007, 11:54
Lokalizacja: PRLu

Post autor: ilin » 13 lutego 2010, 10:50

Na lennym da się zainstalować kadu z experimental.

Awatar użytkownika
shevchenko1987
Beginner
Posty: 306
Rejestracja: 23 listopada 2008, 17:00
Lokalizacja: Warta

Post autor: shevchenko1987 » 13 lutego 2010, 11:06

A nie będzie chciało zaktualizować mu pół systemu? ;-)

Awatar użytkownika
ilin
Senior Member
Posty: 2292
Rejestracja: 26 sierpnia 2007, 11:54
Lokalizacja: PRLu

Post autor: ilin » 13 lutego 2010, 11:09

Sprawdź :)

Nie jest tak źle.

Awatar użytkownika
shevchenko1987
Beginner
Posty: 306
Rejestracja: 23 listopada 2008, 17:00
Lokalizacja: Warta

Post autor: shevchenko1987 » 13 lutego 2010, 11:12

optimus_prime, zainstaluj te pakiety:

Kod: Zaznacz cały

libgadu-dev
libsndfile1-dev
libqca2
libqca2-dev
I daj znać czy poszło dalej ;-) Albo skorzystaj z rady kolegi ilin.

Awatar użytkownika
Yampress
Administrator
Posty: 6249
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Post autor: Yampress » 13 lutego 2010, 11:20

ja pobrałem pakiety żródłowe z experimentall(kadu rc1,2 i libgadu/ libgad-dev ) i skompilowałem sobie pod lennym i spokojnie chodzi. Także z pełną wersją stable też nie powinno być problemów. Trzeba tylko zobaczyć czy paczi żródłowe są tej wersji kadu

Awatar użytkownika
ilin
Senior Member
Posty: 2292
Rejestracja: 26 sierpnia 2007, 11:54
Lokalizacja: PRLu

Post autor: ilin » 13 lutego 2010, 11:23

Mała poprawka.

Ta wersja kadu jest już w unstable.
W experimental juz nie ma.
Poszła w dół. :)

Awatar użytkownika
davidoski
Beginner
Posty: 234
Rejestracja: 17 kwietnia 2007, 10:53
Lokalizacja: Poznań

Post autor: davidoski » 13 lutego 2010, 11:28

Ja niedawno instalowałem na Lennym Kadu ze źródeł w najnowszej wersji i poszło.
Ale najpierw trzeba było poinstalować te pakiety o których pisał shevchenko1987 plus jeszcze pakiety

Kod: Zaznacz cały

libgadu3, libasound-dev, libxss-dev, x11-dev, pkg-config, libqt4-dev

Sokon
Posty: 47
Rejestracja: 09 czerwca 2008, 09:50

Post autor: Sokon » 04 marca 2010, 11:21

Mam zainstalowanego Debiana 5.0.4 i wczoraj instalowałem KADU.

Dopisałem do /etc/apt/sources.list:

Kod: Zaznacz cały

#~~~~~~Squeeze~~~~~~#
deb [url]http://ftp.pl.debian.org/debian/[/url] squeeze main non-free contrib
deb-src [url]http://ftp.pl.debian.org/debian/[/url] squeeze main non-free contrib
deb [url]http://security.debian.org/[/url] squeeze/updates main contrib non-free
deb-src [url]http://security.debian.org/[/url] squeeze/updates main contrib non-free
Znalezione tutaj: http://debian.linux.pl/viewtopic.php?t=1515.

Następnie:

Kod: Zaznacz cały

aptitude update
aptitude install kadu
W czasie instalacji zapytał się mnie o to co zrobić z jakimiś pakietami, nie pamiętam dokładnie jakimi, ale klikałem "N" co oznaczało zostawienie ich w spokoju.

Po instalacji zakomentowałem zmiany w pliku /etc/apt/sources.list znaczkiem #

Kod: Zaznacz cały

#~~~~~~Squeeze~~~~~~#
#deb [url]http://ftp.pl.debian.org/debian/[/url] squeeze main non-free contrib
#deb-src [url]http://ftp.pl.debian.org/debian/[/url] squeeze main non-free contrib
#deb [url]http://security.debian.org/[/url] squeeze/updates main contrib non-free
#deb-src [url]http://security.debian.org/[/url] squeeze/updates main contrib non-free
Kadu działa, nie wiem jeszcze jak będzie działać po najbliższej aktualizacji systemu ale jestem pełen nadziei, że będzie.

ODPOWIEDZ