Skype na j

Archiwalne, stare wpisy FAQ i HowTo Użytkowników
m4yer
Posty: 57
Rejestracja: 23 kwietnia 2007, 17:27

Skype na jądrach amd64

Post autor: m4yer » 11 listopada 2007, 21:11

Chcialbym napisac jak udalo mi sie odpalić
Skype (beta) na Linuxie jadrem 2.6.22-2-amd64

A więc do dzieła :)

instalacja pakietów:

Kod: Zaznacz cały

apt-get install lib32asound2 
apt-get install ia32-libs
apt-get install ia32-libs-gtk
apt-get install libsigc++-2.0-0c2a
apt-get install libxss1
Sciagamy pliczki
skype --> http://www.skype.com/go/getskype-linux-deb
libxss1 --> http://ftp.cz.debian.org/debian/pool/ma ... 1_i386.deb

Przenosimy pliczki z katalogu:
/usr/lib/libXss.so
/usr/lib/libXss.so.1
/usr/lib/libXss.so.1.0.0
do katalogu:
/lib/ lub /lib64/

pozniej instalujemy sciagniety pliczek:

Kod: Zaznacz cały

dpkg -i --force-architecture libxss1_1.1.0-1_i386.deb
Przenosimy pliczki z katalogu:
/usr/lib/libXss.so
/usr/lib/libXss.so.1.0.0
do katalogu:
/lib32

Przypominam o przenoszeniu plikow a nie kopiowaniu.

pozostaje nam zainstalowac skype a wiec:

Kod: Zaznacz cały

dpkg -i --force-architecture skype-debian_2.0.0.13-1_i386.deb
i cieszyc sie dzialajacym Skype :)

Mogą ale nie muszą być jakieś niespotkane błędy
w razie jakiś błędów pisać tu a postaram sie pomóc

pozdrawiam.
m4yer

Poprawki:
Poprawa nazwy pakietu do zainstalowania z ia32-libs-kde na ia32-libs-gtk

newuser
Posty: 4
Rejestracja: 27 listopada 2007, 13:49

Post autor: newuser » 27 listopada 2007, 22:47

Dzięki
bez tego miałem ciągle problemy z libXss.so.1
np przy skypie komunikat

Kod: Zaznacz cały

./skype: /lib32/libc.so.6: version `GLIBC_2.4' not found (required by /usr/lib3 2/libQtCore.so.4)
No match found for package libXss.so.1
No libraries to download.
po opisane sztuczce
już tylko

Kod: Zaznacz cały

./skype: /lib32/libc.so.6: version `GLIBC_2.4' not found (required by /usr/lib32/libQtCore.so.4)
This application isn't missing any dependencies
ale niestety ciągle nie działa

Wiem google - ale szukam, szukam, szukam...
plik /lib32/libc.so.6 to dowiązanie do /lib32/libc-2.3.6.so
Czyżby nie było nowej wersji tej paczki dla mojej wersji ???
kernel 2.6.18-5-amd64
Debian etch x64
Help !!!

[ Dodano: 2007-12-06, 22:12 ]
Hmmm.

Jestem już po małych testach.
Zmiana Etcha na Sid-a pomogła jeżeli można tak powiedzieć. Na razie ok.

Nailvegher
Posty: 43
Rejestracja: 15 lipca 2007, 07:09
Lokalizacja: Go³dap

Post autor: Nailvegher » 25 grudnia 2007, 10:28

Kod: Zaznacz cały

./skype: /lib32/libc.so.6: version `GLIBC_2.4' not found (required by /usr/lib32/libQtCore.so.4)
This application isn't missing any dependencies 
Pomogła, pomogła, ponieważ komunikat mówił, że nie znalazł wersji 2.4 biblioteki GLIBC. Do Sida nie musiałeś aktualizawać, ponieważ wystarczyło by do Lenniego. Etch jest przeznaczony dla komputerów maksymalnie stabilnych, tj. serwerów itd.

psv
Beginner
Posty: 234
Rejestracja: 08 maja 2007, 13:42

Post autor: psv » 18 stycznia 2008, 20:37

Jest jeszcze prostszy sposób. Po zainstalowaniu ia32-libs i wszystkich zależności trzeba pobrać pakiet libxss1_1.1.0-1_i386.deb (wersja może się różnić). Jako root poprzez mc "wchodzimy" do tego pakietu jak do katalogu. Wchodzimy do

Kod: Zaznacz cały

CONTENTS/usr/lib
i kopiujemu dwa pliki (są tylko te dwa, więc nie trzeba się martwić, które) z tego miejsca do katalogu z bibliotekami systemowymi lib32, czyli tu:

Kod: Zaznacz cały

/lib32
. Potem normalnie można uruchomić skype.

Overeating
Posty: 1
Rejestracja: 08 stycznia 2015, 09:26

Post autor: Overeating » 08 stycznia 2015, 09:28

enjoy running Skype but can not be any niespotkane errors C4060-155 dump - testking.me in the event of an error message here and I will try to help greet. m4yer

ODPOWIEDZ