[Debian 64 bit] Najnowszy Wine ze źróde

Archiwalne, stare wpisy FAQ i HowTo Użytkowników
Awatar użytkownika
neo86
Beginner
Posty: 285
Rejestracja: 16 października 2013, 00:03
Lokalizacja: Opolskie

Post autor: neo86 » 02 września 2014, 18:40

Ja nie wiem nie znam się zbytnio na programowaniu w linuksie (jedynie od biedy pamiętam coś z Turbo Pascala, Delphi i zwykłego HTML). Mi się to

Kod: Zaznacz cały

winealsa.drv.so
samo wtrąbiło w systemie ale czy z paczką DEB którą wyplułem w Debianie czy to gdzieś mi siedzi w systemie z pakietem

Kod: Zaznacz cały

libasound2-dev
tego nie wiem. Tu też bym prosił o wszelkie wyjaśnienia osoby bardziej kumate w temacie. :D

us3r.deb
Posty: 10
Rejestracja: 06 stycznia 2015, 18:35

Post autor: us3r.deb » 08 stycznia 2015, 18:51

Wszystko robię wedle instrukcji, ale tylko w jednym miejscu coś nie tak było, przy instalacji ia32-libs wyświetla mi się taki kominukat:

Kod: Zaznacz cały

Package ia32-libs is not available, but is referred to by another package.This may mean that the package is missing, has been obsoleted, oris only available from another sourceHowever the following packages replace it:  lib32z1 lib32ncurses5E: Package 'ia32-libs' has no installation candidate
Jeśli dobrze zrozumiałem to pakiety lib32z1 i lib32ncurses5 zastąpią ten pakiet tak ? Bo tego ia32-libs nie udało mi się zainstalować więc zainstalowałem tylko te dwa.

Awatar użytkownika
neo86
Beginner
Posty: 285
Rejestracja: 16 października 2013, 00:03
Lokalizacja: Opolskie

Post autor: neo86 » 09 stycznia 2015, 14:05

W tym akurat przepisie powinien być pełny pakiet ia32-libs by móc kompilować wine. Bez niego będą takie błędy powstawały.

us3r.deb
Posty: 10
Rejestracja: 06 stycznia 2015, 18:35

Post autor: us3r.deb » 14 stycznia 2015, 15:17

Ale co mam zrobić jeśli nie mogę zainstalować wgl ia32-libs ?najpierw chcę zainstalować to co podałeś:

Kod: Zaznacz cały

apt-get install xserver-xorg-dev:i386 libfreetype6-dev:i386 libxcursor-dev:i386 libxi-dev:i386 libxxf86vm-dev:i386 libxrandr-dev:i386 libxinerama-dev:i386 libxcomposite-dev:i386 libglu1-mesa-dev:i386 libdbus-1-dev:i386 libgnutls-dev:i386 libncurses5-dev:i386 libsane-dev:i386 libhal-dev:i386 liblcms2-dev:i386 libcapi20-dev:i386 libcups2-dev:i386 libopenal-dev:i386 libfontconfig1-dev:i386 libmpg123-dev:i386 libgsm1-dev:i386 libldap2-dev:i386 prelink libxslt1-dev:i386 libpng12-dev:i386 libosmesa6-dev:i386 libglu1-mesa-dev:i386 libfontconfig1-dev:i386 oss4-dev
i wywala mi:

Kod: Zaznacz cały

 Czytanie list pakietów... GotoweBudowanie drzewa zależności       Odczyt informacji o stanie... GotowePackage libgnutls-dev:i386 is not available, but is referred to by another package.This may mean that the package is missing, has been obsoleted, oris only available from another sourceE: Package 'libgnutls-dev:i386' has no installation candidateE: Nie udało się odnaleźć pakietu libhal-dev
A potem gdy chcę zainstalować*te 32libsy itd komendą:

Kod: Zaznacz cały

apt-get install ia32-libs gcc-multilib
otrzymuję:

Kod: Zaznacz cały

Czytanie list pakietów... GotoweBudowanie drzewa zależności       Odczyt informacji o stanie... GotowePackage ia32-libs is not available, but is referred to by another package.This may mean that the package is missing, has been obsoleted, oris only available from another sourceHowever the following packages replace it:  lib32z1 lib32ncurses5E: Package 'ia32-libs' has no installation candidate
Co z tym wszystkim zrobić ?

Awatar użytkownika
neo86
Beginner
Posty: 285
Rejestracja: 16 października 2013, 00:03
Lokalizacja: Opolskie

Post autor: neo86 » 14 stycznia 2015, 19:44

Nie wiem jakąś kaszanę w systemie masz... :/ ja nigdy takich problemów nie miałem z kompilacją Wine.

us3r.deb
Posty: 10
Rejestracja: 06 stycznia 2015, 18:35

Post autor: us3r.deb » 15 stycznia 2015, 11:33

jaki zkaszaniony ? dopiero co zainstalowany debian jessie, dopiero co, i nie ma tych pakietów...

Awatar użytkownika
Yampress
Administrator
Posty: 6025
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Post autor: Yampress » 15 stycznia 2015, 16:31

Jaka wersja debiana? Kompilacje wg tego przepisu robisz to na stable czy na testingu/jessie?

Awatar użytkownika
neo86
Beginner
Posty: 285
Rejestracja: 16 października 2013, 00:03
Lokalizacja: Opolskie

Post autor: neo86 » 15 stycznia 2015, 18:35

Yampressie Drogi to dzała na wszystkich Debianach. Sprawdzałem na live Jessie oraz na zainstalowanym na dysku u siebie Sidzie i na zainstalowanym u mamy Wheezy.

Awatar użytkownika
Yampress
Administrator
Posty: 6025
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Post autor: Yampress » 15 stycznia 2015, 19:08

A pomyślałeś o innych wersjach zależności gdzie coś może pójść nie tak? Mówie o jessie. Może dana paczka zniknęła w jessie albo coś...

Awatar użytkownika
neo86
Beginner
Posty: 285
Rejestracja: 16 października 2013, 00:03
Lokalizacja: Opolskie

Post autor: neo86 » 15 stycznia 2015, 20:36

Wiesz nie mam magicznej kuli by zgadywać co w każdej dystrybucji znika ale jeszcze miesiąc temu na Jessiem działało jak sprawdzałem na live.

ODPOWIEDZ