Klawiatura bluetooth laczy sie ale nie dziala

Wszystko związane z jądrem systemowym, sterownikami, sprzętem itp.
kamil_gda
Posty: 5
Rejestracja: 01 września 2016, 12:10

Klawiatura bluetooth laczy sie ale nie dziala

Post autor: kamil_gda » 19 maja 2017, 10:41

Witam,

Posiadam klawiature gembird KB-BT-001 oraz adapter bluetooth: Adapter USB Bluetooth 4.0 CSR8510. Problem polega na tym, ze adapter wykrywa oraz laczy sie z klawiatura, hcidump przechwytuje zdarzenia, ale klawiatura w dalszym ciagu nie dziala jako klawiatura. Co mozna zauwazyc, to ze nie tworzone sa urzadzenia /dev/hidraw* oraz /dev/input*. Ponizej log z wersji systemu oraz jadra oraz wykonywanych operacji:

Kod: Zaznacz cały

 cat /etc/debian_version 
7.11

uname -a 
Linux ED4012 3.1.10-ge8678dd-dirty #8 SMP PREEMPT Wed May 17 11:00:22 CEST 2017 armv7l GNU/Linux

lsusb, lsusb -t

Kod: Zaznacz cały

Bus 001 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
       |__ Port 3: Dev 4, If 0, Class='bInterfaceClass 0xe0 not yet handled', Driver=btusb, 12M
        |__ Port 3: Dev 4, If 1, Class='bInterfaceClass 0xe0 not yet handled', Driver=btusb, 12M
udevadm monitor po wykonaniu polecenia hidd --search lub bluez-test-input connect adres_urzadzenia

Kod: Zaznacz cały

KERNEL[1594.819112] add      /devices/platform/tegra-ehci.1/usb1/1-1/1-1.3/1-1.3:1.0/bluetooth/hci0/hci0:71 (bluetooth)
ACTION=add
DEVPATH=/devices/platform/tegra-ehci.1/usb1/1-1/1-1.3/1-1.3:1.0/bluetooth/hci0/hci0:71
DEVTYPE=link
SEQNUM=1439
SUBSYSTEM=bluetooth
UDEV_LOG=3

UDEV  [1594.829708] add      /devices/platform/tegra-ehci.1/usb1/1-1/1-1.3/1-1.3:1.0/bluetooth/hci0/hci0:71 (bluetooth)
ACTION=add
DEVPATH=/devices/platform/tegra-ehci.1/usb1/1-1/1-1.3/1-1.3:1.0/bluetooth/hci0/hci0:71
DEVTYPE=link
SEQNUM=1439
SUBSYSTEM=bluetooth
UDEV_LOG=3
USEC_INITIALIZED=1594822032

KERNEL[1595.139271] add      /devices/platform/tegra-ehci.1/usb1/1-1/1-1.3/1-1.3:1.0/bluetooth/hci0/hci0:71/0005:05AC:0239.0003 (hid)
ACTION=add
DEVPATH=/devices/platform/tegra-ehci.1/usb1/1-1/1-1.3/1-1.3:1.0/bluetooth/hci0/hci0:71/0005:05AC:0239.0003
HID_ID=0005:000005AC:00000239
HID_NAME=Brcom Wireless Keyboard
HID_PHYS=00:1A:7D:DA:71:13
HID_UNIQ=09:30:DE:3B:1A:68
MODALIAS=hid:b0005v000005ACp00000239
SEQNUM=1440
SUBSYSTEM=hid
UDEV_LOG=3

UDEV  [1595.153637] add      /devices/platform/tegra-ehci.1/usb1/1-1/1-1.3/1-1.3:1.0/bluetooth/hci0/hci0:71/0005:05AC:0239.0003 (hid)
ACTION=add
DEVPATH=/devices/platform/tegra-ehci.1/usb1/1-1/1-1.3/1-1.3:1.0/bluetooth/hci0/hci0:71/0005:05AC:0239.0003
HID_ID=0005:000005AC:00000239
HID_NAME=Brcom Wireless Keyboard
HID_PHYS=00:1A:7D:DA:71:13
HID_UNIQ=09:30:DE:3B:1A:68
MODALIAS=hid:b0005v000005ACp00000239
SEQNUM=1440
SUBSYSTEM=hid
UDEV_LOG=3
USEC_INITIALIZED=1595142908

proba przelaczenia urzadzenia w tryb hid

Kod: Zaznacz cały

/lib/udev/hid2hci --method logitech-hid --devpath=/devices/platform/tegra-ehci.1/usb1/1-1/1-1.3/1-1.3:1.0/bluetooth/hci0/hci0:71 --mode hid
error: could not find hiddev device node

t@ED4012:/home/term# /lib/udev/hid2hci --method logitech-hid --devpath=/devices/platform/tegra-ehci.1/usb1/1-1/1-1.3/1-1.3:1.0/bluetooth/hci0/hci0:71/0005:05AC:0239.0004 --mode hid
error: could not find hiddev device node

log z hcidump po nacisnieciu q

Kod: Zaznacz cały

hcidump
HCI sniffer - Bluetooth packet analyzer ver 2.4
device: hci0 snap_len: 1028 filter: 0xffffffff
> HCI Event: Mode Change (0x14) plen 6
    status 0x00 handle 71 mode 0x00 interval 0
    Mode: Active
> ACL data: handle 71 flags 0x02 dlen 14
    L2CAP(d): cid 0x0041 len 10 [psm 0]
> HCI Event: Mode Change (0x14) plen 6
    status 0x00 handle 71 mode 0x02 interval 18
    Mode: Sniff
> ACL data: handle 71 flags 0x02 dlen 14
    L2CAP(d): cid 0x0041 len 10 [psm 0]
> HCI Event: Mode Change (0x14) plen 6
    status 0x00 handle 71 mode 0x00 interval 0
    Mode: Active
> HCI Event: Mode Change (0x14) plen 6
    status 0x00 handle 71 mode 0x02 interval 36
    Mode: Sniff

konfiguracja /etc/default/bluetooth

Kod: Zaznacz cały

HIDD_ENABLED=1
#HID2HCI_ENABLED=1
HID2HCI_UNDO=0

Odpowiedz

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość