[+]spotify niespełnione zależnosci

Tematy związane z oprogramowaniem, instalacją, konfiguracją
pawelk29
Posty: 79
Rejestracja: 29 lutego 2016, 12:51

[+]spotify niespełnione zależnosci

Post autor: pawelk29 » 09 sierpnia 2017, 19:11

Instaluje spotify:

Kod: Zaznacz cały

 root@pk28-host:/home/pk28# apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 BBEBDCB318AD50EC6865090613B00F1FD2C19886
Executing: /tmp/apt-key-gpghome.DwX49kVAqx/gpg.1.sh --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 BBEBDCB318AD50EC6865090613B00F1FD2C19886
gpg: key 13B00F1FD2C19886: public key "Spotify Public Repository Signing Key <operations@spotify.com>" imported
gpg: Total number processed: 1
gpg:               imported: 1
root@pk28-host:/home/pk28# echo deb http://repository.spotify.com stable non-free | sudo tee /etc/apt/sources.list.d/spotify.list
deb http://repository.spotify.com stable non-free
root@pk28-host:/home/pk28# sudo apt-get update
Ign:1 http://ftp.pl.debian.org/debian stretch InRelease
Stary:2 http://ftp.pl.debian.org/debian stretch-updates InRelease              
Stary:3 http://ftp.pl.debian.org/debian stretch Release                        
Ign:5 http://deb.debian.org/debian stretch InRelease                           
Stary:6 http://deb.debian.org/debian stretch Release                           
Pobieranie:8 http://repository.spotify.com stable InRelease [3302 B]           
Stary:9 http://security.debian.org/debian-security stretch/updates InRelease
Pobieranie:10 http://repository.spotify.com stable/non-free amd64 Packages [1588 B]
Pobrano 4890 B w 1s (3654 B/s)      
Czytanie list pakietów... Gotowe
root@pk28-host:/home/pk28# apt-get install spotify-client
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 spotify-client : Wymaga: libssl1.0.0 ale nie da się go zainstalować
                  Poleca: libavcodec54 ale nie da się go zainstalować lub
                          libavcodec-extra-54 ale nie da się go zainstalować
                  Poleca: libavformat54 ale nie da się go zainstalować
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
i nie wiem co zrobić
Ostatnio zmieniony 10 sierpnia 2017, 05:38 przez pawelk29, łącznie zmieniany 2 razy.

Awatar użytkownika
dedito
Moderator
Posty: 2015
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: spotify niespełnione zależnosci

Post autor: dedito » 09 sierpnia 2017, 20:20

W kwestii tych brakujących paczek medialnych, dodaj do repozytoriów http://deb-multimedia.org/
lub może lepiej ściągnij je stamtąd (zakładając, że nie są powiązane z kolejnymi zależnościami) bo spotykam się z opiniami, że te repozytorium lubi sprawiać kłopoty.
libssl1.0.0 chwilowo nie widzę w stretchu ale jest w innych https://packages.debian.org/search?sear ... ibssl1.0.0

pawelk29
Posty: 79
Rejestracja: 29 lutego 2016, 12:51

Re: [+]spotify niespełnione zależnosci

Post autor: pawelk29 » 10 sierpnia 2017, 07:49

Pobrałem i zainstalowałem ibssl1.0.0 z neta i działą

Zablokowany