Aktualizacja FlashPlayer

Tematy związane z oprogramowaniem, instalacją, konfiguracją
tokirium
Posty: 39
Rejestracja: 02 czerwca 2016, 12:56

Aktualizacja FlashPlayer

Post autor: tokirium » 15 lutego 2017, 01:44

Od pewnego czasu nie działa instalacja oraz aktualizacja FlashPlayera w ten sposób https://wiki.debian.org/FlashPlayer#Installation

Po wpisaniu

Kod: Zaznacz cały

# update-flashplugin-nonfree --install
wyrzuca

Kod: Zaznacz cały

ERROR: wget failed to download http://people.debian.org/~bartm/flashplugin-nonfree/D5C0FC14/fp.24.0.0.221.sha512.i386.pgp.asc
More information might be available at:
  http://wiki.debian.org/FlashPlayer
root@Krzys-db:/home/krzysztof# curlftpfs ftp://tokirium:grat63a@tokirium.cba.pl /home/krzysztof/Dokumenty/ftp/ -o allow_other
Wczoraj FlashPlayer przestał działać w przeglądarce i niektóre strony nie działają poprawnie bez niego. W takiej sytuacji aktualizacja zawsze przywracała działanie, ale już nie da się w ten sposób zainstalować i nie widzę by miało coś być poprawione. Jest jakieś inne wyjście? Korzystam z przeglądarki Seamonkey.

Moderacja: Uzupełnij informacje na temat systemu i architektury.

Awatar użytkownika
Morfik
Posty: 85
Rejestracja: 21 lutego 2009, 21:00

Re: Aktualizacja FlashPlayer

Post autor: Morfik » 15 lutego 2017, 11:08

Wyjście jest.

Edit: W sumie to rozwiązanie podane w podlinkowanym wątku zostało usunięte z jakiegoś powodu (w sumie wszystkie posty użytkownikabuntu). Także ten post też można skasować. :D

Awatar użytkownika
dedito
Moderator
Posty: 1836
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Aktualizacja FlashPlayer

Post autor: dedito » 15 lutego 2017, 14:11

Nie napisałeś nic na temat wersji systemu.
Przejdź na https://get.adobe.com/pl/flashplayer/
Pobierz paczkę tar.gz
Instrukcje instalacji w pliku readme. Poniżej cytat.
Installing using the plugin tar.gz:
o Unpack the plugin tar.gz and copy the files to the appropriate location.
o Save the plugin tar.gz locally and note the location the file was saved to.
o Launch terminal and change directories to the location the file was saved to.
o Unpack the tar.gz file. Once unpacked you will see the following:
+ libflashplayer.so
+ /usr
o Identify the location of the browser plugins directory, based on your Linux distribution and Firefox version
o Copy libflashplayer.so to the appropriate browser plugins directory. At the prompt type:
+ cp libflashlayer.so <BrowserPluginsLocation>
o Copy the Flash Player Local Settings configurations files to the /usr directory. At the prompt type:
+ sudo cp -r usr/* /usr
Po polsku (wersja powyższego).
Rozpakuj pliki

Kod: Zaznacz cały

tar -zxvf plik.tar.gz
Dalsze komendy wykonuj jako root.
W przypadku seamonkey (firefox również) libflashplayer.so skopiuj do:

Kod: Zaznacz cały

cp libflashplayer.so /usr/lib/mozilla/plugins/
Skopiuj katalog usr do:

Kod: Zaznacz cały

cp -r usr/* /usr
Sprawdź czy instalacja przebiegła poprawnie wchodząc na poniższy link:
https://helpx.adobe.com/flash-player.html

Zrzut z mojego seamonkey
Obrazek

P.S. Sama strona oferuje również link apt, ale nie mam go zaimplementowanego w obsłudze przeglądarki, jak ktoś posiada to nic nie stoi (chyba) na przeszkodzie aby taki link wybrać.

Awatar użytkownika
Yampress
Administrator
Posty: 5915
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Re: Aktualizacja FlashPlayer

Post autor: Yampress » 16 lutego 2017, 17:59

A kto to tam jeszcze z tego korzysta? ten cały flasz jest wszędzie usuwany...

A nie lepiej wykorzystać pepprerflashplugin z chromium/chrome do FF czy innej przeglądarki?

Kod: Zaznacz cały

apt-get  install pepperflashplugin-nonfree  browser-plugin-freshplayer-pepperflash 

[yampress@debian ~]$ apt show browser-plugin-freshplayer-pepperflash
Package: browser-plugin-freshplayer-pepperflash
Version: 0.3.5-1+b1
Priority: optional
Section: contrib/web
Source: freshplayerplugin (0.3.5-1)
Maintainer: Vincent Danjean <vdanjean@debian.org>
Installed-Size: 1162 kB
Depends: libasound2 (>= 1.0.18), libavcodec57 (>= 7:3.2.2) | libavcodec-extra57 (>= 7:3.2.2), libavutil55 (>= 7:3.2.2), libc6 (>= 2.14), libcairo2 (>= 1.2.4), libevent-2.0-5 (>= 2.0.10-stable), libevent-pthreads-2.0-5 (>= 2.0.10-stable), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:3.0), libgl1-mesa-glx | libgl1, libglib2.0-0 (>= 2.31.18), libgtk2.0-0 (>= 2.24.0), libpango-1.0-0 (>= 1.22.0), libpangocairo-1.0-0 (>= 1.14.0), libpangoft2-1.0-0 (>= 1.14.0), libpulse0 (>= 0.99.1), libssl1.1 (>= 1.1.0), libstdc++6 (>= 5.2), libv4l-0 (>= 0.5.0), libva-x11-1 (>= 1.0.3), libva1 (>= 1.7.3), libvdpau1 (>= 0.2), libx11-6, libxcursor1 (>> 1.1.2), libxrandr2 (>= 2:1.2.0), libxrender1
Recommends: pepperflashplugin-nonfree
Homepage: https://github.com/i-rinat/freshplayerplugin
Tag: uitoolkit::gtk
Download-Size: 358 kB
APT-Manual-Installed: yes
APT-Sources: http://ftp.pl.debian.org/debian stretch/contrib amd64 Packages

Description: PPAPI-host NPAPI-plugin adapter for pepperflash
The main goal of the project is to get PPAPI (Chrome) plugins
working in Firefox (and any other web-browser supporting NPAPI plugins).
It implements a wrapper which behaves like browser to PPAPI plugin and implements NPAPI plugin interface
for browser to use.
.

This particular implementation doesn't implement any sandboxing,
which means any malicious code can break through plugin security
as there are no additional barriers. This is the same level of security as
NPAPI Flash have.
.
Flash plugin for Linux provided by adobe stopped at version 11.2; for
chrome/chromium users there is pepperflash plugin but it's not supported by
firefox/iceweasel/other browsers.
.
This package allows one to use the Pepper Flash plugin from Chrome
in NPAPI web browsers.

[yampress@debian ~]$

P.S.
też tak kiedyś dawno aktualizowałem flasha tą metodą jak dedito wcześniej napisał, ale mi się znudziła ta ciągła aktualizacja, tego "dziurawego badziewia"

Awatar użytkownika
sinplez1y1
Posty: 83
Rejestracja: 13 stycznia 2017, 23:25

Re: Aktualizacja FlashPlayer

Post autor: sinplez1y1 » 18 lutego 2017, 00:53

flash nawet na linuksie jest baaaaaaaaaaaaardzo niebezpieczny, kaganiec zakładany przez apparmor-a też niewiele daje. Jak chcesz używać flasha, proszę bardzo virtualka z lustrzanym systemem+migawki+google chrome (które chyba jako jedyne to natywnie obsługuje). Nie chcesz mieć krasnoludków w maszynie nie używasz flasha o kawie-javie to chyba już zapomnieli ale jeszcze widać desperatów..takie programistyczne to na każdym systemie zrobią krasnoludki. Trzymać się z daleka albo użyć i od razu wyrzucić upapraną migawkę na vmce ;)

Awatar użytkownika
Yampress
Administrator
Posty: 5915
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Re: Aktualizacja FlashPlayer

Post autor: Yampress » 18 lutego 2017, 17:11

jeśli nie trzeba flasha, a wystarcza html5 (youtube/inne), to nie ma sensu flasha instalować

Odpowiedz

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość