Pokaż wyniki od 1 do 6 z 6

Temat: Nie można połączyć się z siecią zabezpieczoną - Bcm4313

  1. #1

    Nie można połączyć się z siecią zabezpieczoną - Bcm4313

    Hej!
    Nie mogę połączyć się z siecią zabezpieczoną wpa2:
    Kod:
    wpa_supplicant -B -c /etc/wpa_supplicant.conf -iwlan0
    daje wynik
    Kod:
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    Po wpisaniu:
    Kod:
    wpa_supplicant -B -c /etc/wpa_supplicant.conf -iwlan0 -d
    Kod:
    random: Trying to read entropy from /dev/random
    Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
    Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
    Reading configuration file '/etc/wpa_supplicant.conf'
    ctrl_interface='/var/run/wpa_supplicant'
    Priority group 0
       id=0 ssid='moja siec'
    WEXT: cfg80211-based driver detected
    wext: interface wlan0 phy: phy0
    rfkill: initial event: idx=0 type=1 op=0 soft=0 hard=0
    rfkill: initial event: idx=1 type=1 op=0 soft=0 hard=0
    SIOCGIWRANGE: WE(compiled)=22 WE(source)=21 enc_capa=0xf
      capabilities: key_mgmt 0xf enc 0xf flags 0x0
    netlink: Operstate: linkmode=1, operstate=5
    wlan0: Own MAC address: 00:26:82:a0:22:2d
    wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=4 set_tx=0 seq_len=0 key_len=0
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    Driver did not support SIOCSIWENCODEEXT
    wpa_driver_wext_set_key: alg=0 key_idx=5 set_tx=0 seq_len=0 key_len=0
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    Driver did not support SIOCSIWENCODEEXT
    wpa_driver_wext_set_countermeasures
    wlan0: RSN: flushing PMKID list in the driver
    wlan0: Setting scan request: 0 sec 100000 usec
    WPS: Set UUID for interface wlan0
    WPS: UUID based on MAC address - hexdump(len=16): 6d 42 ef 2d 83 5a 5b f5 9e 61 c7 85 d2 a2 de f0
    EAPOL: SUPP_PAE entering state DISCONNECTED
    EAPOL: Supplicant port status: Unauthorized
    EAPOL: KEY_RX entering state NO_KEY_RECEIVE
    EAPOL: SUPP_BE entering state INITIALIZE
    EAP: EAP entering state DISABLED
    EAPOL: Supplicant port status: Unauthorized
    EAPOL: Supplicant port status: Unauthorized
    Using existing control interface directory.
    wlan0: Added interface wlan0
    Daemonize..
    Zastanawia mnie to pogrubione.


    Kod:
    cat /etc/wpa_supplicant.conf
    ctrl_interface=/var/run/wpa_supplicant
    network={ 
            ssid="moja siec" 
            key_mgmt=WPA-PSK 
            psk="moje haslo"
    }

    Kod:
    lspsci -k
    03:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
        Subsystem: Hewlett-Packard Company Device 145c
        Kernel driver in use: brcmsmac
    Kod:
    cat /etc/network/interfaces
    auto wlan0
    iface wlan0 inet dhcp
    Kod:
    iwconfig
    lo        no wireless extensions.
    
    
    wlan0     IEEE 802.11bgn  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              
    eth0      no wireless extensions.
    Kod:
    dpkg --print-architecture
    amd64
    Kod:
    uname -r
    3.2.0-2-amd64
    Kod:
    cat /etc/debian_version 
    wheezy/sid

    Przy wyłączonym WPA2 w ruterze, łączy się bez problemu. Sprawdzałem również na Windowsie i tam przy włączonych zabezpieczeniach działa, a więc to raczej nie wina sprzętu a sterownika jak mniemam.
    Tylko (panie Premierze) - co robić?
    Ostatnio edytowane przez fnmirk ; 16-09-2012 o 21:57

  2. #2
    Może powinieneś użyć własnościowego sterownika. Zobacz http://askubuntu.com/questions/59694...se-for-bcm4313

  3. #3
    Już działa. Skompilowałem po prostu wpa_supplicant stąd: http://hostap.epitest.fi/wpa_supplicant/. Wersja z repozytorium coś nie działała u mnie i non stop był ten błąd.
    Ostatnio edytowane przez fnmirk ; 16-09-2012 o 21:59

  4. #4
    Hej. Mam taką samą kartę i nie mogę się połączyć z siecią uczelnianą (eduroam), certyfikaty plus WPA2 Enterprise TLS, jak sądzisz, kompilacja wpa_supplicant rozwiąże także mój błąd? Miałem taką sytuację że się po prostu łączył w nieskończoność i co chwile wywalał okno Network Manager w GNOME. A w logach nic ciekawego nie znalazłem.
    Wszystko na stabilnym Debianie i otwartych sterownikach brcm80211.

  5. #5
    Pewnie, warto spróbować. Ja się męczyłem ze sterownikami, a wystarczyło w moim przypadku skompilować ze źródeł supplicanta i po sprawie. Teraz mogę się cieszyć bezprzewodowym internetem.

    A i odnośnie kompilacji - musiałem zainstalować z repozytorium:
    Kod:
    libssl-dev 
    libnl-dev
    bo nie chciała kompilacja działać bez tego.
    Ostatnio edytowane przez fnmirk ; 16-09-2012 o 22:00

  6. #6
    Chyba nie ruszy na stabilnym Debianie ta wersja wpa_supplicant, kompilator co chwilę zwraca błędy (kilka udało się rozwiązać). Tym bardziej, że nawet wersja z testowego (*.deb) wymaga aktualizacji połowy systemu. Być może jednak brakuje jakiejś paczki, zależności, ale nie mam pojęcia jakiej bo już wszystko prawie zainstalowałem.

    Jaką dałeś konfiguracje? Wszystkie moduły tak jak w przykładzie?

    Moje logi:
    http://wklej.org/id/777578/

    Jak wykluczę z kompilacji wszystkie sterowniki, to i tak wysypuje się na innym błędzie, więc albo brakuje jakiejś podstawowej paczki, albo trzeba zrobić aktualizację do testowej wersji Debiana.
    Ostatnio edytowane przez fnmirk ; 16-09-2012 o 22:01

Podobne wątki

  1. Odpowiedzi: 12
    Ostatni post/ autor: 21-05-2012, 18:32
  2. Odpowiedzi: 1
    Ostatni post/ autor: 07-01-2011, 10:54
  3. Odpowiedzi: 6
    Ostatni post/ autor: 23-03-2010, 09:20
  4. Nie można połączyć z siecią wifi
    By giaur in forum Sieci
    Odpowiedzi: 2
    Ostatni post/ autor: 22-12-2009, 18:30
  5. Nie można połączyć z siecią gg
    By irtomek in forum Software
    Odpowiedzi: 6
    Ostatni post/ autor: 14-07-2007, 08:57

Zakładki

Uprawnienia

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •