Pokaż wyniki od 1 do 3 z 3

Temat: Powrót do standardowej konfiguracji sterowników do karty graficznej

  1. #1

    Powrót do standardowej konfiguracji sterowników do karty graficznej

    Witam wszystkich!
    Moja karta graficzna to ATI 2600 XT, system squeeze, chciałem ją skonfigurować więc postępowałem według tego poradnika: http://camelek.wikidot.com/instalacj...a-linux-debian
    Niestety po dokonaniu powyższych zmian grafika nie działała za dobrze (co chwile pojawiały się jakieś puste pola na różnych programach). Dlatego postanowiłem chociażby powrócić do standardowej konfiguracji i wtedy nastąpił problem. Odistalowałem wszytkie fglrxy, wyrzuciłem xorg.conf, a mimo to monitor chodzi mi na niższej rozdzielczości 1600x1200 a ja musze mieć 1920x1200. W preferencjach monitora pisze "Nieznany".
    Próbowałem na różnych konfiguracjach xorg.conf ale nic to nie daje. Tu jest mój standardowy xorg wytworzony przez polecenie
    X -configure:
    Kod:
    Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/X11/misc"
        FontPath     "/usr/share/fonts/X11/cyrillic"
        FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/Type1"
        FontPath     "/usr/share/fonts/X11/100dpi"
        FontPath     "/usr/share/fonts/X11/75dpi"
        FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath     "built-ins"
    EndSection
    
    Section "Module"
        Load  "record"
        Load  "dri2"
        Load  "dbe"
        Load  "extmod"
        Load  "dri"
        Load  "glx"
    EndSection
    
    Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
    EndSection
    
    Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option        "Protocol" "auto"
        Option        "Device" "/dev/input/mice"
        Option        "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "ShadowFB"               # [<bool>]
            #Option     "Rotate"                 # <str>
            #Option     "fbdev"                  # <str>
            #Option     "debug"                  # [<bool>]
        Identifier  "Card0"
        Driver      "fbdev"
        VendorName  "ATI Technologies Inc"
        BoardName   "RV630 [Radeon HD 2600XT]"
        BusID       "PCI:2:0:0"
    EndSection
    
    Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
            Viewport   0 0
            Depth     1
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     4
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     8
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     15
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     16
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     24
        EndSubSection
    EndSection
    Ostatnio edytowane przez tomekn_85 ; 27-10-2010 o 16:50

  2. #2
    Zainstalowałem poprzez skrypt sgfxi i teraz pełna rozdzielczość już jest. Ale nie mogę otworzyć compiza:
    Kod:
    tomek:/home/tomek# compiz
    compiz (core) - Warn: SmcOpenConnection failed: None of the authentication protocols specified are supported
    Backend     : gconf
    Integration : true
    Profile     : default
    Adding plugins
    Initializing core options...done
    Initializing move options...done
    Initializing resize options...done
    Initializing place options...done
    Initializing decoration options...done
    
    (compiz-decorator:2616): GConf-CRITICAL **: gconf_client_set_string: assertion `val != NULL' failed
    Podam jeszcze mój xorg.conf
    Kod:
    Section "ServerLayout"
        Option         "AIGLX"  "on"
        Identifier     "X.org Configured"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/X11/misc"
        FontPath     "/usr/share/fonts/X11/cyrillic"
        FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/Type1"
        FontPath     "/usr/share/fonts/X11/100dpi"
        FontPath     "/usr/share/fonts/X11/75dpi"
        FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath     "built-ins"
    EndSection
    
    Section "Module"
        Load  "record"
        Load  "dri2"
        Load  "dbe"
    #    Load  "extmod"
        SubSection  "extmod"
          Option  "omit xfree86-dga"
        EndSubSection
        Load    "dri"
        Load    "glx"
    EndSection
    
    Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
    EndSection
    
    Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option        "Protocol" "auto"
        Option        "Device" "/dev/input/mice"
        Option        "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
    EndSection
    
    Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option        "VendorName" "ATI Proprietary Driver"
        Option        "ModelName" "Generic Autodetecting Monitor"
        Option        "DPMS" "true"
    EndSection
    
    Section "Device"
    
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "ShadowFB"               # [<bool>]
            #Option     "Rotate"                 # <str>
            #Option     "fbdev"                  # <str>
            #Option     "debug"                  # [<bool>]
        Identifier  "Card0"
        Driver    "fglrx"
        VendorName  "ATI Technologies Inc"
        BoardName   "RV630 [Radeon HD 2600XT]"
        BusID       "PCI:2:0:0"
    EndSection
    
    Section "Device"
        Option      "AllowGLXWithCopozite"  "true"
        Option      "RenderAccel"           "true"
        Identifier  "aticonfig-Device[0]-0"
        Driver    "fglrx"
        BusID       "PCI:2:0:0"
    EndSection
    
    Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
            Viewport   0 0
            Depth     1
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     4
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     8
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     15
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     16
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     24
        EndSubSection
    EndSection
    
    Section "Screen"
        Option     "XAANoOffscreenPixmaps"
        Option     "AddARGBGLXVisuals    "   "true"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
            Viewport   0 0
            Depth     24
        EndSubSection
    EndSection
    
    
    Section "Extensions"
        Option      "Composite"    "Enable"
    #    Option      "RENDER"    "disable"
    EndSection
    Nie mogłem znaleźć w Google więc pisze tu, dziękuje za pomoc.

  3. #3
    Dobrze, teraz już jakoś się samo naprawiło, nic nie zmieniałem a wszystko działa.
    Jedno mam tylko małe pytanie, w trybie tekstowym chciałbym mieć kolory w trybie roota.
    Na razie mam rozdzielczość 1600x1200 czyli poprawną, w trybie użytkownika mam kolory, ale jak przełączę się na konto roota to wszystko mam w 1 kolorze, jak zmienić abym miał kolory?
    Ostatnio edytowane przez fnmirk ; 05-11-2010 o 15:12

Podobne wątki

  1. Odpowiedzi: 3
    Ostatni post/ autor: 17-09-2011, 12:58
  2. Odpowiedzi: 7
    Ostatni post/ autor: 09-02-2011, 10:08
  3. Odpowiedzi: 2
    Ostatni post/ autor: 07-11-2010, 20:42
  4. instalacja sterowników do karty graficznej ATI HD4850
    By rejestracja_to_fallus in forum Desktop
    Odpowiedzi: 1
    Ostatni post/ autor: 10-08-2010, 19:29
  5. Odpowiedzi: 2
    Ostatni post/ autor: 22-11-2009, 12:53

Uprawnienia

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •