Strona 1 z 3 123 OstatniOstatni
Pokaż wyniki od 1 do 10 z 22

Temat: [+] Firefox - problem z uruchomieniem

  1. #1

    [+] Firefox - problem z uruchomieniem

    Witam.

    Firefox - problem z uruchomieniem, niestety. Zrobiłem dokładnie tak jak opisał Dworakex tutaj http://debian.linux.pl/threads/14318...fox+instalacja

    Próbowałem z wersjami: 3.5; 3.5.7; 3.6 i wszędzie ten sam problem. Po kliknięciu w ikonę przeglądarki "Aplikacje -> Internet -> FireFox... nic się kompletnie nie dzieje, żadnego komunikatu błędu, żadnej informacji, nic.

    Prosiłbym o jakąś radę albo naprowadzenie.

    Pozdrawiam.
    Ostatnio edytowane przez fnmirk ; 30-03-2010 o 20:43

  2. #2
    1. Która wersja Debiana?
    2. Uruchom gnome-terminal/konsole/xterm i tam wpisz w linii poleceń:
      Kod:
      firefox
      i zobacz, co się stanie.
    3. Czy masz zainstalowany pakiet iceweasel? Jeśli nie to nie instaluj, jeśli tak to w jakiej wersji. Jaka jest dostępna wersja Iceweasel w repozytorium?
    Ostatnio edytowane przez fnmirk ; 20-03-2010 o 19:47

  3. #3
    Odpowiedź 1.
    Kod:
    sifer:~# cat /etc/debian_version
    5.0.4
    Kod:
    sifer:~# uname -a
    Linux sifer 2.6.26-2-amd64 #1 SMP Tue Jan 12 22:12:20 UTC 2010 x86_64 GNU/Linux
    Odpowiedź 2:
    Uruchomiła się przeglądarka "Iceweasel"

    Odpowiedź 3:
    Jest zainstalowany w wersji 3.0.6-3

    Pozdrawiam.
    Ostatnio edytowane przez fnmirk ; 20-03-2010 o 20:24

  4. #4
    Cytat Napisał rodi83 Zobacz post
    Odpowiedź 2:
    Uruchomiła się przeglądarka "Iceweasel"
    To, że się uruchomiła było do przewidzenia, a w terminalu musiały pojawić się jakieś komunikaty i je należy przedstawić.

  5. #5
    Wydaje mi się, że w takiej sytuacji najlepiej dodać do
    Kod:
    /etc/apt/sources.list
    Kod:
    deb http://www.backports.org/debian/ lenny-backports main
    i zaktualizować Iceweasela (aktualnie jest dostępna wersja 3.5.8).
    No i warto dodać klucz repozytorium:
    Kod:
    wget -O - http://backports.org/debian/archive.key | apt-key add -
    Co prawda zastanawia mnie, skąd Ci się wziął aktywator Firefoxa w menu, ale szkoda na to czasu.
    Ostatnio edytowane przez tremor ; 20-03-2010 o 22:11

  6. #6
    Cytat Napisał rodi83 Zobacz post
    Zrobiłem dokładnie jak opisał Dworakex tutaj http://debian.linux.pl/threads/14318...fox+instalacja
    rodi83 prawdopodobnie jednak nie dokładnie wykonałeś instrukcje z linka który podałeś.
    Przejrzyj jeszcze raz dokładnie tą stronę szczególnie punkt 5.

    Jeśli dalej nie będzie działać Firefox, to zobacz co pokaże konsola po wykonaniu polecenia:
    Kod:
    /usr/share/firefox/firefox

  7. #7
    Ok już piszę co i jak...

    Punkt 1:

    Polecenie
    Kod:
    /usr/share/firefox/firefox
    Daje następujący wynik:
    Kod:
    /usr/share/firefox/firefox-bin: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
    Rozumiem, że brakuje biblioteki "libgtk-x11-2.0.so.0". Szukałem jej ale do Debiana nic nie znalazłem.


    Punkt 2:

    Saturno, wykonałem punkt piąty zgodnie z instrukcją i niestety zero reakcji na kliknięcie w ikonę FireFox-a.


    Punkt 3:

    Termor zrobiłem krok po kroku jak napisałeś i również nie pomogło

    Podsumowanie:


    Koniec końców nadal nie można uruchomić FireFox-a,


    PS: wersja firefoxa to 3.6 for Linux i686 mój system to
    Kod:
    Linux sifer 2.6.26-2-amd64 #1 SMP Tue Jan 12 22:12:20 UTC 2010 x86_64 GNU/Linux
    Ma ktoś jeszcze jakieś pomysły? Będę wdzięczny za pomoc.

  8. #8
    A o architekturze systemu ty nie pomyślał ?
    Problemy rozwiązujemy na forum nie na PW
    http://forum.dug.net.pl/

  9. #9
    Doinstaluj ia32-libs-gtk, może pomoże - w nim jest ta biblioteka brakująca, poza tym jak kolega wyżej pisze (może niezbyt dosadnie ) uruchamiasz 32 bitowego Firefoxa na systemie o architekturze 64 bitowej.
    Ostatnio edytowane przez grucha ; 21-03-2010 o 19:06

  10. #10
    Panowie i panie, mamy przełom. Dograłem ia32-libs-gtk jak poradził "grucha" i lisek się uruchomił. Niestety na razie nie udało mi się uruchomić żadnej strony bo zachowuje się tak jakby był w trybie offline. No ale szukam na forum, może coś znajdę.

    PS. Na pytania o architekturę odpowiem, było późno. Choć szczerze myślałem, że 32 uruchomi się bez problemu na 64 podobnie jak na Windows. Aha zapomniałem napisać, że Linuksem bawię się od niespełna 72godizn. Wcześniej tylko okazyjnie. A, że Windows już mnie znudził postanowiłem rzucić sobie kłodę pod nogi i przesiąść się na coś "nowego". Stąd całe zamieszanie bo stawiam pierwsze kroki.

    Dziękuję za pomoc, jak komuś wpadnie pomysł odnośnie tego co wyżej napisałem to będzie miło jak się podzieli rozwiązaniem.
    Ostatnio edytowane przez fnmirk ; 21-03-2010 o 20:44

Podobne wątki

  1. Problem z uruchomieniem gry
    By przemeq999 in forum Software
    Odpowiedzi: 4
    Ostatni post/ autor: 17-09-2008, 20:00
  2. AWN+KDE+problem z uruchomieniem
    By ts1990 in forum Desktop
    Odpowiedzi: 6
    Ostatni post/ autor: 28-02-2008, 18:56
  3. Problem z uruchomieniem gry.
    By Coremeil in forum Software
    Odpowiedzi: 4
    Ostatni post/ autor: 01-02-2008, 18:35
  4. bind9 - problem z uruchomieniem
    By kaul in forum Software
    Odpowiedzi: 0
    Ostatni post/ autor: 15-08-2007, 19:09
  5. problem z uruchomieniem debiana
    By fotomek69 in forum Instalacja systemu
    Odpowiedzi: 20
    Ostatni post/ autor: 30-11-2006, 21:34

Zakładki

Uprawnienia

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •