Strona 1 z 2 12 OstatniOstatni
Pokaż wyniki od 1 do 10 z 17

Temat: brak polskich znakow

  1. #1

    brak polskich znakow

    Witam,
    Zaktualizowalem, o ile dobrze pamietam xorg'a, i jak widac wcielo mi polskie znaki. Probowalem w ustawieniach xfce zmienic uklad na polski, ale jest tylko "qwertz". Ma ktos pomysl jak to naprawic?

  2. #2
    A masz w xorg.conf taki wpis:

    Kod:
    Section "InputDevice"
    
        Identifier     "Keyboard0"
        Driver         "kbd"
            Option          "CoreKeyboard"
            Option          "XkbRules"      "xorg"
            Option          "XkbModel"      "pc105"
            Option          "XkbLayout"     "pl"
    
    EndSection
    ?

  3. #3

  4. #4
    Dodalem to do xorg.conf i aktualnie wyglada on tak:
    Kod:
    Section "ServerLayout"
    	Identifier     "X.org Configured"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    	ModulePath   "/usr/lib/xorg/modules"
    	FontPath     "/usr/share/fonts/X11/misc"
    	FontPath     "/usr/share/fonts/X11/cyrillic"
    	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    	FontPath     "/usr/share/fonts/X11/Type1"
    	FontPath     "/usr/share/fonts/X11/100dpi"
    	FontPath     "/usr/share/fonts/X11/75dpi"
    	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    	FontPath     "built-ins"
    EndSection
    
    Section "Module"
    	Load  "glx"
    	Load  "dri2"
    	Load  "dbe"
    	Load  "dri"
    	Load  "extmod"
    	Load  "record"
    EndSection
    
    Section "InputDevice" 
        Identifier     "Keyboard0" 
        Driver         "kbd" 
        Option         "XkbRules" "xorg" 
        Option         "XkbModel" "pc105" 
        Option         "XkbLayout" "pl" 
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "auto"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
    	#DisplaySize	  330   250	# mm
    	Identifier   "Monitor0"
    	VendorName   "GSM"
    	ModelName    ""
    	HorizSync    30.0 - 98.0
    	VertRefresh  50.0 - 160.0
    	Option	    "DPMS"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: [i]: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "NoAccel"            	# [<bool>]
            #Option     "SWcursor"           	# [<bool>]
            #Option     "Dac6Bit"            	# [<bool>]
            #Option     "Dac8Bit"            	# [<bool>]
            #Option     "BusType"            	# [<str>]
            #Option     "CPPIOMode"          	# [<bool>]
            #Option     "CPusecTimeout"      	# [i]
            #Option     "AGPMode"            	# [i]
            #Option     "AGPFastWrite"       	# [<bool>]
            #Option     "AGPSize"            	# [i]
            #Option     "GARTSize"           	# [i]
            #Option     "RingSize"           	# [i]
            #Option     "BufferSize"         	# [i]
            #Option     "EnableDepthMoves"   	# [<bool>]
            #Option     "EnablePageFlip"     	# [<bool>]
            #Option     "NoBackBuffer"       	# [<bool>]
            #Option     "DMAForXv"           	# [<bool>]
            #Option     "FBTexPercent"       	# [i]
            #Option     "DepthBits"          	# [i]
            #Option     "PCIAPERSize"        	# [i]
            #Option     "AccelDFS"           	# [<bool>]
            #Option     "IgnoreEDID"         	# [<bool>]
            #Option     "DisplayPriority"    	# [<str>]
            #Option     "PanelSize"          	# [<str>]
            #Option     "ForceMinDotClock"   	# <freq>
            #Option     "ColorTiling"        	# [<bool>]
            #Option     "VideoKey"           	# [i]
            #Option     "RageTheatreCrystal" 	# [i]
            #Option     "RageTheatreTunerPort" 	# [i]
            #Option     "RageTheatreCompositePort" 	# [i]
            #Option     "RageTheatreSVideoPort" 	# [i]
            #Option     "TunerType"          	# [i]
            #Option     "RageTheatreMicrocPath" 	# <str>
            #Option     "RageTheatreMicrocType" 	# <str>
            #Option     "ScalerWidth"        	# [i]
            #Option     "RenderAccel"        	# [<bool>]
            #Option     "SubPixelOrder"      	# [<str>]
            #Option     "ShowCache"          	# [<bool>]
            #Option     "DynamicClocks"      	# [<bool>]
            #Option     "VGAAccess"          	# [<bool>]
            #Option     "ReverseDDC"         	# [<bool>]
            #Option     "LVDSProbePLL"       	# [<bool>]
            #Option     "AccelMethod"        	# <str>
            #Option     "DRI"                	# [<bool>]
            #Option     "ConnectorTable"     	# <str>
            #Option     "DefaultConnectorTable" 	# [<bool>]
            #Option     "DefaultTMDSPLL"     	# [<bool>]
            #Option     "TVDACLoadDetect"    	# [<bool>]
            #Option     "ForceTVOut"         	# [<bool>]
            #Option     "TVStandard"         	# <str>
            #Option     "IgnoreLidStatus"    	# [<bool>]
            #Option     "DefaultTVDACAdj"    	# [<bool>]
            #Option     "Int10"              	# [<bool>]
            #Option     "EXAVSync"           	# [<bool>]
            #Option     "ATOMTVOut"          	# [<bool>]
            #Option     "R4xxATOM"           	# [<bool>]
    	Identifier  "Card0"
    	Driver      "radeon"
    	VendorName  "ATI Technologies Inc"
    	BoardName   "RV280 [Radeon 9200 SE]"
    	BusID       "PCI:2:0:0"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    
    	EndSubSection
    EndSection
    Dodam, ze polskie litery znikly po tym jak zainstalowalem xfswitch-plugin (przelaczanie użytkowników w xfce). Dodatkowo rozdzielczosc mi sie zmienila na bardzo wysoka, niby da sie ja zmienic, ale tylko na czas jednej sesji, gdyz ustawienia nie zostaja zapisane.

    Próbowałem
    Kod:
    dpkg-reconfigure xorg.conf
    i:
    Kod:
    ]X -configure
    ale nic to nie dało. Dodam, ze w konsolach tekstowych, gdy nie sa wlaczone iksy wszystkie polskie znaki sa.

  5. #5
    Przedstaw plik:
    Kod:
    /var/log/Xorg.0.log

  6. #6
    Cytat Napisał gawomontyk
    Dodam, ze polskie litery znikly po tym jak zainstalowalem xfswitch-plugin (przelaczanie użytkowników w xfce).
    Wywal ten pakiet "xfswitch-plugin" powinno wrócić do normy.
    A "xorg.conf" przywróć do stanu przed instalacją tego "xfswitch-plugin" pakietu.

    Zastosuj "gdmflexiserver" i logujesz się na konto drugiego użytkownika, a przełączasz się między użytkownikami "Ctrl + Alt F7 F8 F9 ..." ile tam będziesz miał użytkowników.
    Pozdrawiam ;-)
    gruby
    jabber: lingruby@jabster.pl

  7. #7
    Wywalilem ten pakiet ale nic sie nie zmienilo. Xorg.0.log (duzo tego, przekracza limit znakow dla tego forum, dlatego na wklejce jest)

  8. #8
    Witaj. Ja miałem podobny problem na Xubuntu. Problem rozwiązałem uruchamiając skrypt znajdujący się w /usr/share/locales, a mianowicie:
    Kod:
    install-language-pack
    Na początku nadaj mu uprawnienia do wykonania, a później jako root:
    Kod:
     ./install-language-pack pl
    Mnie to spolonizowało XFCE. Zresetuj również system po tej operacji. Pozdrawiam

  9. #9
    Cytat Napisał Xorg.0.log
    (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
    gawomontyk, przedstaw wynik polecenia:
    Kod:
    dpkg -l | grep xorg

  10. #10
    Kod:
    $ dpkg -l | grep xorg
    ii  xorg                                 1:7.4+4                       X.Org X Window System
    ii  xorg-docs-core                       1:1.4-5                       Core documentation for the X.org X Window System
    ii  xserver-xorg                         1:7.3+18                      the X.Org X server
    ii  xserver-xorg-core                    2:1.6.5-1                     Xorg X server - core server
    ii  xserver-xorg-input-all               1:7.4+4                       the X.Org X server -- input driver metapackage
    ii  xserver-xorg-input-evdev             1:2.2.5-1                     X.Org X server -- evdev input driver
    ii  xserver-xorg-input-synaptics         1.1.2-1                       Synaptics TouchPad driver for X.Org server
    ii  xserver-xorg-input-wacom             0.8.3.2-1                     X.Org X server -- Wacom input driver
    ii  xserver-xorg-video-all               1:7.4+4                       the X.Org X server -- output driver metapackage
    ii  xserver-xorg-video-apm               1:1.2.1-2                     X.Org X server -- APM display driver
    ii  xserver-xorg-video-ark               1:0.7.1-2                     X.Org X server -- ark display driver
    ii  xserver-xorg-video-ati               1:6.12.3-1                    X.Org X server -- ATI display driver wrapper
    ii  xserver-xorg-video-chips             1:1.2.1-3                     X.Org X server -- Chips display driver
    ii  xserver-xorg-video-cirrus            1:1.3.1-1                     X.Org X server -- Cirrus display driver
    ii  xserver-xorg-video-fbdev             1:0.4.0-4                     X.Org X server -- fbdev display driver
    ii  xserver-xorg-video-i128              1:1.3.2-1                     X.Org X server -- i128 display driver
    ii  xserver-xorg-video-i740              1:1.3.0-1                     X.Org X server -- i740 display driver
    ii  xserver-xorg-video-intel             2:2.9.0-1                     X.Org X server -- Intel i8xx, i9xx display driver
    ii  xserver-xorg-video-mach64            6.8.2-1                       X.Org X server -- ATI Mach64 display driver
    ii  xserver-xorg-video-mga               1:1.4.11.dfsg-1               X.Org X server -- MGA display driver
    ii  xserver-xorg-video-neomagic          1:1.2.3-1                     X.Org X server -- Neomagic display driver
    ii  xserver-xorg-video-nv                1:2.1.14-2                    X.Org X server -- NV display driver
    ii  xserver-xorg-video-openchrome        1:0.2.903+svn741-1+b1         X.Org X server -- VIA display driver
    ii  xserver-xorg-video-r128              6.8.1-1                       X.Org X server -- ATI r128 display driver
    ii  xserver-xorg-video-radeon            1:6.12.3-1                    X.Org X server -- ATI Radeon display driver
    ii  xserver-xorg-video-radeonhd          1.2.5-1                       X.Org X server -- AMD/ATI r5xx, r6xx display driver
    ii  xserver-xorg-video-rendition         1:4.2.1-1                     X.Org X server -- Rendition display driver
    ii  xserver-xorg-video-s3                1:0.6.2-1                     X.Org X server -- legacy S3 display driver
    ii  xserver-xorg-video-s3virge           1:1.10.2-2                    X.Org X server -- S3 ViRGE display driver
    ii  xserver-xorg-video-savage            1:2.3.0-1                     X.Org X server -- Savage display driver
    ii  xserver-xorg-video-siliconmotion     1:1.7.2-1                     X.Org X server -- SiliconMotion display driver
    ii  xserver-xorg-video-sis               1:0.10.1-2                    X.Org X server -- SiS display driver
    ii  xserver-xorg-video-sisusb            1:0.9.1-1                     X.Org X server -- SiS USB display driver
    ii  xserver-xorg-video-tdfx              1:1.4.1-1                     X.Org X server -- tdfx display driver
    ii  xserver-xorg-video-trident           1:1.3.1-1                     X.Org X server -- Trident display driver
    ii  xserver-xorg-video-tseng             1:1.2.1-1                     X.Org X server -- Tseng display driver
    ii  xserver-xorg-video-v4l               0.2.0-3                       X.Org X server -- Video 4 Linux display driver
    ii  xserver-xorg-video-vesa              1:2.2.1-1                     X.Org X server -- VESA display driver
    ii  xserver-xorg-video-vmware            1:10.16.7-1                   X.Org X server -- VMware display driver
    ii  xserver-xorg-video-voodoo            1:1.2.2-1                     X.Org X server -- Voodoo display driver
    PS. jmarcin_1984, nie mam żadnego skryptu ,,install-language-pack'' na moim Debianie.

Podobne wątki

  1. [+] Brak polskich znaków
    By Nacrob in forum Software
    Odpowiedzi: 2
    Ostatni post/ autor: 20-12-2009, 13:39
  2. Brak polskich znaków na www
    By Jam_PL in forum Główne tematy
    Odpowiedzi: 6
    Ostatni post/ autor: 26-02-2009, 12:20
  3. [+] brak polskich znaków
    By ArkediuS in forum Główne tematy
    Odpowiedzi: 8
    Ostatni post/ autor: 12-08-2008, 12:02
  4. Brak polskich znakow
    By stephanek in forum Główne tematy
    Odpowiedzi: 2
    Ostatni post/ autor: 25-10-2007, 17:04
  5. [+] Brak polskich znaków
    By stephanek in forum Serwer
    Odpowiedzi: 3
    Ostatni post/ autor: 05-07-2007, 11:53

Zakładki

Uprawnienia

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •