Pokaż wyniki od 1 do 6 z 6

Temat: Napęd ATAPI zawiesza system - brak emulacji scsi?

  1. #1

    Napęd ATAPI zawiesza system - brak emulacji scsi?

    Witam.

    Mam taki problem: używam teraz Squeeze AMD64. Przytrafia mi się zawieszanie systemu przez napęd optyczny ATAPI. Objawy są takie, że nagle wszystko się zatrzymuje, kursorem da się ruszyć raz na 30 sekund, laptopa ciężko też wyłączyć; poniżej informacje o napędzie i stosowne kawałki logów:
    Kod:
    sudo dmesg | grep hda
    [    2.304159] hda: TSSTcorpCD/DVDW TS-L632D, ATAPI CD/DVD-ROM drive
    [    2.976109] hda: host max PIO5 wanted PIO255(auto-tune) selected PIO4
    [    2.976829] hda: UDMA/33 mode selected
    [    4.088050] ide-cd: hda: ATAPI 24X DVD-ROM DVD-R/RAM CD-R/RW drive, 2048kB Cache
    [    8.764084] hda_codec: Unknown model for ALC861, trying auto-probe from BIOS...
    Kod:
    sudo cat /var/log/syslog | grep hda
    Aug 22 12:08:23 feynman kernel: [ 1656.065014] hda: status timeout: status=0xd0 { Busy }
    Aug 22 12:08:23 feynman kernel: [ 1656.065021] hda: possibly failed opcode: 0xa0
    Aug 22 12:08:23 feynman kernel: [ 1656.065026] hda: Strange, packet command initiated yet DRQ isn't asserted
    Aug 22 12:08:33 feynman kernel: [ 1661.120014] hda: status timeout: status=0xd0 { Busy }
    Aug 22 12:08:33 feynman kernel: [ 1661.120021] hda: possibly failed opcode: 0xa0
    Aug 22 12:08:33 feynman kernel: [ 1661.120028] hda: drive not ready for command
    Aug 22 12:08:33 feynman kernel: [ 1666.124010] hda: status timeout: status=0xd0 { Busy }
    Aug 22 12:08:33 feynman kernel: [ 1666.124014] hda: possibly failed opcode: 0xa0
    Aug 22 12:08:33 feynman kernel: [ 1666.124017] hda: drive not ready for command
    Aug 22 12:08:38 feynman kernel: [ 1671.128011] hda: status timeout: status=0xd0 { Busy }
    Aug 22 12:08:38 feynman kernel: [ 1671.128015] hda: possibly failed opcode: 0xa0
    Aug 22 12:08:38 feynman kernel: [ 1671.128020] hda: drive not ready for command
    Aug 22 12:08:43 feynman kernel: [ 1676.132012] hda: status timeout: status=0xd0 { Busy }
    Aug 22 12:08:43 feynman kernel: [ 1676.132017] hda: possibly failed opcode: 0xa0
    Aug 22 12:08:43 feynman kernel: [ 1676.132021] hda: drive not ready for command
    Aug 22 12:09:23 feynman kernel: [ 1681.144014] hda: status timeout: status=0xd0 { Busy }
    Aug 22 12:09:23 feynman kernel: [ 1681.144021] hda: possibly failed opcode: 0xa0
    Aug 22 12:09:23 feynman kernel: [ 1681.144027] hda: drive not ready for command
    Aug 22 12:09:23 feynman kernel: [ 1686.148010] hda: status timeout: status=0xd0 { Busy }
    Aug 22 12:09:23 feynman kernel: [ 1686.148013] hda: possibly failed opcode: 0xa0
    Aug 22 12:09:23 feynman kernel: [ 1686.148017] hda: drive not ready for command
    Aug 22 12:09:23 feynman kernel: [ 1691.152009] hda: status timeout: status=0xd0 { Busy }
    Aug 22 12:09:23 feynman kernel: [ 1691.152013] hda: possibly failed opcode: 0xa0
    Aug 22 12:09:23 feynman kernel: [ 1691.152016] hda: drive not ready for command
    Aug 22 12:09:23 feynman kernel: [ 1691.152020] ide-cd: hda: weird block size 0
    Aug 22 12:09:23 feynman kernel: [ 1691.152022] ide-cd: hda: default to 2kb block size
    Przy wyłączaniu:
    Kod:
    Aug 22 12:10:28 feynman shutdown[4908]: shutting down for system reboot
    Aug 22 12:10:33 feynman kernel: [ 1786.724015] hda: status timeout: status=0xd0 { Busy }
    Aug 22 12:10:38 feynman kernel: [ 1786.724022] hda: possibly failed opcode: 0xa0
    Aug 22 12:10:38 feynman kernel: [ 1786.724029] hda: drive not ready for command
    Aug 22 12:10:38 feynman kernel: [ 1791.728014] hda: status timeout: status=0xd0 { Busy }
    Aug 22 12:10:38 feynman kernel: [ 1791.728020] hda: possibly failed opcode: 0xa0
    Aug 22 12:10:38 feynman kernel: [ 1791.728024] hda: drive not ready for command
    Aug 22 12:10:38 feynman kernel: [ 1791.728682] ACPI Exception (evregion-0422): AE_TIME, Returned by Handler for [EmbeddedControl] [20090320]
    Aug 22 12:10:38 feynman kernel: [ 1791.728704] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_.ECCM] (Node ffff880077bd3210), AE
    _TIME
    Aug 22 12:10:38 feynman kernel: [ 1791.728782] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_.RDC3] (Node ffff880077bd3fd0), AE
    _TIME
    Aug 22 12:10:43 feynman kernel: [ 1791.728836] ACPI Error (psparse-0537): Method parse/execution failed [\ECIO] (Node ffff880077bd3ed0), AE_TIME
    Aug 22 12:10:43 feynman kernel: [ 1791.728886] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.BAT0._STA] (Node ffff880077bd74b0), AE_TIME
    Aug 22 12:10:43 feynman kernel: [ 1791.728937] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.BAT0._BST] (Node ffff880077bd7470), AE_TIME
    Aug 22 12:10:43 feynman kernel: [ 1791.728996] ACPI Exception (battery-0385): AE_TIME, Evaluating _BST [20090320]
    Aug 22 12:10:43 feynman kernel: [ 1796.732013] hda: status timeout: status=0xd0 { Busy }
    Aug 22 12:10:43 feynman kernel: [ 1796.732018] hda: possibly failed opcode: 0xa0
    Aug 22 12:10:43 feynman kernel: [ 1796.732024] hda: drive not ready for command
    Aug 22 12:10:43 feynman init: Switching to runlevel: 6
    Aug 22 12:10:43 feynman acpid: client 2837[0:0] has disconnected
    Aug 22 12:10:43 feynman acpid: client 2837[0:0] has disconnected
    Aug 22 12:10:44 feynman wpa_supplicant[2774]: CTRL-EVENT-SCAN-RESULTS 
    Aug 22 12:10:51 feynman kernel: [ 1804.324022] hda: status timeout: status=0xd0 { Busy }
    Aug 22 12:10:51 feynman kernel: [ 1804.324163] hda: possibly failed opcode: 0xa0
    Aug 22 12:10:51 feynman kernel: [ 1804.324220] hda: drive not ready for command
    Tak przez chwilę i się wyłącza; zdarza się to czasem, nie wiem od czego to zależy; jeżeli czegoś brakuje (informacji) chętnie uzupełnię i proszę o pomoc.

    Czytałem kiedyś, że napędy ATAPI emulowane są jako SCSI, tutaj zostało hda; (z kolei pod Ubuntu miałem wszystkie dyski łącznie z napędem jako sd*).

    Pozdrawiam

    Edycja:
    Znalazłem plik, który stworzyłem pod Ubuntu (9.04 AMD64), zawiera on dpkg -l; są tam dwie paczki:
    Kod:
    ii  libsgutils1                                1.24-2                             Utilities for working with generic SCSI devi
    ii  sg3-utils                                  1.24-2                             Utilities for working with generic SCSI devi
    Pod Debianem nie mam ich zainstalowanych. W każdym razie pod Ubu mając dyski rozpoznawane jako sd* nie miałem tego problemu. Czy to może być rozwiązanie?
    ...I really belived that it was senseless to make anything because it would all be destroyed very soon anyway, but they didn't understand...

  2. #2
    Cytat Napisał kamil.deb
    Czy to może być rozwiązanie?
    Prawdopodobnie tak. Ubuntu domyślnie wykorzystuje sterownik libata, Debian zarówno ide jak i libata. Jak wymusić w Debianie korzystanie tylko ze sterownika libata - jeszcze nie wiem.

  3. #3
    Cytat Napisał fnmirk
    Jak wymusić w Debianie korzystanie tylko ze sterownika libata - jeszcze nie wiem.
    Skompilować samemu jądro.
    Ostatnio edytowane przez fnmirk ; 24-02-2011 o 14:39
    wolnakultura.info - Życie nie jest tylko do odczytu.

  4. #4
    panjandrum, to nie jest tak. Masz np. zainstalowanego Siduksa, który korzysta ze sterownika libata. Aktualizujesz go do Sida i system przechodzi na korzystanie ze sterownika IDE.

  5. #5
    Miałem ten sam problem i u mnie pomogła aktualizacja firmware w napędzie cd/dvd (trzeba ją zrobić pod Windowsem).

  6. #6
    Witam.

    Dziękuję za wszystkie podpowiedzi (dopiero teraz miałem czas przypomnieć sobie o tym temacie).

    Zaraz zacznę się w to zagłębiać, jeżeli znajdę rozwiązanie typowo linuksowe to się pochwalę.

    Pozdrawiam.

    Instalacji Windowsa nie przewiduję.
    ...I really belived that it was senseless to make anything because it would all be destroyed very soon anyway, but they didn't understand...

Podobne wątki

  1. brak montowania cd-romu ide i dyski scsi
    By Dominik137 in forum Hardware
    Odpowiedzi: 2
    Ostatni post/ autor: 31-10-2008, 13:23
  2. Odpowiedzi: 0
    Ostatni post/ autor: 29-09-2008, 21:43
  3. Odpowiedzi: 2
    Ostatni post/ autor: 01-03-2008, 13:36
  4. Wine zawiesza system
    By ModY_WzM in forum Software
    Odpowiedzi: 3
    Ostatni post/ autor: 23-08-2007, 19:20
  5. Kpackage zawiesza system
    By Demerzel in forum Software
    Odpowiedzi: 0
    Ostatni post/ autor: 08-07-2007, 18:13

Zakładki

Uprawnienia

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •