Pokaż wyniki od 1 do 8 z 8

Temat: [+] GeForce 8500GT Sid AMD64 błąd przy instalacji sterownika

  1. #1

    [+] GeForce 8500GT Sid AMD64 błąd przy instalacji sterownika

    Witam
    Przy próbach instalacji sterownika do karty GeForce 8500GT zawsze wyskakują mi błędy. Próbowałem iść według poradnika Kaki', jednak się nie udało, instalacja nawet nie dobiegła końca.
    Kod:
    nvidia-installer log file '/var/log/nvidia-installer.log'
    creation time: Thu Apr  9 20:25:42 2009
    installer version: 1.0.7
    
    option status:
      license pre-accepted    : false
      update                  : false
      force update            : false
      expert                  : false
      uninstall               : false
      driver info             : false
      precompiled interfaces  : true
      no ncurses color        : false
      query latest version    : false
      OpenGL header files     : true
      no questions            : false
      silent                  : false
      no recursion            : false
      no backup               : false
      kernel module only      : false
      sanity                  : false
      add this kernel         : false
      no runlevel check       : false
      no network              : false
      no ABI note             : false
      no RPMs                 : false
      no kernel module        : false
      force SELinux           : default
      no X server check       : false
      no cc version check     : false
      force tls               : (not specified)
      force compat32 tls      : (not specified)
      X install prefix        : (not specified)
      X library install path  : (not specified)
      X module install path   : (not specified)
      OpenGL install prefix   : (not specified)
      OpenGL install libdir   : (not specified)
      compat32 install chroot : (not specified)
      compat32 install prefix : (not specified)
      compat32 install libdir : (not specified)
      utility install prefix  : (not specified)
      utility install libdir  : (not specified)
      doc install prefix      : (not specified)
      kernel name             : (not specified)
      kernel include path     : (not specified)
      kernel source path      : (not specified)
      kernel output path      : (not specified)
      kernel install path     : (not specified)
      proc mount point        : /proc
      ui                      : (not specified)
      tmpdir                  : /tmp
      ftp mirror              : ftp://download.nvidia.com
      RPM file list           : (not specified)
    
    Using: nvidia-installer ncurses user interface
    -> License accepted.
    -> Installing NVIDIA driver version 180.44.
    -> No precompiled kernel interface was found to match your kernel; would you li
       ke the installer to attempt to download a kernel interface for your kernel f
       rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
    -> No precompiled kernel interface was found to match your kernel; this means
       that the installer will need to compile a new kernel interface.
    -> Performing CC sanity check with CC="cc".
    -> Performing CC version check with CC="cc".
    -> The CC version check failed:
       
       The compiler used to compile the kernel (gcc 4.1) does not exactly match the
       current compiler (gcc 4.3).  The Linux 2.6 kernel module loader rejects kern
       el modules built with a version of gcc that does not exactly match that of t
       he compiler used to build the running kernel.
       
       If you know what you are doing and want to ignore the gcc version check, sel
       ect "No" to continue installation.  Otherwise, select "Yes" to abort install
       ation, set the CC environment variable to the name of the compiler used to c
       ompile your kernel, and restart installation.  Abort now? (Answer: No)
    ERROR: Unable to find the kernel source tree for the currently running kernel. 
           Please make sure you have installed the kernel source files for your
           kernel and that they are properly configured; on Red Hat Linux systems,
           for example, be sure you have the 'kernel-source' or 'kernel-devel' RPM
           installed.  If you know the correct kernel source files are installed,
           you may specify the kernel source path with the '--kernel-source-path'
           command line option.
    ERROR: Installation has failed.  Please see the file
           '/var/log/nvidia-installer.log' for details.  You may find suggestions
           on fixing installation problems in the README available on the Linux
           driver download page at www.nvidia.com.
    linux-headers i build-essnetial instalowałem (poleceniem aptitude), próbowałem też instalacji sterownika innymi sposobami - żaden się nie udał, zawsze jakiś błąd wyskakiwał np. gdy próbowałem zainstalować z repo nvidia-glx to wyskakiwało mi coś takiego:
    Kod:
    Następujące pakiety mają NIESPE£NIONE zależności:
      nvidia-glx 
    0 pakietów aktualizowanych, 1 instalowanych, 0 do usunięcia i 47 nie aktualizowanych.
    Do pobrania 9801kB archiwów. Zajęte po rozpakowaniu: 30,8MB.
    Następujące pakiety mają niespełnione zależności:
      nvidia-glx: Wymaga: nvidia-kernel-180.29 który jest pakietem wirtualnym.
    Nie można rozwiązać problemów z zależnościami!  Rezygnacja...
    Następujące pakiety mają NIESPE£NIONE zależności:
      nvidia-glx 
    0 pakietów aktualizowanych, 1 instalowanych, 0 do usunięcia i 47 nie aktualizowanych.
    Do pobrania 9801kB archiwów. Zajęte po rozpakowaniu: 30,8MB.
    Nie udało się znaleźć rozwiązania dla tych zależności. Można spróbować uzupełnić zależności ręcznie lub wpisać "n" aby wyjść.
    Następujące pakiety mają niespełnione zależności:
      nvidia-glx: Wymaga: nvidia-kernel-180.29 który jest pakietem wirtualnym.
    Uzupełnić te zależności ręcznie? [N/+/-/_/:/?]
    I nie ważne, co bym wcisnął, to i tak pojawia się dalej ten komunikat (no, chyba, że wpiszę n, to wtedy wyłącza ten komunikat).
    Sporo googlowałem, ale nie znalazłem rozwiązania mojego problemu (może po prostu jeszcze nie umiem szukać pomocy na temat Debiana, bo do tej pory korzystałem z Windowsa Visty i jednak inaczej się szuka pomocy), a próbuję to rozwiązać już od kilku dni.

  2. #2
    Napewno posiadasz zainstalowane nagłówki do aktualnie uruchomionego jądra? Wrzuć:
    Kod:
    dpkg -l | grep linux-image-`uname -r`
    Jeśli są prawidłowe to spróbuj je przeinstalować.

  3. #3
    Po tym poleceniu mam taki komunikat:
    Kod:
     debian:/home/artur# dpkg -l | grep linux-image-`uname -r`
    ii  linux-image-2.6.26-1-amd64           2.6.26-13lenny2             Linux 2.6.26 image on AMD64
    debian:/home/artur#
    Nie wiem, czy to dobrze (jestem jeszcze dość początkujący), ale spróbowałem przeinstalować te nagłówki komendami
    Kod:
    aptitude remove linux-headers-`uname -r` 
    aptitude install linux-headers-`uname -r`
    Nie wiem, czy poprawnie, ale przy obu komendach dostawałem komunikat
    Kod:
    Nie zostaną zainstalowane, zaktualizowane ani usunięte żadne pakiety.
    0 pakietów aktualizowanych, 0 instalowanych, 0 do usunięcia i 47 nie aktualizowanych.

  4. #4
    Kod:
    aptitude remove linux-headers-2.6.26-1-amd64 
    aptitude install linux-headers-2.6.26-1-amd64
    W ten sposób.

  5. #5
    ArnVaker
    Guest
    ERROR: Unable to find the kernel source tree for the currently running kernel.
    Czyli nie masz nagłówków jądra.

    Sprawdzisz to poleceniem
    Kod:
    dpkg -l |grep linux-headers-`uname -r`
    Poleceniem
    Kod:
    dpkg -l |grep linux-image-`uname -r`
    sprawdzasz zainstalowane kernele, nie nagłówki.

    Pokaż swój sources.list
    Kod:
    cat /etc/apt/sources.list

  6. #6
    Cytat Napisał maly
    Kod:
    aptitude remove linux-headers-2.6.26-1-amd64 
    aptitude install linux-headers-2.6.26-1-amd64
    W ten sposób.
    Te polecenia dają taki sam efekt, jak te które wpisywałem (chodzi mi o to, że też pisze, o zaktualizowanych itp.)

    A co do sources.list:
    Kod:
    #~~~~~~~~~~~~~~~~~~~~~~Sid~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~#
    deb ftp://ftp.pl.debian.org/debian/ sid main non-free contrib
    deb-src ftp://ftp.pl.debian.org/debian/ sid main non-free contrib
    #~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~#
    
    deb http://volatile.debian.org/debian-volatile lenny/volatile main
    deb-src http://volatile.debian.org/debian-volatile lenny/volatile main
    
    
    deb http://people.debian.org/~rdonald/nvidia unstable nvidia-graphics-drivers
    deb http://people.debian.org/~rdonald/nvidia unstable nvidia-kernel-common
    deb http://people.debian.org/~rdonald/nvidia unstable nvidia-settings
    deb http://people.debian.org/~rdonald/nvidia unstable nvidia-xconfig
    deb http://people.debian.org/~rdonald/nvidia unstable modules

  7. #7
    ArnVaker
    Guest
    Zmień wpisy w sources.list wg tego tematu.

    Twój problem wynika z tego, że repozytoria masz z wersji niestabilnej, a używasz kernela ze stabilnej.

    W repozytoriach Sida nie ma nagłówków do tego jądra. Dodaj jeszcze wpis
    deb http://ftp.pl.debian.org/debian/ lenny main non-free contrib
    Następnie
    Kod:
    aptitude update
    a potem
    Kod:
    aptitude install linux-headers-`uname -r`

  8. #8
    Dziękuję. Wszystko działa.
    Po dodaniu tego wpisu i aktualizacji dalej poszedłem według poradnika Kaki' i wszystko pięknie się zainstalowało.
    Ps. Mimo, że mam z Debianem więcej problemów niż z Windowsem, to miło mi się jego używa - głównie dzięki takim ludziom jak Wy. Z problemem odnośnie Windowsa jeszcze nigdy nie otrzymałem tak szybko i tak fachowych odpowiedzi

Podobne wątki

  1. Odpowiedzi: 0
    Ostatni post/ autor: 08-09-2010, 16:27
  2. Odpowiedzi: 10
    Ostatni post/ autor: 01-04-2009, 14:13
  3. [+]Turion 64 X2 + Debian AMD64 -czarny ekran przy instalacji
    By czyzzz in forum Instalacja systemu
    Odpowiedzi: 4
    Ostatni post/ autor: 21-03-2009, 10:58
  4. Odpowiedzi: 2
    Ostatni post/ autor: 06-03-2009, 08:14
  5. Odpowiedzi: 0
    Ostatni post/ autor: 21-02-2009, 16:45

Zakładki

Uprawnienia

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •